Ispconfig3 Squirrelmail No Mail to Inbox

Discussion in 'Installation/Configuration' started by skinnypete, Jun 19, 2014.

  1. skinnypete

    skinnypete New Member

    Hello, when we installed ISPConfig3, we followed the tutorial for The Perfect Server all has gone well so far. The issue that we are having is we are not able to receive any emails in squirrelmail's inbox.
    We can send email to outside mailservers and outside mailservers can send mail back. Testing in MXtoolbox shows everything is good with DNS configurations and PTR.
    Mail was getting stuck in queue until we changed the mail_box_size and message_size after that we expected to see mail delivered to the inbox but no dice and not sure where to start on the trouble shooting since the mail log is empty.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check the mail.log.
     
    Last edited: Jun 19, 2014
  3. skinnypete

    skinnypete New Member

    the mail.log is empty
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux distribution do you use?
     
  5. skinnypete

    skinnypete New Member

    We are using Centos 6.5, ispconfig3 is configured for nginx.
    I have checked /var/log/maillog and it is empty
     
  6. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Did you enable "Server requires authentication." in your email client?
    What's in /etc/postfix/main.cf


    What's the output of telnet localhost 25
    ehlo localhost?
     
  7. skinnypete

    skinnypete New Member

    Let me get back to you on. I broke something :( since posting so going to reinstall dovecot and ispconfig3. Will update when the reinstall is completed.
     
  8. skinnypete

    skinnypete New Member

    Now something is really broken! I removed ISPConfig3 so as to reinstall it. Since then nginx refuses to start! (I have been running nginx for a few years now with no problems) Since the removal of ISPConfig3 I am getting the following error for nginx:
    Starting nginx: nginx: [emerg] unknown "no_cache" variable
    [FAILED]
     
  9. skinnypete

    skinnypete New Member

    Going to start this problem in a new thread.......
     
  10. skinnypete

    skinnypete New Member

    Now back to my original problem. Following "The Perfect Server" tutorial we have re-installed postfix/dovecot/squirrelmail and ispconfig3. At the end of the tutorial it says to replace dovecot's config file with one that is created by ispconfig3 using the following:

    cd /etc/dovecot
    mv dovecot.conf dovecot.conf_orig
    ln -s ../dovecot.conf dovecot.conf
    /etc/init.d/dovecot restart

    ....the problem that we are having now is once we have done this dovecot will NOT start!
     
  11. skinnypete

    skinnypete New Member

    .....copied over a configuration file that looked like it makes sense. Here is the dovecot.conf Can someone tell me if this looks right??

    listen = *,[::]
    protocols = imap pop3
    auth_mechanisms = plain login
    disable_plaintext_auth = no
    log_timestamp = "%Y-%m-%d %H:%M:%S "
    mail_privileged_group = vmail
    ssl_cert = </etc/postfix/smtpd.cert
    ssl_key = </etc/postfix/smtpd.key
    passdb {
    args = /etc/dovecot-sql.conf
    driver = sql
    }
    userdb {
    args = /etc/dovecot-sql.conf
    driver = sql
    }
    plugin {
    quota = dict:user::file:/var/vmail/%d/%n/.quotausage
    sieve=/var/vmail/%d/%n/.sieve
    }
    service auth {
    unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
    }
    unix_listener auth-userdb {
    group = vmail
    mode = 0600
    user = vmail
    }
    user = root
    }
    service imap-login {
    client_limit = 1000
    process_limit = 500
    }
    protocol imap {
    mail_plugins = quota imap_quota
    }
    protocol pop3 {
    pop3_uidl_format = %08Xu%08Xv
    mail_plugins = quota
    }
    protocol lda {
    mail_plugins = sieve quota
    postmaster_address = [email protected]
    }
     
  12. skinnypete

    skinnypete New Member

    ....here's the skinny!
    Everything is working and mail system is working beautifully!!!
    :) skinnypete is happy again!
     

Share This Page