ISPConfig3 | shared IP

Discussion in 'General' started by Hans, Apr 1, 2010.

  1. djtremors

    djtremors ISPConfig Developer ISPConfig Developer

    When NameVirtualHost is being used, Apache will try to match the servername against the vhosts that exist. When none are found, it uses the first listed.

    In debian you usually have a /etc/apache2/sites-enabled/000-default file which is your shareip site you're looking for. This has no ServerName and is usually first loaded due to the naming order it loads.

    See if you have that file and it's configured to be a non NameVirtualHost site.

    So worst case, add the sharedip vhost mentioned in the other post just before the websites includes in /etc/apache2/apache2.conf

    <vhost here>
    # Include the virtual host configurations:
    Include /etc/apache2/sites-enabled/

    this should work as it'll be the first listed and will match if no others are matched.
     
  2. bajodel

    bajodel New Member

    exactly.. this is the reason of that "particular" symlink name

    bye..

    bajodel
     
  3. Hans

    Hans Moderator ISPConfig Developer

    Nope. every single document within /etc/apache2/sites-available has a symlink to /etc/apache2/sites-enabled
    UNtil now i don't understand what's wrong, but never mind as i have a workable solution for it.

    Thanks for your help.
     
  4. dclardy

    dclardy Member

    What is the work around that you were able to get?

    Thanks.
     
  5. ressel

    ressel Member

    Hans, what is your solution?
     
  6. ressel

    ressel Member

    its working for me now :)
     
  7. keesje76

    keesje76 New Member

    Same problem, Ubuntu 10.04 LTS.
    Solution: put IP adresses in the default Vhost declaration like this:

    <VirtualHost 11.11.11.11:80 11.11.11.12:80>

    could be one ore more IP's, depending on your config.

    Works for me.

    Kees

    ----------------
    Exclusief beddengoed kopen
     
    wwhtf likes this.
  8. wwhtf

    wwhtf New Member

    @keesje76, I know you posted this a LONG time ago, but I wanted to say Thank You for your post.

    I was also experiencing the same issue trying to make the "Default"/SharedIP site appear in ISPConfig3 like it was in ISPConfig2.

    Replacing the "*" with the IP address in the default vhost fixed it.
     

Share This Page