ISPConfig3, Roundcube, Spam-Policy-Settings

Discussion in 'Plugins/Modules/Addons' started by adrastea, Aug 28, 2015.

  1. adrastea

    adrastea New Member

    Hallo all,
    I'm working with ISPConfig3, Roundcube and amavis-new. Now, I'm playing around with activating Spam-Filtering and I would like to enable the possibility for users to choose one of the given policies in the Roundcube configuration.
    But that does not work for me.
    Usually, my email user is not(!) identical with the preferred e-mail address!
    User name: [email protected]_tld
    Preferred email address: [email protected]_tld
    If I create a new account, in roundcube I change the standard email address to the preferred one at once.
    When now a user chooses a policy, e.g. "normal" for spam filtering, amavis-now does nothing.
    My experience is, that in the ISPConfig database in the table "spamfilter_users" the field "email" is filled with the user name, but not with the preferred email address.
    Because of that, amavis-new never adds a X-Spam-Header to the mails (just only the default).
    If I change the value to the email address, it works for me.
    If I add a policy to the domain only in ISPConfig, X-Spam-Headers appears also. But that would be global and this is not the goal.
    My question is, where do I have to change and what to make it possible, that a user can set a policy on its own?
    Where do I have to make changes, that the email field of the database is filled with the preferred email, that was set in Roundcube?
    Thank you very much for any hints,

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The username of an email account in ISPConfig is identical with the email address and ISPConfig uses this email address for the spamfilter. Do not manipulate the email address or you will lose some functionality as you see in your setup. If you want to have a custom username, then enable the custom username function and enter your username in the username field that appears then but don't manipulate the email address.
  3. adrastea

    adrastea New Member

    Hi, Till,

    thank you for your reply.
    I didn't manipulate the data set of the user. Sorry, if that could be misunderstood. Don't worry. I mean, I create an user with a specific username and its email, which is the same, but that is not the preferred email address. I also create an alias email address, that is redirected to the username. That's what I do.
    Because, from the internet I recognized a lot of password attacks against email addresses. So, if the username is different to the published email address, these attacks never will be successful.
    OK, now I have other problems :-/
    No possibility to change the behaviour?
    Roundcube knows the alias, as it is set as the standard identity. This should be sent to the ISPConfig database as the email address, that should be scanned. Would this be a possibility?

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The way you do it is just wrong, an alias is not intended for that. If you want an username that differs from thr mail address, then just enable the custom username function in isp config under system > interface config and enter the username into the username filed of the mailbox.
  5. adrastea

    adrastea New Member

    Yessss! That's the way, how it works! Thank you very much.
    But this only works with the email address, that is associated with the account.
    If the User has alias email addresses, this addresses are still not scanned.
    I think, the only way is to create an account for each "alias address" and delete all incoming mail by rule and redirect to the main email address. Am I right?

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can either set a spamfilter rue for the whole domain name or you comment out the line "receive_override_options = no_address_mappings" in so that the rewriting takes place before the mail goes to amavisd or you add a rule for the alias domain under spamfilter user/domain.

Share This Page