ISPConfig3+Roundcube+ispconfig_autoreply plugin

Discussion in 'Tips/Tricks/Mods' started by flyingscubakev, Aug 30, 2011.

  1. flyingscubakev

    flyingscubakev New Member HowtoForge Supporter

    HI , I hope this is the right place for this question, if not point me in the right direction.

    I have installed the perfect server for ISPConfig3, the difference being that I added roundcube for webmail. I really wanted the end user to be able to set/change their own out of office reply so I downloaded and enabled the ispconfig plugins.

    When I login to roundcube and go to settings and change my autoresponder info, the date/time fields always revert back to all zeros. If I then go into the ispconfig3 control panel and look at the autoresponder info page for that user it has Nov 30 set as the date (no time). (I can log in and out of the roundcube mail client and it always displays zeros). At this point the autoresponder seems to work (my end time has not come and gone yet).

    If I set the date and time for a user while in ispconfig control panel, it will then show the proper date/time if I log out and go back in. Also, if I log into the roundcube client as that specific user the autoresponder date/time is correct.
    Did I miss something while enabling the plugins that is not updating/setting something correctly?

    Thanks in advance.;)
     
  2. pszemaz

    pszemaz New Member

    Hi!

    The same problem.
    ISPConfig3, Debian 6, Dovecot.

    I use let's say 2 plugins (these two I'm testing now): ispconfig3_autoreply & ispconfig_forward.

    1. I set autorelpy message and dates. Data in database saved OK.
    2. I set then forward email and click SAVE.
    3. I look into database table mail_user, then I see "cc" data OK - email to forward, but autoresponder_start_date & autoresponder_end_date has been set to 0000-00-00 00:00:00

    pszemaz
     

Share This Page