ispconfig3 on centos 5.4 i386

Discussion in 'HOWTO-Related Questions' started by emetib, Mar 4, 2011.

  1. emetib

    emetib New Member

    Great tutorial!

    All is working well so far.

    So I am now here in the tutorial

    I am at the point of installing the latest ispconfig3 via ...

    While reading through the config information I realize I need a few answers to complete this install.

    I have never done this before.
    I am not clear what I should enter for ...

    Full qualified hostname (FQDN) of the server, eg server1.domain.tld []: <-- ENTER


    Organizational Unit Name (eg, section) []: <-- ENTER
    Common Name (eg, your name or your server's hostname) []: <-- ENTER
    Email Address []: <-- ENTER

    My /etc/hosts info is ...

    [[email protected] tmp]# cat /etc/hosts

    # Do not remove the following line, or various programs
    # that require network functionality will fail. centos1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6

    Which allows me to browse using this address

    Thank You in advance.
    Last edited: Mar 4, 2011
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You should not enter anything, please press just the enter key on your keyboard.
  3. emetib

    emetib New Member

    Thanks Till :)

    That sounds easy enough.

    very great

    I can now access ISPConfig 3 with
    I can't access it with

    I did change the following to my area on the install
    Country Name (2 letter code) [GB]: <-- ENTER
    State or Province Name (full name) [Berkshire]: <-- ENTER
    Locality Name (eg, city) [Newbury]: <-- ENTER


    I am not able to access
    Name: root
    Password: <password>

    Is there possibly another tutorial(s) available once I complete the ISPconfig 3 instructions?

    One that will assist me with accessing Squirrelmail and setting up an ISPconfig 3 control panel?
    Last edited: Mar 5, 2011
  4. falko

    falko Super Moderator ISPConfig Developer

    Does point to your router'S public IP address? Did you configure your router to forward port 8080 to your ISPConfig server?

    You must log in with an email address (that you set up through ISPConfig) and the appropriate password.
  5. emetib

    emetib New Member

    Thanks falko!

    having router set up now :)

    ISPconfig panel --> email --> Add New Domain --->
    server =
    domain = any domain on that needs email?
    eg: domain = and/or ( is the www needed??)
    eg: domain alias =

    IS there a good tutorial regarding the setup of ISPconfig 3 email
    and/or ISPconfig 3 control panel?
    Last edited: Mar 7, 2011
  6. falko

    falko Super Moderator ISPConfig Developer



    The www is not needed (unless you want to receive emails in the form of user@[B]www[/B]
    Yes, there's the ISPConfig 3 Manual:
  7. emetib

    emetib New Member

    Public IP

    Thanks again falko

    I'd love your assistance again regarding pointing my router to Public IP address and forwarding port 8080.

    I have only one public IP address available to me which my router is currently pointing to.

    Currently I am using it to host files on a Win 2008 server Xampp

    Godaddy hosts account.

    I then created Centos5.4 Perfect Server through remote desktop via AnzioWin-

    Now I don't want to take off line since it is hosting web sites.
    I believe that will occur IF point - to my public IP address.

    Can this be resolved by using different ports possibly
    port 80 for
    port 81 for

    port 8080 for
    port 8181 for

    Or something else so I can use both Win 2008 and this new Centos5 server?

    [[email protected] ssh]$ netstat -r
    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface * U 0 0 0 eth0 * U 0 0 0 eth0
    default UG 0 0 0 eth0
    Last edited: Mar 9, 2011
  8. falko

    falko Super Moderator ISPConfig Developer is a private IP address (the router's internal one), not a public one.

    Go to your router's status page, and it should show you the public IP.
  9. emetib

    emetib New Member

    It is not my router yet thanks for your reply!
    I'll pass your message on.

    Thanks again for all your assistance

Share This Page