ISPConfig3: Need some assistance correcting a few things.

Discussion in 'General' started by Routh, Apr 15, 2011.

  1. Routh

    Routh New Member

    Alright, before I begin; I'd like to thank the creators of HowToForge and ISPConfig3 - Your guides have allowed me to create a great intranet server that I can now use to do securely do development of my site. Since my site is non-profit and a hobby; finding an easy to use and comprehensive tutorial for setup that did not cost me an arm and a leg to get access to was crucial. I have plans to become a subscriber as soon as I can, and have already bought the manual. However, still waiting for the link to come through.

    While I wait, I need to fill a few holes in my configuration. Everything seems to work with DNS, and my site is now loading with www.routh.home; client setup and subsites work as well, and I already have a user created called amateurwriting, and the site loads under amateurwriting.routh.home as expected as well.

    I have the following problems:

    1. Despite the obvious fact that apache is up and running (no errors or problems with it restarting); Monitor claims that apache is offline. I have noticed that apache is not listening on port 80, however I am uncertain if that can be true as it clearly is responding to http requests.

    2. The MySQL server is reporting as offline as well, and it is showing in netstat -tap.

    3. When I create clients, their default account does not seem to have proper FTP access enabled. FTP recognizes the user, but rejects login with error 503.
    When a new user is created (amateurwriting-ftp for example) - FTP works perfectly, and the user is chrooted (I chose to install JailBreak) as epected. However I would like the main account to have FTP access (amateurwriting)

    I followed: The Perfect Server - Ubuntu 10.10 [ISPConfig 3]
    The Following is my netstat -tap result:

    Code:
    [email protected]:/home/routh# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      16077/amavisd (mast
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      16016/master    
    tcp        0      0 *:mysql                 *:*                     LISTEN      680/mysqld      
    tcp        0      0 localhost.localdo:spamd *:*                     LISTEN      844/spamd.pid   
    tcp        0      0 *:http-alt              *:*                     LISTEN      17637/apache2   
    tcp        0      0 *:www                   *:*                     LISTEN      17637/apache2   
    tcp        0      0 *:tproxy                *:*                     LISTEN      17637/apache2   
    tcp        0      0 webserver.routh.:domain *:*                     LISTEN      16963/named     
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      16963/named     
    tcp        0      0 *:ftp                   *:*                     LISTEN      16939/pure-ftpd (SE
    tcp        0      0 *:ssh                   *:*                     LISTEN      567/sshd        
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN      16963/named     
    tcp        0      0 *:smtp                  *:*                     LISTEN      16016/master    
    tcp        0      0 *:https                 *:*                     LISTEN      17637/apache2   
    tcp        0      0 webserver.routh.hom:ssh 192.168.0.193:34342     ESTABLISHED 15310/sshd: routh [
    tcp        0      0 localhost.localdo:37011 localhost.localdo:mysql ESTABLISHED 16806/amavisd (ch7-
    tcp        0      0 webserver.routh.hom:ssh 192.168.0.179:38043     ESTABLISHED 19646/sshd: routh [
    tcp        0      0 localhost.localdo:mysql localhost.localdo:37011 ESTABLISHED 680/mysqld      
    tcp        0      0 localhost.localdo:mysql localhost.localdo:49289 ESTABLISHED 680/mysqld      
    tcp        0      0 localhost.localdo:49289 localhost.localdo:mysql ESTABLISHED 16805/amavisd (ch8-
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      16862/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      16890/couriertcpd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      16873/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      16845/couriertcpd
    tcp6       0      0 [::]:domain             [::]:*                  LISTEN      16963/named     
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      16939/pure-ftpd (SE
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      567/sshd        
    tcp6       0      0 localhost:953           [::]:*                  LISTEN      16963/named
     
  2. Routh

    Routh New Member

    Additional Note

    I have notice that SSH access is not being enabled for clients either, like FTP a sub account must be created.
     
  3. Routh

    Routh New Member

    Oops!

    Ack, my post needs to be moved to ISPConfig3 > General ! - Sorry for the mispost moderators.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    1+2) Please check the /etc/hopsts file and ensure that it contains a vlaid line for "localhost"

    3) There is no such thing as a defualt FTP user in ispconfig 3. FTP users are virtual users in mysql only. You seem to mix up SSH users with FTP users here.
     

Share This Page