ISPConfig3 myDNS -Server Offline?

Discussion in 'Installation/Configuration' started by koltz, Feb 21, 2009.

  1. koltz

    koltz New Member

    Everything is coming together, but myDNS server isn't starting still. Under the Monitor area, it says I have one error, and that the myDNS server is offline. I go to command line and I run /etc/init.d/mydns start and it gives me

    Code:
    Starting DNS server: mydns
    But nothing that says it has started. Any ideas?
     
  2. till

    till Super Moderator

    Please post the output of:

    netstat -tap
     
  3. koltz

    koltz New Member

    Code:
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      4504/amavisd (maste
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      5142/master     
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN      4578/mysqld     
    tcp        0      0 localhost.localdo:spamd *:*                     LISTEN      4651/spamd.pid  
    tcp        0      0 *:webcache              *:*                     LISTEN      10581/apache2   
    tcp        0      0 *:www                   *:*                     LISTEN      10581/apache2   
    tcp        0      0 *:ftp                   *:*                     LISTEN      20743/pure-ftpd (SE
    tcp        0      0 server.koltz.com:domain *:*                     LISTEN      10555/mydns     
    tcp        0      0 thegamestore.us:domain  *:*                     LISTEN      10555/mydns     
    tcp        0      0 172.21.152.33:domain    *:*                     LISTEN      10555/mydns     
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      10555/mydns     
    tcp        0      0 *:smtp                  *:*                     LISTEN      5142/master     
    tcp        0      0 *:https                 *:*                     LISTEN      10581/apache2   
    tcp        0    174 server.koltz.com:smtp   190-201-221-144.d:61429 ESTABLISHED 32383/smtpd     
    tcp        0      0 localhost.localdo:48602 localhost.localdo:mysql ESTABLISHED 32343/smtpd     
    tcp        0      0 localhost.localdo:39118 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:48603 localhost.localdo:mysql ESTABLISHED 32343/smtpd     
    tcp        0      0 localhost.localdo:48598 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:48592 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:60227 localhost.localdo:mysql ESTABLISHED 13909/amavisd (ch13
    tcp        0      0 localhost.localdo:mysql localhost.localdo:60227 ESTABLISHED 4578/mysqld     
    tcp        0      0 localhost.localdo:mysql localhost.localdo:48603 ESTABLISHED 4578/mysqld     
    tcp        0      0 localhost.localdo:48596 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:48597 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:48593 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:48605 localhost.localdo:mysql ESTABLISHED 32343/smtpd     
    tcp        0      0 localhost.localdo:48604 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:39114 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:mysql localhost.localdo:48605 ESTABLISHED 4578/mysqld     
    tcp        0      0 localhost.localdo:mysql localhost.localdo:33580 ESTABLISHED 4578/mysqld     
    tcp        0      0 localhost.localdo:33580 localhost.localdo:mysql ESTABLISHED 13969/amavisd (ch12
    tcp        0      0 localhost.localdo:48594 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:48590 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 thegamestore.us:www     172.21.153.104:61894    ESTABLISHED 30303/apache2   
    tcp        0      0 localhost.localdo:48600 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:48591 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:48595 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:39116 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:39115 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:48599 localhost.localdo:mysql TIME_WAIT   -               
    tcp        0      0 localhost.localdo:48601 localhost.localdo:mysql ESTABLISHED 32343/smtpd     
    tcp        0      0 localhost.localdo:mysql localhost.localdo:48602 ESTABLISHED 4578/mysqld     
    tcp        0      0 localhost.localdo:mysql localhost.localdo:48601 ESTABLISHED 4578/mysqld     
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      5033/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      5072/couriertcpd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      5052/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      5013/couriertcpd
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      20743/pure-ftpd (SE
    tcp6       0      0 ip6-localhost:domain    [::]:*                  LISTEN      10555/mydns     
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      23019/sshd   
    
     
  4. falko

    falko Super Moderator

    MyDNS is running:

     
  5. koltz

    koltz New Member

    I saw that it was running, but why isn't it registering with ISPConfig?
     
  6. till

    till Super Moderator

    It takes a few minutes (about 5 or 10 minutes if I remember correctly) until the monitor refreshes, so you will have to wait after you started mydns.
     
  7. koltz

    koltz New Member

    It has never shown online under the ISPConfig Monitor even though it has been running. So it isn't registering with ISPConfig for some reason.
     
  8. falko

    falko Super Moderator

    What's in /etc/mydns.conf? Which distribution are you using?
     
  9. koltz

    koltz New Member

    Code:
    ## AUTOMATICALLY GENERATED BY DEBCONF. DO NOT MODIFY DATABASE
    ## INFORMATION (database, db-*)...
    ## PLEASE RUN 'dpkg-reconfigure mydns-mysql' INSTEAD.
    ## CHANGES TO THE FOLLOWING DIRECTIVES ARE NOT PRESERVED, BUT REPLACED,
    ## ON UPGRADE:
    ##  user, group, pidfile, db-*, database
    
    ##
    ##  /etc/mydns.conf
    ##  Thu Aug  2 16:36:26 2007
    ##  For more information, see mydns.conf(5).
    ##
    
    
                                    # DATABASE INFORMATION
    
    db-host = localhost             # SQL server hostname
    db-user = deletedforsecurity             # SQL server username
    db-password = deletedforsecurity         # SQL server password
    database = dbispconfig          # MyDNS database name
    
    
                                    # GENERAL OPTIONS
    
    user = nobody                   # Run with the permissions of this user
    group = nogroup                 # Run with the permissions of this group
    listen = *                      # Listen on these addresses ('*' for all)
    no-listen =                     # Do not listen on these addresses
    
    
                                    # CACHE OPTIONS
    
    zone-cache-size = 2048  # Maximum number of elements stored in the zone cache
    zone-cache-expire = 60  # Number of seconds after which cached zones expires
    reply-cache-size = 2048 # Maximum number of elements stored in the reply cache
    reply-cache-expire = 30 # Number of seconds after which cached replies expire
    
    
                                    # ESOTERICA
    
    log = LOG_DAEMON        # Facility to use for program output (LOG_*/stdout/stderr)
    pidfile = /var/run/mydns.pid    # Path to PID file
    timeout = 120   # Number of seconds after which queries time out
    multicpu = 1    # Number of CPUs installed on your system
    recursive =                     # Location of recursive resolver
    allow-axfr = yes # Should AXFR be enabled?
    allow-tcp = yes  # Should TCP be enabled?
    allow-update = no       # Should DNS UPDATE be enabled?
    ignore-minimum = no     # Ignore minimum TTL for zone?
    soa-table = dns_soa     # Name of table containing SOA records
    rr-table = dns_rr       # Name of table containing RR data
    soa-where = server_id = 1               # Extra WHERE clause for SOA queries
    rr-where =  server_id = 1               # Extra WHERE clause for RR queries
    use-soa-active = yes # To fix bug 295 where active or inactive status is ignored.
    use-rr-active = yes# To fix bug 295 where active or inactive status is ignored.
    
    
     
  10. falko

    falko Super Moderator

    Looks ok. Can you stop or kill the running MyDNS and then start it again?
     
  11. koltz

    koltz New Member

    I stopped it, verified that no mydns instances were running with netstat -tap, started it back up, ran netstat -tap again, four instances were running. Waited 10 minutes and checked in ISPConfig, still shows Offline.
     
  12. till

    till Super Moderator

    Post the content of the /etc/hosts file.
     
  13. koltz

    koltz New Member

    Code:
    
    127.0.0.1       localhost.localdomain           localhost
    172.21.152.31   server.koltz.com                server
    172.21.152.32   gamingdealz.com         www
    172.21.152.32   8bitclassics.com        www
    172.21.152.31   geekdealz.com           www
    172.21.152.31   gamecents.com           www
    172.21.152.31   hullprodj.com           www
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    
     
  14. till

    till Super Moderator

    Looks fin so far. i have no idea why the dns server shows offline on your server.
     
  15. webschiff

    webschiff New Member

    start mydns on debian xxx with ISPConfig 3

    Here is the startsequenz for installed mydns-1.2.8.26.tar.gz:
    mydns --conf=/etc/mydns.conf
    (if path of mydns.conf = /etc/mydns.conf)

    I think in prev Version can start it too

    Greeding Webschiff

    (or you can move file mydns.conf in /usr/local/sbin) and start it with

    mydns

    and mydns is online
    Remember you from ISPConfig opt-out and Internet Explorer to close to join newly then the online status.
    Create a file mydns and writing this Code purely:
    ----------------------------------------------------
    #!/bin/sh
    # MyDNS start and stop

    case "$1" in
    'start')
    /usr/local/sbin/mydns # if mydns.conf in /usr/local/sbin else /usr/local/sbin/mydns --conf=/etc/mydns.conf
    ;;
    'stop')
    ;;
    *)
    echo "Usage: $0 { start | stop }"
    ;;
    esac
    exit 0
    -----------------------------------------------
    and save it as /etc/init.d/mydns
     
    Last edited: Mar 22, 2009
  16. OvrFlote

    OvrFlote New Member

    Same Issue

    running ispconfig3 on centos 5
    recently upgraded to php 5.3 from php 5.1.6
    ran update.php per Till in another post.

    left with same issue, except mydns is not showing up in netstat -tap.

    I try starting mydns but nothing happens:

    #/etc/init.d/mydns start
    #

    I try getting status but nothing happens

    #/etc/init.d/mydns status
    #

    mydns.conf looks exactly the same as above, with an exception:

    very last line
    use-rr-active = yes # To fix bug 295 where active or inactive status is ignored.

    this just looked wrong to me, so i changed it, there was no space between yes and # originally (as seen in the above post) so in mine i inserted a space between yes and #.

    sorry, don't mean to ramble about trivial things, and sorry for double posting but I'm under the gun here. Need help badly.

    Thanks
     
  17. brayton82

    brayton82 New Member

    Same issue here with mydns not showing up in a netstat -tap so I looked in /usr/local/sbin/ and it was empty. Downloaded mydns-1.2.8.27.tar.gz, did a make dance and all is good. I also added the space between yes and the # on the last line of mydns.conf and that change did nothing.
     
  18. till

    till Super Moderator

    mydns has to be installed before ispconfig is installed. Please download ispconfig and run the update.php script and select to reconfigure services during update process.
     

Share This Page