ISPConfig3 Manual?

Discussion in 'General' started by giganet, Jun 3, 2009.

  1. giganet

    giganet New Member

    Hello group

    Just finished following the tutorial: The Perfect Server - Ubuntu 9.04 [ISPConfig 3]

    Outstanding as always with anything HTF provides....

    I am wondering if there is a manual available?
    Seems the new navigation and features are intimidating me just a wee bit.

    Immediately I am having issue with assigning an IP Address to newly added sites, the IP Address drop down is only listing an '*' or the primary server IP Address.
    In /etc/network/interfaces I have defined multiple interfaces but they are not available for some reason.

    Thank you Falko and Till very much for everything you do ;)

    Best regards
    Last edited: Jun 3, 2009
  2. Croydon

    Croydon HowtoForge Supporter


    there is no manual available, yet.
    Please try logging in as admin user and then go to System -> System -> Edit Server IP.
    There you can add IP addresses for your server(s).
  3. giganet

    giganet New Member

    Thank you very much Croydon for the reply...

    OK that dilemma is solved- now onto a new issue I found this morning...

    Edit: I have found that WebMail is now inaccessible today.
    I have added only the domain ( which hosts the server to ISPConfig3 and my web-site domain (

    I have uploaded the contents of a site which uses '.shtml' pages.
    When I attempt to view this site I receive '403 Forbidden'.

    What might be causing this situation?

    Thank you for your time and help.

    Best Regards
    Last edited: Jun 3, 2009
  4. Croydon

    Croydon HowtoForge Supporter

    I think index.shtml is not a file for DirectoryIndex.

    Edit /etc/apache2/mods-enabled/dir.conf

    DirectoryIndex index.html index.cgi index.php index.xhtml index.htm

    add the file "index.shtml" to the end of that list.
  5. giganet

    giganet New Member

    Thank you very much Croydon that did it!

    I am trying to access and the server is returning 404 Not Found.

    The only sites I have added to ISPConfig3 at this point are which is the primary server host and then which is for our web-site.

    Have you got an idea what I would check to restore access to 'webmail'?

    Thank you once again

    Best Regards
  6. Croydon

    Croydon HowtoForge Supporter

    Double check that in /var/www there is a symlink "webmail" to /usr/share/squirrelmail
    Maybe you forgot to set this (or the squirrel setup)
  7. till

    till Super Moderator

    You can access the webmail over the IP address only if you selected * for all created sites. Otherwise the sites vhost get precedence over the default vhost so you can not access webmail anymore. In this case you can e.g. make a symlink in the websites directories that point to the webmail sources or you craete a website for and then install a webmail application of your choice in this website.
  8. giganet

    giganet New Member

    Hi Croydon

    Thank you for the reply...

    I was sure to apply the symlink 'webmail' within /var/www dir during the installation / setup using the tutorial.

    I will look over Till' reply and try adding another domain to ISPConfig3 ( and then move the contents of 'webmail' into that site and see if things work that way.

    Best Regards
  9. giganet

    giganet New Member

    Hi Till

    Thank you for the reply...

    EDIT: OHHH, I see I set both sites to use '*' from the IP Address drop-down and SqirrellMail is available again!

    Please see my next posting as I am now trying to deal with something new.

    Thanking you in advance for your help Till.

    Best Regards
    Last edited: Jun 4, 2009
  10. giganet

    giganet New Member

    Hello Till

    SOLVED: I had to remove the domain from mydestination in PostFix then reload PostFix- ALL IS GREAT THANK YOU VERY MUCH!

    EDIT 2: It appears that ALL E-Mail being sent to the domain '' is seeing a response from PostFix OR ISPConfig claiming 'unknown user' at the domain

    After regaining access to SquirrellMail I logged into a users account and sent an E-Mail out to one of my Gmail accounts successfully.

    From Gmail however when I try to reply I receive an error notice:

    <[EMAIL=""][/EMAIL]>: unknown user: "usermagic"
    Final-Recipient: rfc822; [EMAIL=""][/EMAIL]
    Original-Recipient: [EMAIL=""]rfc822;[/EMAIL]
    Action: failed
    Status: 5.1.1
    Diagnostic-Code: X-Postfix; unknown user: "usermagic"

    I tailed '/var/log/mail.log' while Gmail attempted sending to the server- following is the results of that:
    Jun  3 17:47:00 giganetwireless postfix/smtpd[25291]: connect from[]
    Jun  3 17:47:01 giganetwireless postfix/trivial-rewrite[25312]: warning: do not list domain in BOTH mydestination and virtual_mailbox_domains
    Jun  3 17:47:01 giganetwireless postfix/smtpd[25291]: D3273B8C1E8:[]
    What could be the cause of this strange behaviour?

    Thank you for your suggestions.

    Best Regards
    Last edited: Jun 4, 2009
  11. till

    till Super Moderator

    Send an email with squirrelmail to your local account to find it out.
  12. giganet

    giganet New Member

    Hi Till

    Thank you very much for your replies to my questions...

    I did as you suggested by sending an E-Mail to one of my internal address' from SqirrellMail successfully.

    Have a great day

    Best Regards

Share This Page