ISPConfig3, mail issues

Discussion in 'Server Operation' started by xstnc, Nov 25, 2010.

  1. xstnc

    xstnc New Member

    Hi,
    I'm experiencing issues with e-mail on my server.
    I setup the ISPConfig3 as "usual" (by following a tutorial) and everything has worked out great!
    Untill now.......

    Mail is queing and log is filling with:

    Nov 24 21:44:31 hostname amavis[14441]: (14441-04) (!!)TROUBLE in check_mail: parts_decode_ext FAILED: file(1) utility (/usr/bin/file) error: run_command (open pipe): Can't fork at /usr/lib/perl/5.10/IO/File.pm line 66. at /usr/sbin/amavisd-new line 2892.

    Any pointers on this one?
     
  2. falko

    falko Super Moderator

    Please try to restart amavisd.
     
  3. xstnc

    xstnc New Member

    I've tried this several times.
    It keeps crashing, and I have to get it up and running again.
    Installed Monit to do the restarting aswell.

    Why does this happen?

    I think I solved it by rebooting the entire server....
     
  4. abintipl

    abintipl New Member

    Mail Problem

    Hi,

    I have installed ISPconfig 3 as per instructions/ script given in the forums & have also downloaded ISpconfig manual

    I am able to add user, domain , site ftp etc etc but Not able to send or receive Emails.

    When I created first email account I did receive Welcome Email on Account creation

    I had sent One Email from another account of mine to the Account I created on ISpconfig

    Ist Email was received but after that I am not able to send or recieve emails

    Please advice

    Thanks

    Abin
     
  5. xstnc

    xstnc New Member


    Does the mail que, or do you see anything special in your logs?
     
  6. abintipl

    abintipl New Member

    Error Log

    Following is from Error File I could find on Monitoring

    COuld you please advice what all chnages to be made in postfix/main.cf, I mean which all lines I should uncomment

    Your advice would be highly appreciated.

    Thanks

    Nov 26 14:10:05 isp postfix/master[20694]: warning: process /usr/libexec/postfix/smtpd pid 23379 exit status 1
    Nov 26 14:10:05 isp postfix/master[20694]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Nov 26 14:13:23 isp clamd[841]: SelfCheck: Database status OK.
    Nov 26 14:15:02 isp dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Nov 26 14:15:02 isp dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Nov 26 14:15:03 isp postfix/smtpd[23534]: connect from localhost[127.0.0.1]
    Nov 26 14:15:03 isp postfix/smtpd[23534]: fatal: non-null host address bits in "1xx.xx.xx.xx/8", perhaps you should use "1xx.0.0.0/8" instead
    Nov 26 14:15:04 isp postfix/master[20694]: warning: process /usr/libexec/postfix/smtpd pid 23534 exit status 1
    Nov 26 14:15:04 isp postfix/master[20694]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Nov 26 14:18:38 isp clamd.amavisd[13308]: SelfCheck: Database status OK.
    Nov 26 14:20:03 isp dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Nov 26 14:20:03 isp dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Nov 26 14:20:03 isp postfix/smtpd[23689]: connect from localhost[127.0.0.1]
    Nov 26 14:20:03 isp postfix/smtpd[23689]: fatal: non-null host address bits in "1xx.xx.xx.1xx/8", perhaps you should use "1xx.0.0.0/8" instead
    Nov 26 14:20:04 isp postfix/master[20694]: warning: process /usr/libexec/postfix/smtpd pid 23689 exit status 1
     
  7. falko

    falko Super Moderator

    Can you post your /etc/postfix/main.cf here?
     
  8. abintipl

    abintipl New Member

    Main cf

    Dear Sir,

    I have made some changes in main.cf The changes I made was as under

    I have uncommented
    myhostname = isp.mydomain.com & have changed name of the Domain
    mydomain = mydomain.com
    myorigin = $myhostname
    myorigin = $mydomain
    inet_interfaces = all
    mynetworks = xxx.xxx.xxx.xxx, 127.0.0.0/8

    Further, xxx.xxx.xxx.xxx is my public IP address

    Thanks for your kind support
     
  9. till

    till Super Moderator

    The mailsystem will not work if you use a domainYou have to change:

    mydomain = mydomain.com

    to:

    mydomain = isp.mydomain.com

    and restart postfix. You can not use a domain as mydomain or myhostname in a postfix virtual setup that is used for email accounts.
     
  10. abintipl

    abintipl New Member

    Reply

    Sir,

    I did as per your recommendations but didn't work

    My Further question is as under;

    I have installed ISP config on Cloud server as per shell script given on your forum thread #

    http://www.howtoforge.com/forums/showthread.php?t=47166

    http://www.howtoforge.com/forums/showthread.php?t=47167

    Then I created Client , Email account, DNS(Manual) as per instructions given in your Manual.

    My request is if you can provide the following

    1. Settings on Postfix to be done ( which all files to be edited/uncommented like main.cf or any other file
    2. Some Documentation to make any other changes to make trouble free working of the server

    I would really appreciate your advice

    Thanks

    Abin
     
  11. falko

    falko Super Moderator

    Either use
    Code:
    mynetworks = 127.0.0.0/8
    or
    Code:
    mynetworks = xxx.xxx.xxx.xxx/32, 127.0.0.0/8
     
  12. abintipl

    abintipl New Member

    Email

    Hello,

    Finally, I am able to send Outgoing emails

    let us say

    sales@mydomain.com to sales@yourdomain.com

    When Yourdomain.com replies to sales@mydomain.com its getting bounced back & the error is as under;

    "Name service error for
    name=isp.xxx.com type=AAAA: Host not found"

    I am trying to configure DNS manually & have updated with A , Cname & MX records

    Please advice

    Thanks
     
  13. abintipl

    abintipl New Member

    Email

    Hello,

    Finally, I am able to send & receive emails

    Its working fine

    Thanks a ton for you help & support

    Abin
     
  14. abintipl

    abintipl New Member

    .Co Domain

    Hello,

    I have installed ISpconfig 3 on one server & able to send / receive emails

    Now I am trying to build another server using .co domain

    I have uncommented the following
    myhostname = mydomain.co & have changed name of the Domain
    mydomain = mydomain.co
    myorigin = $myhostname
    myorigin = $mydomain
    inet_interfaces = all
    mynetworks = 127.0.0.0/8 [::1]/128

    then

    service postfix restart

    after that if I update php update.php everything works fine but following error coming

    [Tue Nov 30 14:17:43 2010] [warn] module suphp_module is already loaded, skippin
    g
    httpd: Could not reliably determine the server's fully qualified domain name, us
    ing xxx.co for ServerName
    [Tue Nov 30 14:17:44 2010] [warn] NameVirtualHost *:443 has no VirtualHosts
    Starting httpd: [ OK ]
    Stopping pure-ftpd: [ OK ]
    Starting pure-ftpd: [ OK ]
    Update finished.

    Then If I check Main,cf again my hostname is being changed from

    xxx.co
    to
    xxx

    Further, I am able to send/receive emails to Gmail but to other domains I am getting the following error


    550
    Access denied - Invalid HELO name (See RFC2821 4.1.1.1) (in reply to MAIL
    FROM command)

    Please advice

    Thanks & regards,

    Abin
     
  15. falko

    falko Super Moderator

    What are the outputs of
    Code:
    hostname
    and
    Code:
    hostname -f
    ? What's in /etc/hosts?
     
  16. abintipl

    abintipl New Member

    answer

    Hello Sir,

    The outputs are as under;

    [root@gxl ~]# hostname
    gxl.co

    [root@gxl ~]# hostname -f
    gxl

    vi /etc/hosts

    127.0.0.1 localhost localhost.localdomain
    1xx.1xx.2xx.1xx gxl gxl.co

    Thanks

    Abin
     
  17. falko

    falko Super Moderator

    Which distribution do you use?
     
  18. abintipl

    abintipl New Member

    Fedora

    Dear Sir,

    Fedora 13 on 86x64 server

    regards,

    Abin
     
  19. falko

    falko Super Moderator

    Please run
    Code:
    system-config-network 
    and set an FQDN as your hostname (e.g. server1.gxl.co; make sure the FQDN exists in DNS).
     

Share This Page