ISPConfig3+ISPConfig2= problem

Discussion in 'General' started by bolt, Jul 17, 2009.

  1. bolt

    bolt New Member

    Hello everyone!
    Immediately I'm sorry for my English, I from Ukraine...

    I have problem with ISPConfig 3 which was installed by manual from http://www.howtoforge.org/perfect-server-centos-5.2-ispconfig-3

    Install without any problems, but when i try configure ISPConfig 3 as primary and ISPC2 as secondary I have problems:

    AXFR not work on MyDNS.

    MyDNS config:
    Code:
    [[email protected] ~]# cat /etc/mydns.conf
    
                                    # DATABASE INFORMATION
    
    db-host = localhost             # SQL server hostname
    db-user = ispconfig             # SQL server username
    db-password = superpass         # SQL server password
    database = dbispconfig          # MyDNS database name
    
    
                                    # GENERAL OPTIONS
    
    user = nobody                   # Run with the permissions of this user
    group = nogroup                 # Run with the permissions of this group
    listen = *           # Listen on these addresses ('*' for all)
    no-listen =                     # Do not listen on these addresses
    
    
                                    # CACHE OPTIONS
    
    zone-cache-size = 2048  # Maximum number of elements stored in the zone cache
    zone-cache-expire = 60  # Number of seconds after which cached zones expires
    reply-cache-size = 2048 # Maximum number of elements stored in the reply cache
    reply-cache-expire = 30 # Number of seconds after which cached replies expire
    
    
                                    # ESOTERICA
    
    log = LOG_LOCAL0        # Facility to use for program output (LOG_*/stdout/stderr)
    pidfile = /var/run/mydns.pid    # Path to PID file
    timeout = 120   # Number of seconds after which queries time out
    multicpu = 1    # Number of CPUs installed on your system
    recursive =                     # Location of recursive resolver
    allow-axfr = yes # Should AXFR be enabled?
    allow-tcp = yes  # Should TCP be enabled?
    allow-update = yes       # Should DNS UPDATE be enabled?
    ignore-minimum = no     # Ignore minimum TTL for zone?
    soa-table = dns_soa     # Name of table containing SOA records
    rr-table = dns_rr       # Name of table containing RR data
    soa-where = server_id = 1               # Extra WHERE clause for SOA queries
    rr-where =  server_id = 1               # Extra WHERE clause for RR queries
    use-soa-active = yes # To fix bug 295 where active or inactive status is ignored.
    use-rr-active = yes# To fix bug 295 where active or inactive status is ignored.
    Code:
    [[email protected] ~]# mydns -v
    mydns[32239]: AXFR is enabled
    mydns[32239]: TCP ports are enabled
    mydns[32239]: DNS UPDATE is enabled
    mydns[32239]: DNS NOTIFY is not enabled
    mydns[32239]: DNS IXFR is enabled
    mydns[32239]: optional 'xfer' column found in 'dns_soa' table
    mydns[32239]: optional 'stamp' column found in 'dns_rr' table
    mydns[32239]: optional 'serial' column found in 'dns_rr' table
    mydns[32239]: ipv4_listerner: bind on socket 6 (TCP) failed: 127.0.0.1+53: Адрес уже используется
    
    In Named log from ISPConfig2:

    Code:
    Jul 17 09:40:58 ns1 named[22351]: zone xxx.xxx.ua/IN: refresh: unexpected rcode (REFUSED) from master 10.10.10.111#53 (source 0.0.0.0#0)
    Jul 17 09:40:58 ns1 named[22351]: zone xxx.xxx.ua/IN: Transfer started.
    Jul 17 09:40:58 ns1 named[22351]: transfer of 'xxx.xxx.ua/IN' from 10.10.10.111#53: connected using 10.10.10.1#39498
    Jul 17 09:40:58 ns1 named[22351]: transfer of 'xxx.xxx.ua/IN' from 10.10.10.111#53: failed while receiving responses: REFUSED
    Jul 17 09:40:58 ns1 named[22351]: transfer of 'xxx.xxx.ua/IN' from 10.10.10.111#53: end of transfer
    

    port 53 is open and listening MyDNS (iptables is off)
    At the same time ISPConfig2+ISPConfig2 work fine.

    How can I make them work? What am I doing wrong?

    PS The thread was written using http://translate.google.com
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which mydns-ng version do you have installed?
     
  3. bolt

    bolt New Member

    possibly latest:
     
    Last edited: Jul 17, 2009
  4. bolt

    bolt New Member

    any ideas? :(
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you enter the IP address of the target server in the axfr field of the zone?
     
  6. bolt

    bolt New Member

    Yes, i did..
     
    Last edited: Jul 20, 2009

Share This Page