ispconfig3 interface doesn't open

Discussion in 'General' started by iamshahid, Jan 9, 2013.

  1. iamshahid

    iamshahid New Member

    Hi everybody
    I guess I've a very small problem lying somewhere.
    My primary domain is https://zaawi.co.uk and I installed ispconfig3 on port 8080, https://zaawi.co.uk:8080/
    It was working for last 4-5 months and suddenly stopped working. The problem is only in interface doesn't open and shows 'page not available error'

    My hosted domains are working fine and I can access database using ssh and files using sftp.

    Can anybody help me with this?

    Please let me know if I need to provide more information.

    Kind reagards
    Shahid
     
  2. till

    till Super Moderator

    Please post the exact error.message from apache error.log. Did you edit any apache config files or did you install any apache modules since you accessed ispconfig the last time sucessfully?
     
  3. iamshahid

    iamshahid New Member

    Hi, Thanks for your reply.
    I actually don't get any error on error.log
    I haven't edit any apache config files at all for a while.
    However, when the interface stopped working, I tried to access using ssh and saw that 46 packages can be updated. and 31 updates are security updates.
    I tried to update the server and It didn't update either (if the problem is relevant somehow).

    As I said, my domains are working fine and I can access the database too.

    Please let me know If I can provide more information

    Thanks
     
  4. till

    till Super Moderator

    Thats quite unusual and might be related. Which errors did you get when you tried to install the updates?
     
  5. iamshahid

    iamshahid New Member

    When I login using ssh,
    Linux server1.zaawi.co.uk 3.6.5-linode47 #1 SMP Sun Nov 4 12:51:35 EST 2012 i686 GNU/Linux
    Ubuntu 10.04.4 LTS

    Welcome to Ubuntu!
    * Documentation: https://help.ubuntu.com/

    49 packages can be updated.
    34 updates are security updates.


    Then
    root@server1:~# sudo apt-get update
    Get:1 http://security.ubuntu.com lucid-security Release.gpg [198B]
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
    Get:2 http://security.ubuntu.com lucid-security Release [57.3kB]
    Get:3 http://security.ubuntu.com lucid-security/main Packages [469kB]
    Get:4 http://security.ubuntu.com lucid-security/restricted Packages [2,867B]
    Get:5 http://security.ubuntu.com lucid-security/main Sources [133kB]
    Get:6 http://security.ubuntu.com lucid-security/restricted Sources [1,267B]
    Get:7 http://security.ubuntu.com lucid-security/universe Packages [140kB]
    Get:8 http://security.ubuntu.com lucid-security/universe Sources [43.4kB]
    Hit http://us.archive.ubuntu.com lucid Release.gpg
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
    Hit http://us.archive.ubuntu.com lucid-updates Release.gpg
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_US
    Get:9 http://security.ubuntu.com lucid-security/multiverse Packages [5,360B]
    Get:10 http://security.ubuntu.com lucid-security/multiverse Sources [2,337B]
    Hit http://us.archive.ubuntu.com lucid Release
    Hit http://us.archive.ubuntu.com lucid-updates Release
    Hit http://us.archive.ubuntu.com lucid/main Packages
    Hit http://us.archive.ubuntu.com lucid/restricted Packages
    Hit http://us.archive.ubuntu.com lucid/main Sources
    Hit http://us.archive.ubuntu.com lucid/restricted Sources
    Hit http://us.archive.ubuntu.com lucid/universe Packages
    Hit http://us.archive.ubuntu.com lucid/universe Sources
    Hit http://us.archive.ubuntu.com lucid/multiverse Packages
    Hit http://us.archive.ubuntu.com lucid/multiverse Sources
    Hit http://us.archive.ubuntu.com lucid-updates/main Packages
    Hit http://us.archive.ubuntu.com lucid-updates/restricted Packages
    Hit http://us.archive.ubuntu.com lucid-updates/main Sources
    Hit http://us.archive.ubuntu.com lucid-updates/restricted Sources
    Hit http://us.archive.ubuntu.com lucid-updates/universe Packages
    Hit http://us.archive.ubuntu.com lucid-updates/universe Sources
    Hit http://us.archive.ubuntu.com lucid-updates/multiverse Packages
    Hit http://us.archive.ubuntu.com lucid-updates/multiverse Sources
    Fetched 855kB in 0s (1,366kB/s)
    Reading package lists... Done


    And when try to upgrade
    root@server1:~# sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be upgraded:
    apache2 apache2-doc apache2-mpm-prefork apache2-suexec apache2-utils apache2.2-bin apache2.2-common gnupg gnupg-curl gpgv icedtea-6-jre-cacao icedtea-netx libc-bin libc-dev-bin libc6 libc6-dev libc6-i686 libcap2 libcups2 libcupsimage2 libglib2.0-0 libmysqlclient16
    libperl5.10 libpq5 libproxy0 libtiff4 libxml2 linux-libc-dev lsb-base lsb-release mysql-client mysql-client-5.1 mysql-client-core-5.1 mysql-common mysql-server mysql-server-5.1 mysql-server-core-5.1 openjdk-6-jdk openjdk-6-jre openjdk-6-jre-headless
    openjdk-6-jre-lib perl perl-base perl-modules sudo vim vim-common vim-nox vim-runtime
    49 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 2,219kB/105MB of archives.
    After this operation, 221kB disk space will be freed.
    Do you want to continue [Y/n]? y
    Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main linux-libc-dev 2.6.32-45.102 [865kB]
    Get:2 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main gpgv 1.4.10-2ubuntu1.2 [206kB]
    Get:3 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main gnupg 1.4.10-2ubuntu1.2 [1,073kB]
    Get:4 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main gnupg-curl 1.4.10-2ubuntu1.2 [75.5kB]
    Fetched 2,219kB in 2s (1,039kB/s)
    Reading changelogs... Done

    apache2 (2.2.15-1) unstable; urgency=low

    * This release adds and enables mod_reqtimeout, which limits the time
    Apache waits for a client to send a complete request. This helps to
    mitigate against certain denial of service attacks. In case of problems
    with slow clients, the timeout values can be adjusted in
    /etc/apache2/mods-available/reqtimeout.conf , or the module can be
    disabled with "a2dismod reqtimeout".

    -- Chuck Short <zulcss@ubuntu.com> Tue, 13 Apr 2010 09:09:34 -0400

    /tmp/tmprTlrQ6 (END) at this point I can't do anything else, I have to quit it and open cmd again


    as per the warning used 'a2dismod reqtimeout' to disable timeout update things.

    When I login again I see that same message

    Linux server1.zaawi.co.uk 3.6.5-linode47 #1 SMP Sun Nov 4 12:51:35 EST 2012 i686 GNU/Linux
    Ubuntu 10.04.4 LTS

    Welcome to Ubuntu!
    * Documentation: https://help.ubuntu.com/

    49 packages can be updated.
    34 updates are security updates.



    Please let me know if I can give you more details

    Regards
     
  6. falko

    falko Super Moderator

    What's the output of
    Code:
    netstat -tap
    ? Have you tried to restart Apache?
     
  7. iamshahid

    iamshahid New Member

    Hi Falko
    The output for netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdo:10023 *:* LISTEN 2292/postgrey.pid -
    tcp 0 0 localhost.localdo:10024 *:* LISTEN 2282/amavisd (maste
    tcp 0 0 *:9001 *:* LISTEN 2973/perl
    tcp 0 0 localhost.localdo:10025 *:* LISTEN 2838/master
    tcp 0 0 *:mysql *:* LISTEN 2094/mysqld
    tcp 0 0 localhost.localdo:spamd *:* LISTEN 2297/spamd.pid
    tcp 0 0 *:ftp *:* LISTEN 2851/pure-ftpd (SER
    tcp 0 0 server1.zaawi.co:domain *:* LISTEN 2118/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 2118/named
    tcp 0 0 *:ssh *:* LISTEN 2225/sshd
    tcp 0 0 *:smtp *:* LISTEN 2838/master
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 2118/named
    tcp 1 0 localhost.localdo:46722 localhost.localdo:mysql CLOSE_WAIT 2298/amavisd (ch6-a
    tcp 1 0 localhost.localdo:46720 localhost.localdo:mysql CLOSE_WAIT 2299/amavisd (ch6-a
    tcp 0 240 server1.zaawi.co.uk:ssh 78-105-75-232.zon:58051 ESTABLISHED 859/0
    tcp6 0 0 [::]:imaps [::]:* LISTEN 2713/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 2747/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 2727/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 2693/couriertcpd
    tcp6 0 0 [::]:http-alt [::]:* LISTEN 4636/apache2
    tcp6 0 0 [::]:www [::]:* LISTEN 4636/apache2
    tcp6 0 0 [::]:tproxy [::]:* LISTEN 4636/apache2
    tcp6 0 0 [::]:ftp [::]:* LISTEN 2851/pure-ftpd (SER
    tcp6 0 0 [::]:domain [::]:* LISTEN 2118/named
    tcp6 0 0 [::]:ssh [::]:* LISTEN 2225/sshd
    tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 2118/named
    tcp6 0 0 [::]:https [::]:* LISTEN 4636/apache2


    When I restart apache

    * Restarting web server apache2 [Fri Jan 11 15:58:04 2013] [warn] NameVirtualHost 178.79.190.228:443 has no VirtualHosts
    ... waiting [Fri Jan 11 15:58:05 2013] [warn] NameVirtualHost 178.79.190.228:443 has no VirtualHosts
    [ OK ]


    These warning are there from the beginning.
    Basically, I manually setup the server at first including commercial ssl installation from go daddy.
    Then we decided to have a control panel and bought support from ispconfig to install ispconfig3.

    Since then these warnings are there but interface was working (so I didn't bother) as I mentioned and only stopped 4/5 days ago.

    Please let me know if you need more info.

    Many Thanks
     
  8. falko

    falko Super Moderator

    According to the netstat output, Apache is listening on port 8080, so ISPConfig should load:

    Code:
    tcp6 0 0 [::]:http-alt [::]:* LISTEN 4636/apache2 
    Did you check the Apache logs?
     
  9. iamshahid

    iamshahid New Member

    Well these lines are repeating there (possibly needs update)

    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cgi/conf.d/imagick.ini on line 1 in Unknown on line 0
    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cgi/conf.d/imap.ini on line 1 in Unknown on line 0
    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cgi/conf.d/mcrypt.ini on line 1 in Unknown on line 0


    Does this line sense anything
    [Sun Jan 13 05:31:43 2013] [notice] mod_fcgid: call /var/www/zaawi.co.uk/web/index.php with wrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter


    I checked
    /var/log/apache2/error.log
    and didn't see anything else particular

    on
    /var/log/apache2/access.log
    there are so many entries of following line

    127.0.0.1 - - [13/Jan/2013:22:00:02 +0000] "GET / HTTP/1.1" 200 453 "-" "Mozilla/5.0 (ISPConfig monitor)"


    Thanks
     
: 8080, ispconfig3, ssl

Share This Page