ISPConfig3 Installed/But My Mail Client is rejecting addresses

Discussion in 'Installation/Configuration' started by LinuxGuyMT, Dec 7, 2009.

  1. LinuxGuyMT

    LinuxGuyMT New Member

    Hello,

    I have finished installing ISPconfig3, but my mail server is rejecting addresses when I try to send test email. Can any one please possibly walk me through the steps to properly setup a email account in ISPconfig3 and possibly tell me if I am doing something wrong?


    Thanks,
    LinuxGuyMT
     
  2. Mark_NL

    Mark_NL New Member

    Can you check the /var/log/mail.* files and see if there are errors in it?
     
  3. LinuxGuyMT

    LinuxGuyMT New Member

    /var/log/mail.*

    Here's the Log's There seems to be maximum connection errors and a alot of them:
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:35 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:35 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:35 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:35 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:35 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:35 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:35 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:35 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:35 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:36 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:36 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:31 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:31 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:31 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:31 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:31 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:32 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:32 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:32 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:32 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:32 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:32 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:32 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:33 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:33 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:33 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:33 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:33 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:33 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:33 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:33 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Which distribution do you use?
    Which tutorial (URL) did you use to set the system up?
     
  5. LinuxGuyMT

    LinuxGuyMT New Member

  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The log looks a bit strange. Is 213.177.138.57 the IP of your server or workstation?
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you post the output of
    Code:
    netstat -tap
    ?
     
  8. LinuxGuyMT

    LinuxGuyMT New Member

    Sure here is the results of that :
    login as: root
    root@69.146.9.84's password:
    Linux server1.candyhostinghub.net 2.6.26-2-686 #1 SMP Wed Nov 4 20:45:37 UTC 2009 i686

    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.

    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Sun Dec 13 21:42:53 2009
    server1:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdo:10024 *:* LISTEN 1832/amavisd (maste
    tcp 0 0 localhost.localdo:10025 *:* LISTEN 2590/master
    tcp 0 0 *:mysql *:* LISTEN 1896/mysqld
    tcp 0 0 localhost.localdo:spamd *:* LISTEN 2008/spamd.pid
    tcp 0 0 *:sunrpc *:* LISTEN 1586/portmap
    tcp 0 0 localhost.localdoma:692 *:* LISTEN 2636/famd
    tcp 0 0 *:ftp *:* LISTEN 2604/pure-ftpd (SER
    tcp 0 0 server1.candyhos:domain *:* LISTEN 2518/mydns
    tcp 0 0 localhost.locald:domain *:* LISTEN 2518/mydns
    tcp 0 0 *:34805 *:* LISTEN 1597/rpc.statd
    tcp 0 0 *:ssh *:* LISTEN 1804/sshd
    tcp 0 0 *:smtp *:* LISTEN 2590/master
    tcp 0 148 server1.candyhostin:ssh host-69-146-9-83.s:2522 ESTABLISHED 26541/0
    tcp 0 0 localhost.localdo:mysql localhost.localdo:54787 ESTABLISHED 1896/mysqld
    tcp 64 0 localhost.localdo:32872 localhost.localdo:10025 CLOSE_WAIT 2352/amavisd (ch1-a
    tcp 0 0 localhost.localdo:54787 localhost.localdo:mysql ESTABLISHED 2352/amavisd (ch1-a
    tcp6 0 0 [::]:imaps [::]:* LISTEN 2495/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 2513/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 2501/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 2483/couriertcpd
    tcp6 0 0 [::]:http-alt [::]:* LISTEN 2695/apache2
    tcp6 0 0 [::]:www [::]:* LISTEN 2695/apache2
    tcp6 0 0 [::]:ftp [::]:* LISTEN 2604/pure-ftpd (SER
    tcp6 0 0 localhost:domain [::]:* LISTEN 2518/mydns
    tcp6 0 0 [::]:ssh [::]:* LISTEN 1804/sshd
    tcp6 0 0 [::]:https [::]:* LISTEN 2695/apache2

    as for my IP to my server, no that is not my IP address...
     
  9. Mark_NL

    Mark_NL New Member

    check /etc/courier/pop3d

    ##NAME: MAXPERIP:4
    #
    # Maximum number of connections to accept from the same IP address

    MAXPERIP=?

    what's that "?" value in your file?
     
  10. LinuxGuyMT

    LinuxGuyMT New Member

    The Following MaxperIp is as follows as pasted below:


    ##NAME: MAXPERIP:4
    #
    # Maximum number of connections to accept from the same IP address

    MAXPERIP=4

    This is directly from my servers Config file, Please advise further on how to fix.


    Thank You,
    LinuxGuyMT
     
  11. Mark_NL

    Mark_NL New Member

    I count 8 connections from the same IP within 1 second when it started to throw this error, that's more then 4 ;-)

    Why so many connections from the same ip at once? Are you collecting pop boxes batchwise or something?

    Code:
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
    Dec 6 20:04:34 server1 pop3d: Maximum connection limit reached for ::ffff:213.177.138.57
     
  12. LinuxGuyMT

    LinuxGuyMT New Member

    No, I am not

    I think it is a script that is trying to hack into my mail server but it's cutting him off at 4 attempts. However that is not my problem the mail server is not accepting mail or allowing me to send mail out. Says Relaying not allowed. I send a test mail to a test email on the server and it returns it saying address rejected.


    Thank you,
    LinuxGuyMT
     
  13. Mark_NL

    Mark_NL New Member

    "Relaying not allowed" that's an important thing you said there ;-)

    in your main.cf you define the "mydestination", the value of that setting will tell postfix which domains have theire email hosted on the server. For example:

    Code:
    mydestination = localhost, foo.tld, bar.tld
    That means, the server will accept email for localhost, foo.tld and bar.tld

    now if you want to send an email to "LinuxGuyMT@foo.tld" the message will be delivered on the server.

    but if you'd send an email to MarkNL@other.tld .. the server checks mydestination, and notices "other.tld" is not in that list, so it will try to find the server that hosts "other.tld" and will send it to the correct server.
    That is called "relaying". Relaying is only allowed if the person sending that email authenticates himself with the server. (unautorized relaying is disabled by default to prevent spammer from abusing your mailserver to send spam)

    So in short: When you want to send mail via your mailserver, enable SMTP authentication and use your user/pass, problem solved :)

    p.s. if you want to get rid of that "hacker", block him in iptables (firewall):
    Block: iptables -A INPUT -s 213.177.138.57 -j DROP
    Remove Block: iptables -D INPUT -s 213.177.138.57 -j DROP
     
  14. LinuxGuyMT

    LinuxGuyMT New Member

    Ok not returning mail but now not delivering to the inbox

    Ok, we got the Relaying not allowed problem fix, but when I send a test mail as you said from another account. It doesn't show up in my inbox, were making some progress here I think. The server is almost up and running. :D This is what I get when I send a email from my AOL account to my mail server:


    ----- The following addresses had permanent fatal errors ----- <Brianmissoula@candyhostinghub.net>
    (reason: 550 #5.1.0 Address rejected Brianmissoula@candyhostinghub.net)

    ----- Transcript of session follows ----- ... while talking to smtp.secureserver.net.:
    >>> RCPT To:<Brianmissoula@candyhostinghub.net>
    <<< 550 #5.1.0 Address rejected Brianmissoula@candyhostinghub.net 550 5.1.1 <Brianmissoula@candyhostinghub.net>... User unknown


    However, I goto ISPConfig and the email account is in the ISPconfig control panel. Can anyone provide any ideas as to why I can not get incoming email still? The Outgoing Part is Running fine now.
     
    Last edited: Dec 19, 2009
  15. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please check if the MX record is pointing to the right server:
    Code:
    dig mx candyhostinghub.net
     
  16. LinuxGuyMT

    LinuxGuyMT New Member

    Thank you, That was my issue now my newest problem is as follows I send a test mail to the server and the mail server returns my mail saying as follows:

    This is the mail system at host server1.candyhostinghub.net.

    I'm sorry to have to inform you that your message could not be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to postmaster.

    If you do so, please include this problem report. You can delete your own text from the attached returned message.

    The mail system

    <Brianmissoula@candyhostinghub.net>: mail for candyhostinghub.net loops back to myself


    Any Ideas on how to fix this? I have never gotten a error like this before from my mail server.


    Thanks,
    LinuxGuyMT


    UPDATE:I Figure it out, it was a advanced email routing option that I needed to remove. Please Disregard I am up 100% now.
     
    Last edited: Dec 21, 2009
  17. Mark_NL

    Mark_NL New Member

    Nice work, so everything is up and running as you would like to? :)
     
  18. LinuxGuyMT

    LinuxGuyMT New Member

    Yes, everything is up and running as I would like to. :) Thank you everyone for working with me on this it took a few days but as a team we got it figured out. HOORAH!

    :D:D
     

Share This Page