ISPconfig3 install question, if cannot be answered I am going to look for another

Discussion in 'Installation/Configuration' started by j.smith19810808, Mar 5, 2010.

Thread Status:
Not open for further replies.
  1. j.smith19810808

    j.smith19810808 New Member

    Is it possible to follow the tutorial of ispconfig2's setup on this website and just replace the version of ispconfig 3?

    Its just I keep getting this annoying error when I try install using the command 'sudo rpm -ivh courier-imap-4.6.0-1.12.x86_64.rpm', its saying that a directory is denied because of a certain permissions (I do have a previous post with this error).

    But was thinking of a workaround, I just wanted to know is there any tutorial for Fedora 12 on a 32bit system aswell?

    As another post I have made in a previous thread due to the nature of this rpmbuild problem.

    I have attempted this 5 times previously and its bringing up the same error each time, I have made sure every file is world writable and executable so there's really nothing I can do, or anyone else can do, its really starting to annoy me now.

    Can I ask why there isnt a 32bit version of this tutorial? Seems like you've neglected any person wishing to use a 32bit system, thats what I find annoying really.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No. ISPCOnfig 2 and 3 have completely different system requirements.


    Not at all. there is no 32bit tutorial as its the same then the 64Bit one.

    But fedora is always a bit difficult when it comes to compile applications. Compiling works one day and then there is a package update in fedora and it does not work anymore. Thats why I would never use fedora for a production system on a server.

    My recommendation is to use a linux distribution which is better suited for servers like debian. If you really wnat to stay with fedora, you can use the setup with dovecot instead of courier to avoid the compiling. the dovecot setup is described in a text document that you find in the latest ispconfig 3.0.2 RC 1 tar.gz file in the docs folder. Dovecot requires you to use this rc1 release then, which is pretty stable already.

    See release post in dev forum to download this release.
  3. j.smith19810808

    j.smith19810808 New Member

    You know what I never appreciated that.

    Makes perfect sense now that you mention it, what I would presume its sort of the same thing when you try and install say a group of applications or services and it installs a whole load of crap with it, that consumes that much memory and messes up your system.

    Albeit they probably depend upon those packages to work properly, it does get annoying at times.

    I have probably actually seen this myself once before a while back when I was messing around with various things, so why on earth use Fedora then if it does this so much?

    I bet I am asking the ultimate question there lol.

    Thanks ever so much for that reply though, does make me laugh though, at the problems I have been having, sort of resolves it in my own head and gets a bit more information about distro's of Linux aswell, as most of what (infact all I have done) with Linux has been based upon Fedora and sort of made do with it if you like.

    When I was at university, we practiced doing things with Fedora and thats what the tutorials we where given (merely exercises) where all based on fedora, but in my advanced final year was based upon for network management in the full RHEL cant remember which version it was.

    Thats why I have stuck with fedora but will look at some reviews to see which ones best for me, which one would you say is the best to use then?

    All I like to do though is just fiddle around see if I can get things working (typical nerd lol).

    But I want to eventually say when someone asks at work if I can do something, I can ultimately turn around n say if the IT tech cant do this, I can, and get myself some more praise (possibly for what I am doing so to speak).

    Sorry for the lengthly reply, but thats one ace reply!

    One more messup with Fedora and I'm ditching it, lol.

    Thanks so much,
    Last edited: Mar 5, 2010
  4. j.smith19810808

    j.smith19810808 New Member

    How would best be the way to authenticate though in dovecot to use ISPconfig?

    I tried finding that version of ISPconfig also but just takes me to the latest release, should I just install and configure that as per the normal tutorial as it where?

    I am just a bit confused about how to tackle this, your help is greatly appreciated.

    Sorry I know I am being a pain but once I have it laid out, I get the graps of most projects really.

    I look forward to any replies as usual,
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is handling this with its installer automatically, so no configuration neede in any config file and as long as you do not edit something manually, it will work.

    No. Use the 3.0.2 RC1 from the devlopment forum:

    download the tar.gz, unpack it, look into the docs folder and follow the instructiins in the file INSTALL_FEDORA_12_dovecot_bind.txt
  6. j.smith19810808

    j.smith19810808 New Member

    Hello again,

    Sorry to be a bit of a pain here, but lol.

    I have now changed my system to Centos actually went for v4.8 as v5 wouldnt work some some strange reason, probably something to do with my hardware being relatively old or just not up to the spec of v5.x


    I am having to go to use ispconfig v2, but is there anyway of making subdomains in ispconfig2?

    Like I dont even mind having to go directly into the apache vhosts part to get it changed there so this will work.

    If anyone can help me come up with a solution to this.

    I would really appreciate it.


    Thanks for the advice on the OS though, seems a light weight version of what I had is great, works allot faster than my old one did, going to be doing a bit of messing around with centos, I wont bother predicting a problem unless I actually get one haha, works the mind wonders I think.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Sure, absolutely esay.

    Click on new website,and enter:

    hostname: sub

    thats it.
  8. j.smith19810808

    j.smith19810808 New Member

    How does apache know where to set it for?

    Is it the sub domain that has to be the same as the folder, by any chance?

    Also, as I now have ispconfig2 installed using centos 4.8 32bit tutorial for perfect server.

    Why is the ftp anonymous login asking for a password?

    example when I try to access it keeps asking for a password when I did the equivalent tutorial in fedora it didnt, why is this?

    Is there anyway I can stop this from happening without having to install ispconfig2 again?

    How would I also go about maybe installing the Zend Framework for centos 4.8? (I know this is probably not a place to ask this but just curious).

    Thanks for your help though, ace!
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats all configured by ispconfig. Just enter it in the form in ispconfig and click on save, ispconfig is creating the directorie for the enw website and writes the vhost.

    Please make sure that you enabled anonymous FTP in the website settings.

    This thread is about installing ispconfig 3 and it is in the ispconfig 3 forum. If you have questions about ispconfig 2, please post them in the ispconfig 2 forum into a new thread.
Thread Status:
Not open for further replies.

Share This Page