ispconfig3 ftp problem

Discussion in 'Installation/Configuration' started by Mannensson, Mar 5, 2009.

  1. Mannensson

    Mannensson New Member

    When i installed ispconfig3 on my Debian 5 Lenny server i can login with my ftp users. i'm using prefix before and it tells me wrong password. Anyone knows what to do?
     
  2. till

    till Super Moderator

    Were is the problem when you can login with the ftp users created in ispconfig?
     
  3. Mannensson

    Mannensson New Member

    When i was going to logon to the ftp with FlashFXP.

    But i reinstalled everything and now it works.
     
  4. umano

    umano New Member

    I have the same issue what did you reinstall?? ispconfig?
     
  5. Mannensson

    Mannensson New Member

    I reinstalled debian and everything with successful result.
     
  6. umano

    umano New Member

    I'm trying to connect by ip not by domain, I want to upload my websites before changing dns.

    I set up the client, then the site (and Ip), and the ftp user and pass.
    Then when I tried to connect I specified the Ip as address then username and pass, but no connection established... wrong pass

    I check /etc/pure-ftpd/db/mysql.conf and everything seems ok, I also removed pureFtpd, reinstalled it, and ispconfig as well, following perfect lenny etc etc


    I also manually replaced the password via phpmyadmin, and it doesn't work.

    Where's my fault?
    Thanks
     
  7. falko

    falko Super Moderator

    Have you tried active and passive transfers in your FTP client?
     
  8. till

    till Super Moderator

    And which are the error messages that you get in syslog when you try to login.
     
  9. umano

    umano New Member

    I usually connect to ftp in passive mode, but thinking about It could be a client issue I tried to connect from different pc and os.

    The same problem happens also connecting directly from terminal inside the server ... ftp localhost...

    My log

    ar 24 21:05:01 estrobinario pure-ftpd: (?@localhost) [INFO] New connection from localhost
    Mar 24 21:05:01 estrobinario pure-ftpd: (?@localhost) [INFO] Logout.
    Mar 24 21:10:02 estrobinario pure-ftpd: (?@localhost) [INFO] New connection from localhost
    Mar 24 21:10:02 estrobinario pure-ftpd: (?@localhost) [INFO] Logout.

    Mar 24 21:10:31 estrobinario pure-ftpd: (?@83-103-40-111.ip.fastwebnet.it) [INFO] New connection from 83-103-40-111.ip.fastwebnet.it
    Mar 24 21:10:31 estrobinario pure-ftpd: (?@83-103-40-111.ip.fastwebnet.it) [INFO] PAM_RHOST enabled. Getting the peer address
    Mar 24 21:10:33 estrobinario pure-ftpd: (?@83-103-40-111.ip.fastwebnet.it) [WARNING] Authentication failed for user [defaultumano]
    Mar 24 21:10:37 estrobinario pure-ftpd: (?@83-103-40-111.ip.fastwebnet.it) [INFO] Logout.
    Thank you
     
    Last edited: Mar 25, 2009
  10. falko

    falko Super Moderator

    Is it a physical server or a virtual machine? If it's a virtual machine, which virtualization technology is being used (OpenVZ, Xen, KVM, VMware, etc.)?
     
  11. umano

    umano New Member

    It's a vps on Xen and SAS drives, for that maybe I found also an error on /etc/mdadm . The package is installed but the folder doent's exist

    During the install (following your tutorial) I had the issue about quota but i resolved like the guy who commented the tutorial.

    I tried also the update to 3.0.1 but it did not work. Then i changed my mysql root password (maybe the | character in password is reserved, i tried everything in my rough knowledge :) ) and i did the update process again. The updadate failed again but with a different error.

    Now I told to the hoster (clustered.net) to format and set up a fresh base lenny system.

    I set up ispconfig with lenny and vmware on my mac and it worked perfectly (mail and ftp for sure).

    Now I'm going to do it again with ispc 3.0.1 on my mac and on vps.
    I'll tell u the results, and really thank you for your precious time.
     
  12. till

    till Super Moderator

    You should not use control characters like |<>%$ยง for the mysql passwords as they get interpreted on the shell.
     
  13. umano

    umano New Member

    Found the issue, i did not tried yet, I'm an idiot sorry.
     
    Last edited: Mar 25, 2009

Share This Page