ISPConfig3 Control Panel does not resolve ater upgrading wheezy to jessie / apache 2.2 to 2.4

Discussion in 'Installation/Configuration' started by webmaster-eddie, Aug 24, 2015.

  1. webmaster-eddie

    webmaster-eddie New Member


    I have been trying for two days now to get the ISPConfig3 Control Panel front end to resolve after performing an otherwise successful upgrade from wheezy to jessie and apache 2.2 to 2.4.10. Using php 5.6.9 - all deb jessie standard. Squirrelmail works fine.

    The only problem reported in the htf_report is:
    ##### PORT CHECK #####
    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening

    Basically the applications that I re-installed after the upgrade (like squirrelmail) have only a .conf file in the conf-enabled or conf-available directories. Ispconfig has both an old .vhost and a new .conf file. in teh sites-available directory

    I ran the ispconfig3 update manually as you recommended. I couldn't get the Control panel to resolve. Same thing with when using the IP - with or without https. I want to be able to use the rsync.php tool, but I can't get the control panel to resolve. I tried running the rsync.php from the command line (both as root , and as the ispconfig user) and it failed with two include path errors which I fixed, but that did not seem to do the job - that is to say, I still couldn't get the ispconfig3 control panel to appear or resolve in the browser, even after running the php script, with no errors displayed. I do not know if that method of running the script actually wored - or is possibel to work?

    I even tried uninstalling ispconfig3, doing a fresh install (still no control panel) and then restoring from a backup - and still no control panel. The restore worked, because I got my mail domains and usernames back so squirrelmail started working again. An update after the restore did not help.

    So, I don't know if I need to enable port 8080 in ports.conf, add it to ispconfig.conf and rename or move ispconfig.vhost, and then enable (a2ensite) ispconfig.conf? - I tried it but it didn't get me the control panel. I have IP tables accepting port 8080. This is not a firewall problem, I believe - no resolution when fail2ban is stopped.

    When I try, I get:
    Index of /
    Apache/2.4.10 (Debian) Server at Port 8080

    When I try https ipv4:8080 or https I get:
    SSL Connection error

    Basically, I need to know how to get the control panel to resolve. Can you help with that, please. I did buy your manual, and I do like the software - which was working fine under wheezy and apache 2.2.

    Alternatively, is it an acceptable method to do the rsync.php tool command from the command line? Does it work? If so, how to do it correctly?

    I am hoping that once I can perform that rsync.php command then I will have a workign control panel again, and I will have sites resolve again. How to get the control panle to resolve.

    Lastly, other information is that in the /etc/apache2/apache2.conf file after each ispconfig install or update (all these installs and updates are of the latest stable, of course, patch 8) the last line of that file is: IncludesOptional sites-enabled/
    and if I leave it like that nothing resolves (neither the IspConfig3 control panel, nor squirrelmail, nor any sites), however if I modify that line to read
    IncludesOptional sites-enabled/*.conf, then I get the Index of / screen for the :8080 control panel, a default "It works!" screen for established websites, and, and then squirrelmail works properly.

    when I run "apachectl configtest"
    I receive the following notice:
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:62

    Can anyone suggest what to do to get this working. Reinstalling the server is not an option. Thank you. There is nothing in the logs that tells me what is going on here, I think I just need to manually get the ispconfig control panel to resolve with apache 2.4.10, and I can't seem to accomplish that, as many times as I try. Thanks for any help.

    Last edited: Aug 24, 2015
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    download the ispconfig tar.gz, unpack it, run the update.php script in the install folder and choose reconfigure services during update. then login into ispconfig, go to tools > resync and choose to resync all websites.

    Do not try to alter any apache config files manually as this might break your server. If you altered any config files or apache2.conf, then restore the old version. It is important to not alter any include lines!
  3. webmaster-eddie

    webmaster-eddie New Member


    I did that - 7 or 8 times over the past few days, and I do not get any login screen at all. I did always reconfigure services. I know it must work with a fresh install of jessie and apache 2.4, etc, but it just doesn't work with an upgrade from wheezy and apache 2.2 to jessie and 2.4. I tried following the posts of others who upgraded their vps (this is a dedicated), etc, but their suggestions didn't work either.

    Steps to reporduce:

    Take a debian wheezy server running apache 2.2 and mysql or mariadb. Upgrade to jessie and apache 2.4 - the control panel is not visible.

    Has anyone successfully done this upgrade and have their port 8080 control panel be visible after the upgrade and the ispconfig3 update?
  4. webmaster-eddie

    webmaster-eddie New Member

    Lastly, is running the rsync.php script from the cli a valid way to do it? Should that work? (since I can't get the port 8080 control panel to resolve.)
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Did that as well for several clients and never had a problem. Just run a debian dist upgrade and keep all config files when apt asks. Then download the ispconfig tar.gz, unpack it, run the update.php script in the install folder and choose to reconfigure services during update.

    This script cant be run from cli.
  6. webmaster-eddie

    webmaster-eddie New Member


    I finally got things almost working perfectly again - but I had to reinstall everything - including apache2, openssl, postfix, mariadb, php, dovecot, and finally a clean uninstall and install of ispconfig3 - then I got the control panel to resolve in the browser. The only thing I can think of was that before upgrading to jessie and apache 2.4 I had super-hardened my ssl security - only accepting TLS and the toughest ciphers. Perhaps this caused sopme kind of failure, or perhaps I didn't have sni setup properly?

    A couple of caveats - perhaps even "bugs" to report - I'll leave it to you to report these as "bugs" - if you agree that ispconfog3 can be improved by that:

    1) I had initially used a greater than 64 character password for the admin user in ispconfig3 - and there was no error message when I changed the password, however when I attempted to login again, it didn't work with error message that the password can't be greater than 64 characters. So, my recommendation is to increase the allowable password length to 256 characters. Strong passwords = long paswords. In addition I recommend that you throw an error when changing the password in the tools section of the control panel so that it doesn't accept longer than 256 character (or 64 character currently) passwords.

    2) When restoring the dbispconfig database from backups, there were always primary key id 1 errors that prevented a real clean successful restore, both in phpmyadmin and with the command line; even using -f, I don't think the restore was perfect because of these primay key id 1 errors. Could the system be redesigned so that a restore doesn't throw these errors and works, even in phpmyadmin? That would be great.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Feel free to make a feature request for that.

    Never had that in the past few years but I remember that there was such an issue with a ISPConfig release from 2010 or 2011. Maybe your old ispconfig version was that old so that it did not had keys on some files while current ispconfig versions have keys as duplicate keays are prevented by mysql.
  8. webmaster-eddie

    webmaster-eddie New Member

    OK, I'll make a feature request for the first thing, but I think it's a bug, since it lets you enter in a password too long to work, and then , if you do that, some people won't know how to recover from that error.

    Secondly, I have been using the latest stable with patches verion for a few years now - so the problem wioth primary key id 1 duplicates in a restore scenario still exists currently.

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The data that causes the errors must have been entered into the database with that old version, you will not be able to enter it with any recent version.

Share This Page