ISPCONFIG3 CentOS 6.4 no Mail and Web asking for security login after upgrade

Discussion in 'Installation/Configuration' started by vestport, Apr 10, 2014.

  1. vestport

    vestport Member HowtoForge Supporter

    Hello group,

    I recently upgraded the os and ISPCONFIG to the current revs. Pretty much no glitches other than the only site, mail etc. I can access is the primary site (domain controller) and all other virtual sites ask for .htaccess type login when I try to go to the root web page or to email. I have renamed .htaccess to something like htaccess.orig so it should not be asking for authentication at least in the web directory of the virtual site. FTP works okay but again web and mail have popup window asking for security. I have one new virtual site and one old virtual site.

    In

    Code:
    # /etc/httpd/conf/sites-available/newvirtualdomain.com.vhost 
    says:

    Code:
    # Apache did not start after modifying this vhost file.
    # Please check file /etc/httpd/conf/sites-available/newvirtualdomain.com.vhost.err for syntax errors.
    my oldvirtualdomain.vhost file is:

    Code:
    <Directory /var/www/oldvirtualsite.com>
                    AllowOverride None
                    Order Deny,Allow
                    Deny from all
    </Directory>
    
    <VirtualHost *:80>
                                            DocumentRoot /var/www/oldvirtualsite.com/web
    
                    ServerName oldvirtualsite.com
                    ServerAlias www.oldvirtualsite.com
                    ServerAdmin [email protected]
    
                    ErrorLog /var/log/ispconfig/httpd/oldvirtualsite.com/error.log
    
                    Alias /error/ "/var/www/oldvirtualsite.com/web/error/"
                    ErrorDocument 400 /error/400.html
                    ErrorDocument 401 /error/401.html
                    ErrorDocument 403 /error/403.html
                    ErrorDocument 404 /error/404.html
                    ErrorDocument 405 /error/405.html
                    ErrorDocument 500 /error/500.html
                    ErrorDocument 502 /error/502.html
                    ErrorDocument 503 /error/503.html
    
                    <IfModule mod_ssl.c>
                    </IfModule>
    
                    <Directory /var/www/oldvirtualsite.com/web>
                                    Options FollowSymLinks
                                    AllowOverride All
                                    Order allow,deny
                                    Allow from all
    
                                    # ssi enabled
                                    AddType text/html .shtml
                                    AddOutputFilter INCLUDES .shtml
                                    Options +Includes
                    </Directory>
                    <Directory /var/www/clients/client3/web2/web>
                                    Options FollowSymLinks
                                    AllowOverride All
                                    Order allow,deny
                                    Allow from all
    
                                    # ssi enabled
                                    AddType text/html .shtml
                                    AddOutputFilter INCLUDES .shtml
                                    Options +Includes
                    </Directory>
    
                    <IfModule mod_ruby.c>
                            <Directory /var/www/oldvirtualsite.com/web>
                                    Options +ExecCGI
                            </Directory>
                            RubyRequire apache/ruby-run
                            #RubySafeLevel 0
                            AddType text/html .rb
                            AddType text/html .rbx
                            <Files *.rb>
                                    SetHandler ruby-object
                                    RubyHandler Apache::RubyRun.instance
                            </Files>
                            <Files *.rbx>
                                    SetHandler ruby-object
                                    RubyHandler Apache::RubyRun.instance
                            </Files>
                    </IfModule>
    
    
                    <IfModule mod_python.c>
                            <Directory /var/www/oldvirtualsite.com/web>
                                    AddHandler mod_python .py
                                    PythonHandler mod_python.publisher
                                    PythonDebug On
                            </Directory>
                    </IfModule>
    
                    # cgi enabled
            <Directory /var/www/clients/client3/web2/cgi-bin>
                            Order allow,deny
                            Allow from all
                    </Directory>
                    ScriptAlias  /cgi-bin/ /var/www/clients/client3/web2/cgi-bin/
                    AddHandler cgi-script .cgi
                    AddHandler cgi-script .pl
                    # suexec enabled
                    <IfModule mod_suexec.c>
                            SuexecUserGroup web2 client3
                    </IfModule>
                    # Clear PHP settings of this website
                    <FilesMatch "\.ph(p3?|tml)$">
                                    SetHandler None
                    </FilesMatch>
                    # php as fast-cgi enabled
            # For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
                    <IfModule mod_fcgid.c>
                                    IdleTimeout 300
                                    ProcessLifeTime 3600
                                    # MaxProcessCount 1000
                                    DefaultMinClassProcessCount 0
                                    DefaultMaxClassProcessCount 100
                                    IPCConnectTimeout 3
                                    IPCCommTimeout 360
                                    BusyTimeout 300
                    </IfModule>
                    <Directory /var/www/oldvirtualsite.com/web>
                                    AddHandler fcgid-script .php .php3 .php4 .php5
                                    FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
                                    Options +ExecCGI
                                    AllowOverride All
                                    Order allow,deny
                                    Allow from all
                    </Directory>
                    <Directory /var/www/clients/client3/web2/web>
                                    AddHandler fcgid-script .php .php3 .php4 .php5
                                    FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
                                    Options +ExecCGI
                                    AllowOverride All
                                    Order allow,deny
                                    Allow from all
                    </Directory>
    
    
                    # add support for apache mpm_itk
                    <IfModule mpm_itk_module>
                            AssignUserId web2 client3
                    </IfModule>
    
                    <IfModule mod_dav_fs.c>
                    # Do not execute PHP files in webdav directory
                            <Directory /var/www/clients/client3/web2/webdav>
                                    <ifModule mod_security2.c>
                                            SecRuleRemoveById 960015
                                            SecRuleRemoveById 960032
                                    </ifModule>
                                    <FilesMatch "\.ph(p3?|tml)$">
                                            SetHandler None
                                    </FilesMatch>
                            </Directory>
                            DavLockDB /var/www/clients/client3/web2/tmp/DavLock
                            # DO NOT REMOVE THE COMMENTS!
                            # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
          # WEBDAV BEGIN
                            # WEBDAV END
                    </IfModule>
    
    
    </VirtualHost>
    
    Neither virtual site works but one difference is that the new .vhost file had errors.


    Now I know apache is running as I can access the primary domain of the ns controller web pages (http and https pages). Also, no problem accessing mail. The only issues are with the virtual domains (new and old).

    What is going on?

    Thanks in advance for any replies!


    Art:eek:
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to set the IP address instad of * in a website that is not working in ispconfig.
     
  3. vestport

    vestport Member HowtoForge Supporter

    Setting IP address versus *

    Hi Till,

    It won't let me do that. It keeps resetting to * when I go to save or next field. What do I need to do?

    Thanks!


    Art
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that you are logged ina s admin in ispconfig.
     
  5. vestport

    vestport Member HowtoForge Supporter

    Yes, I am logged in as ADMIN and the pull down menu under "Sites" only allows for "*" and not an IP. Every time I try to put an IP it disappears. I am doing this where it says IPv4Address unless that is not the right place?
     
    Last edited: Apr 14, 2014
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to add the IP under System > server ip first.
     
  7. vestport

    vestport Member HowtoForge Supporter

    Thanks Till! Got that and changed the IP but under "System" to the server IP versus the ns name and changed each domain but still not working. Security window keeps coming up. Like a .htaccess security.


    Art
     
  8. vestport

    vestport Member HowtoForge Supporter

    I tried sync, deleting sites & recreating and nothing works. One thing I did notice is that after deleting a domain the structure & files still appear in

    Code:
    /etc/httpd/conf/sites-available 
    and

    Code:
    /etc/httpd/conf/sites-enabled
    There are only 3 domains on this server. The DNS server itself (ns1.mydomain.com) and 2 other domains. One domain gets the following error:

    Code:
    # Apache did not start after modifying this vhost file.
    # Please check file /etc/httpd/conf/sites-available/domain2.com.vhost.err for syntax errors.
    
    and the other (domain3.com) does not get this error yet both domains ask for authentication when going to the website and get a 401 error. I have renamed

    Code:
    .htaccess
    to

    Code:
    htaccess-orig
    and deleted the hidden file and still no luck.

    What should I do? This seems more like an apache issue than ISPCONFIG.
     
  9. vestport

    vestport Member HowtoForge Supporter

    The problem appears to be more apache related than ispconfig due to the error above and the following error when I try to manually restart apache:

    Code:
    [[email protected] sites-available]# service httpd restart
    Stopping httpd:                                            [  OK  ]
    Starting httpd: [Wed Apr 16 20:27:39 2014] [warn] NameVirtualHost 111.222.333.444:443 has no VirtualHosts
    [Wed Apr 16 20:27:39 2014] [warn] NameVirtualHost *:80 has no VirtualHosts
    [Wed Apr 16 20:27:39 2014] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Wed Apr 16 20:27:39 2014] [warn] NameVirtualHost *:80 has no VirtualHosts
    How can I get things back to normal?
     
  10. vestport

    vestport Member HowtoForge Supporter

    Okay, so I decided to go back to an old

    Code:
    /etc/httpd/conf/httpd.conf
    file and things sort of got better in the following way. Now no security screen but the only site it goes to is the main DNS site and not the new domain. This happens for any additional real domain that I try to add. If you try to go to the domain itself, www or mail.domain.com it always just goes to the ns1.domain.com site and not to the actual domain. Squirrel mail never comes up for the new domain. The only mail domain that actually works for mail is the ns1.domaincontroller.com site (main server ns1).

    Any ideas on where I can go from here to get additional domains and mail working appreciated. The www and mail is setup in dns, in mail domain etc. just not working. I think I need to edit a .conf file somewhere and just not sure which one. Probably somewhere in a subdirectory of

    Code:
    /etc/httpd/conf
    Thanks in advance for any replies!

    Art
     

Share This Page