ispconfig3 can sent, can't Receive

Discussion in 'General' started by litgle, Jan 16, 2010.

  1. litgle

    litgle New Member

    My server name is sone.serverdomain.net, I already point sone.serverdomain.net to this server IP in the DNS
    Code:
    sone.serverdomain.net  A  74.157.X.X
    
    I have installed ispconfig3 on this server, and added clientdomain.com to ispconfig3 Email, At the same time I was add MX records clientdomain.com points to sone.serverdomain.net in the DNS
    Code:
    clientdomain.com  MX  10  sone.serverdomain.net
    
    my server config:
    Code:
    sone:~# postconf -n
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    debug_peer_list = clientdomain.com
    inet_interfaces = all
    inet_protocols = ipv4
    mailbox_size_limit = 0
    message_size_limit = 0
    mydestination = sone.serverdomain.net , localhost
    myhostname = sone.serverdomain.net
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
    myorigin = /etc/mailname
    readme_directory = no
    recipient_delimiter = +
    relayhost =
    smtp_tls_note_starttls_offer = yes
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtp_use_tls = yes
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom
    
    Code:
    sone:~# hostname
    sone.serverdomain.net
    sone:~# hostname -f
    sone.serverdomain.net
    
    In all settings complete, It can send e-mail, but it can't receive e-mail, even i send mail from it@clientdomain.com to hr@clientdomain.com.
    Here is sent mail to it@clientdomain.com from gmail, the mail server's log:
    Code:
    Jan 16 15:19:37 sone imapd: Connection, ip=[::ffff:127.0.0.1]
    Jan 16 15:19:37 sone imapd: LOGIN, user=it@clientdomain.com, ip=[::ffff:127.0.0.1], port=[45199], protocol=IMAP
    Jan 16 15:19:37 sone imapd: LOGOUT, user=it@clientdomain.com, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=87, sent=391, time=0
    Jan 16 15:20:01 sone imapd: Connection, ip=[::ffff:127.0.0.1]
    Jan 16 15:20:01 sone imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Jan 16 15:20:01 sone pop3d: Connection, ip=[::ffff:127.0.0.1]
    Jan 16 15:20:01 sone pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Jan 16 15:20:01 sone postfix/smtpd[2207]: connect from localhost[127.0.0.1]
    Jan 16 15:20:01 sone postfix/smtpd[2207]: lost connection after CONNECT from localhost[127.0.0.1]
    Jan 16 15:20:01 sone postfix/smtpd[2207]: disconnect from localhost[127.0.0.1]
     
    Last edited: Jan 16, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Gmail ha snot even tried to deliver the email to your server, so the nprblem is not on your server, its either a problem with a fit´rewall in fron of your server that blocks smtp connections or the mx record of clientdomain.com does not point to the hostname of your server. If you just changed the dns for clientdomain.com, you will have to wait up to 48 hours until the changes will have been propagated to all dns caches.
     
  3. litgle

    litgle New Member

    tks!

    But why it@clientdomain.com can not receive e-mail from hr@clientdomain.com?
     
  4. litgle

    litgle New Member

    After 12 hour, I recive mail from snoe.serverdomain.com:
    Code:
    This is an automatically generated Delivery Status Notification. THIS IS A WARNING MESSAGE ONLY. YOU DO NOT NEED TO RESEND YOUR MESSAGE. Delivery to the following recipients has been delayed.
     

Share This Page