ISPConfig3 and the lenny php5-cli bug

Discussion in 'Installation/Configuration' started by webno, Mar 29, 2009.

  1. webno

    webno New Member

    Just informing all that running ISPConfig (or any other application that uses php5-cli) might cause segmentation faults.

    I'm running lenny inside xen with a compiled kernel from xensource

    I'm getting random segmentation faults in my /var/log/ispconfig/cron.log.

    /usr/local/ispconfig/server/ line 7: 22245 Segmentation fault      /usr/bin/php -q /usr/local/ispconfig/server/server.php
    According to:

    there is a bug somewhere hidden in php5-cli.The bugreport suggests recompiling php5 as a temporary solution.

    I'm rather worried that the ispconfig installation script or other scripts ispconfig uses, might run into a segmentation fault without the script itself failing, which in turn might lead to all kinds of strange errors later on for people installing or using ispconfig3 on lenny.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Segmentation faults are often by hardware problems, e.g. RAM problems. I know many ispconfig 3 isntallations on lenny and none of it has segmentation faults and ther are already more thne 10.000 installations of ispconfig 3 so it might be that this is just related to your system od the bug in php is just triggered on your system.

    ISPConfig is transaction based and ispconfig will redo a transaction if the script diesd during processing.
  3. webno

    webno New Member

    Did what was advised at:

    1) Install php5-dev, libmysqlclient15-dev and the source of php5 (apt-get source php5)
    2) cd php5-5.2.6.dfsg.1/ext/mysql/
    3) run "phpize" in this directory
    4) ./configure && make && make install

    All is fine now.

Share This Page