ISPConfig3 and SSL

Discussion in 'Installation/Configuration' started by voltron81, Mar 10, 2010.

  1. voltron81

    voltron81 New Member

    Hi to everybody.
    I've realized a mailserver following the perfect server how-to(

    Everything is working fine.
    My question is: at the moment the outlook configuration to use that server is a standard one (POP3 port 110 and SMTP with server authentication on port 25).
    How can I setuo the server to allow also the use of SSL?

    I mean I want to use the standard configuration, but also give the opportunity to access on the account using the SSL protocol (so port 995).

  2. yoplait

    yoplait Member

    Last edited: Mar 10, 2010
  3. voltron81

    voltron81 New Member

    Hi yoplait,
    thanks for your reply.

    Reading the links that you suggested me I can see that it's look like quite easy.

    My question now is: is it sure that qith this method the customers can access to their accounts in both ways (with and without SSL)???

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. SSL is enabled as additional connection method beside the normal non encrypted connections.
  5. voltron81

    voltron81 New Member

    Hi guys.
    It' working.

    Do you also know how to setup POP3 with SSL?
    As before could be nice to offer both solution, with and without SSL...

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    pop3 is already configured for SSL if you installed your server as described in the perfect setup guide.
  7. voltron81

    voltron81 New Member

    Perfect Till, it's working... thanks!
  8. u4david

    u4david New Member


    what ports have to be enabled to let the ssl traffic through?
    465,995 any other?
  9. radim_h

    radim_h Member HowtoForge Supporter

    If you in /etc/postfix/ uncomment also line
    submission inet n - - - - smtpd
    then you get also port 587 for TLS as gmail does

    So then you have three ports for SMTP
    25 - non crypted&TLS
    465 - SSL only
    587 - TLS only
  10. u4david

    u4david New Member


    so if i fallow the above mentioned links+have the changes in :
    If you in /etc/postfix/ uncomment also line
    submission inet n - - - - smtpd

    all ineed is to open ports 25,465,587
    ports 993 ,995 i do not need to open correct?
  11. falko

    falko Super Moderator ISPConfig Developer

    If you want to use POP3S and IMAPS, you must open these ports as well.
  12. carpman

    carpman Member

    Hi, i too am trying to get smtp over ssl setup,

    I have made the changes to /etc/postfix/

    submission inet n       -       -       -       -       smtpd
    smtps     inet  n       -       -       -       -       smtpd
    All firewall are open to correct ports.

    Sending via port 25 works fine

    Sending via StartTLS works except sent mail can't be copied to Sent folder. This set correctly in email client settings.

    Sending via SSl fails, it connects and if first time ask me to confirm self signed cert, but then get message that connection to smtp server timed out.

    Any ideas?


Share This Page