ISPConfig3 and rewrite

Discussion in 'General' started by jrbrownusa, Sep 26, 2009.

  1. jrbrownusa

    jrbrownusa New Member

    I am a little frustrated. I am migrating over from Virtualmin to ISPConfig3. I have several websites. One uses Drupal, several use WordPress. Now I know some stuff about Apache and getting mod_rewrite to work, but ISPConfig confuses me. I found several post here on this forum and none of the solutions work. I have edited my template to include the Options I need, but still I get 500 error messages with Wordpress and my Drupal doesn't navigate to the pages I have setup.

    I don't understand why this should break.
    my vhost file looks like this
    Code:
    <Directory /var/www/clients/client2/web2/web>
            Options Indexes FollowSymLinks Includes ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
    my wordpress .htaccess look like this
    Code:
    Options +FollowSymLinks
    RewriteEngine on
    RewriteRule ^download/([^/]+)$ *your wp-content dir*/plugins/download-monitor/download.php?id=$1 [L]
    
    
    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    This worked before I went to ispconfig3.
     
  2. Norman

    Norman HowtoForge Supporter

    What happens if you remove the .htaccess , does the 500 error disappear?
    I'm pretty sure that the default apache settings are pretty "hard" on user settable options through .htaccess and that you've forgotten something.

    Make sure that +Options is allowed in template and the option isnt overwritten by other permissions.

    Otherwise, add the content of .htaccess to apache directives under the site instead (in the webgui).
     
  3. jrbrownusa

    jrbrownusa New Member

    Hi

    The problems seems to lie in the permalink options for both drupal and wordpress. So I will try to put the .htaccess information in and see what happens.
     
  4. jrbrownusa

    jrbrownusa New Member

    Still not working

    I have placed into the Apache Directives the following
    Code:
    <Directory /var/www/clients/client2/web2/web>
    
    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    RewriteRule ^download/([^/]+)$ *your wp-content dir*/plugins/download-monitor/download.php?id=$1 [L]
    </IfModule>
    
    # END WordPress
    </Directory>
    
    And deleted the .htaccess file in the site directory. When I view the page it is fine until I click on a page. A 404 message pops up....?:confused:

    I like ispconfig, but it seems to me that something isn't working right. I had this site just working fine under virtualmin, but wanted to move to a more stable solution. I am using ISPConfig 3.0.1.4.
     
  5. jrbrownusa

    jrbrownusa New Member

    It works now...

    Apparently I had forgotten to enable the mod_rewrite in apache. Once I did this it started to work thanks.

    :):D
     

Share This Page