ISPConfig3 and MyDNS/BIND

Discussion in 'General' started by mikey169, Jan 13, 2009.

  1. mikey169

    mikey169 New Member

    hi, first: i'm very new to dns in general - so any hints will be very helpful to me..

    i have set up a clean debian4 with ispconfig3 using the INSTALL_DEBIAN_4.0.txt

    now, i did test my dns-server using this test-page:
    http://recursive.iana.org/

    it said that my server allows recursion, altough i checked that /etc/mydns.conf has the line: "recursive = "

    after some research i found out that beside mydns also bind was running.. so after adding the line "recursion no" in /etc/bind/named.conf.options and restarting the bind-service did give positive results using the test-page..

    so, finally i thought i could shutdown the bind-service and only use mydns.. this didn't work (the test-page did not longer found my server..)

    now, my question as a newbie:

    1) mydns requires a running bind-instance?

    2) is something i did do obviously wrong?

    i also used this test-page:

    http://dnscheck.iis.se/

    it says that my dns does not give authoritative answers for NS and SOA..

    3) where can i change this?

    thanks :)


    *EDIT*


    i found out that editing the /etc/bind/named.conf.options raised new problems, as "dig @localhost mydomain.de" did not give any result of my dns back.. so i finally stopped the bind-service and afterwards started the mydns-service and everything worked well (as far as i can see)..
    - authoritative answers
    - no recursion

    so, the following questions remain:

    1) is stopping the bind-service the right way for me?.. or is this some kind of a terrible workaround.. oO
    2) why is stopping the bind-service not mentioned in the INSTALL_DEBIAN_4.0.txt ?
     
    Last edited: Jan 13, 2009
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Bind and mydns can not be installed together. You will have to uninstall bind, it is not suppoerted by ispcomfig 3.

    because bind is not installed by default on a debian system, so there is nothing to stop. You should have followed just the ispconfog 3 installation guide without installing bind first!
     
  3. mikey169

    mikey169 New Member

    ok, thank you for your help!

    i really followed the guide, but:

    i found out that that hosteurope.de (where i am using a VPS) installs bind9 on every new debian-vps..

    @hosteurope-users, therefore:
    Code:
    apt-get remove bind9
     

Share This Page