ispconfig3 and munin

Discussion in 'ISPConfig 3 Priority Support' started by Spaetzle, Nov 9, 2018.

  1. Spaetzle

    Spaetzle Member HowtoForge Supporter

    Hi
    I installed munin using the hints found in https://www.howtoforge.com/tutorial/server-monitoring-with-munin-and-monit-on-ubuntu-16-04-lts/
    Most things work correctly, but if I like to look at a dynazoom the graphics is not shown. I already tried out some hints from https://www.howtoforge.com/community/threads/no-dynazoom-in-munin.70275/.
    I did the following:
    Code:
    /usr/lib/munin/cgi/
    set the alias in /etc/munin/apache24.conf to the new location and changed owner:
    Code:
    chown -R ispconfig. /var/www/munin
    Now it seems that apache runs the script but in apaches error logs now I find the following:
    I see two solutions to this:
    1. add user ispconfig to group adm
    2. change /var/log/munin/munin-cgi-graph.log rights, so anybody can read them. I fear after log rotations the rights will be reset.

    Now for the question:
    What would you recommend: 1, 2 or a better solution or am I doing something completely wrong?

    Regards
    Bernd
     
    Last edited: Nov 12, 2018
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I would try 1) first.
     
  3. Spaetzle

    Spaetzle Member HowtoForge Supporter

    Hi
    So I went for the first idea with no success at first but other errors ;-) But I solved it this way:
    1) Add ispconfig to adm
    Code:
    usermod -a -G adm ispconfig
    2) Give group write permission to /var/log/munin/munin-cgi-graph.log
    Code:
    chmod g+w /var/log/munin/munin-cgi-graph.log
    3) Now there was just the directory for storing the graphics missing. Create it and change some ownerships and permissions:
    Code:
    mkdir -p /var/lib/munin/cgi-tmp/munin-cgi-graph/cranimax.com/host1.cranimax.com
    chown -R www-data.adm /var/lib/munin/cgi-tmp/munin-cgi-graph
    chmod -R g+w /var/lib/munin/cgi-tmp/munin-cgi-graph
    Done. Now my setup works quit well ... no other problems found so far.
     
    till likes this.

Share This Page