ISPConfig3 and FCGI wrapper

Discussion in 'General' started by Keeper, Aug 30, 2009.

  1. Keeper

    Keeper New Member


    I noticed that ISPConfig creates .php-fcgi-starter in /var/.../php-fcgi-scripts/ispconfig/ and /var/.../php-fcgi-scripts/webx/ folders. There are values called PHP_FCGI_CHILDREN and export PHP_FCGI_CHILDREN which shouldn't be used.

    These values are meant for standalone fcgi server, not for mod_fastcgi or mod_fcgid which handle process creation by themselves. When used with mod_fastcgi or mod_fcgid, these values cause problems.


    Am I correct in assuming that editing /usr/local/ispconfig/server/conf/php-fcgi-starter.master would make these changes default?
    Edit: Apparently I am.

    Edit 2: And apparently PHP_FCGI_MAX_REQUESTS should be set to 500 to prevent a probable race condition.
    Last edited: Aug 30, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thanks for the info. I will take look into this.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I commented out the PHP_FCGI_MAX_REQUESTS variable in the fcgi starter script and uploaded it to svn.
  4. Keeper

    Keeper New Member

    Actually I believe it should be PHP_FCGI_CHILDREN that should be either commented out, or set to 1. And PHP_FCGI_MAX_REQUESTS should be set to 500.

    After some tinkering I noted that it is probably easier to change existing settings this way:
    Go to System / Server Config / FastCGI
    FastCGI Children 1
    FastCGI max. Requests 500

    Not sure if /php-fcgi-scripts/ispconfig/.php-fcgi-starter is used for anything, but just to be on the safe side I edited it manually afterwards. And I left the master file alone since looks like editing System / Server Config / FastCGI is better place to edit the values. Apache probably needs to be restarted to let unnecessary fcgi processes die.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You are right, I meant the PHP_FCGI_CHILDREN variable. I commented them out instead of setting it in server config as this will fix the problem also on existing systems and this setting in server config is not needed until we offer support for e.g. lighttpd.

Share This Page