ISPconfig3, allow relay and outgoing spamfiltering

Discussion in 'Developers' Forum' started by Justin Albstmeijer, Oct 15, 2008.

  1. Justin Albstmeijer

    Justin Albstmeijer New Member

    I could not find an option to allow mail relay from my webserver through the mail server (multi-server setup).

    Added the ipnumer of the webserver to "mynetworks" in /etc/postfix/main.cf.
    Looking a the sql queries postfix does web receiving mail to relay, I would expect to be able to add these ip's through the ispconfig control panel.

    After getting relaying to work by editting main.cf.. mail gets filtered by the spamfiler.
    Any way to disable or control the spam settings of mail being send out/relayed?

    Justin
    Justin
     
  2. till

    till Super Moderator

    The relaying option is not used often. I do not plan to add this to the interface.

    Change the default options in the amavisd configuration to not filter out spam by default or add the demains under Spamfilter > User / Domains with a policy like "Wants all spam".
     
  3. Justin Albstmeijer

    Justin Albstmeijer New Member

    "Change the default options in the amavisd configuration to not filter out spam by default"

    How can I change this default behaviour, which should be overruled if I enable filtering for a curtain mailbox?
     
  4. Justin Albstmeijer

    Justin Albstmeijer New Member

    in my case I had to do the following:

    @bypass_virus_checks_maps = (1);
    @bypass_spam_checks_maps = (1);
    #@bypass_virus_checks_maps = (
    # \%bypass_virus_checks, \@bypass_virus_checks_acl, \$bypass_virus_checks_re);
    #@bypass_spam_checks_maps = (
    # \%bypass_spam_checks, \@bypass_spam_checks_acl, \$bypass_spam_checks_re);

    Is this the correct way, to give ispconfig settings full control on spam/virus filtering... and leave relayed/outgoing mail un-filtered?
     
  5. till

    till Super Moderator

    Yes, as this is one of the options that I wrote above.
     

Share This Page