ISPConfig3 Add a php 7.x version with 5.6 in use (

Discussion in 'Installation/Configuration' started by Pierrot727, Jan 2, 2019.

  1. Pierrot727

    Pierrot727 New Member

    Hello,

    I'm currently using php5.6 for some website in production environement. I need to get the latest version of php 7.x for project using symfony.

    I already tried this tutorial:
    https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/

    But it doesn't work, when i try to use it, i'm stucked in the queue of ispconfig.

    It looks like some steps are missing, i want to install php7.3

    Thanks for your help,

    regards

    P.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I use the tutorial as well, works fine. Just ensure that you switch back to the original php version as described in step 10.
     
  3. Pierrot727

    Pierrot727 New Member

    Ok, i will tried again as soon as my problem of queue will be fixed.

    Look on the topic pleased, thanks for your help, if needed feel free to contact me directly

    regards

    P.
     
  4. Magiodev

    Magiodev New Member

    I suggest you to use the Automated installation, you'll find in the installation logs how to enable 5.6 in addition to the 7.0.
     
  5. Pierrot727

    Pierrot727 New Member

    Ok, now my problem of queue is fixe, i work on install php7.3

    I follow the tutorial for 7.3: no crash, i only get this message now:

    You are missing a required extension to PHP that are requires to run. Please install:

    mbstring (more information)
    xml (more information)

    I tryed:
    apt install php7.3-mbstring
    for the first one, then i restart the daemon an refresh the page: no changes, before making stupid thinks i prefer to ask.
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  7. Pierrot727

    Pierrot727 New Member

    Thanks for your help,

    As far as i know, the install works ... and now, with clearing the cache, i only get xml missing so:

    apt-cache search mbstring show:
    libapache2-mod-php5 - server-side, HTML-embedded scripting language (Apache 2 module)
    libapache2-mod-php5filter - server-side, HTML-embedded scripting language (apache 2 filter module)
    libphp5-embed - HTML-embedded scripting language (Embedded SAPI library)
    php5-cgi - server-side, HTML-embedded scripting language (CGI binary)
    php5-cli - command-line interpreter for the php5 scripting language
    php5-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)
    php5-phpdbg - server-side, HTML-embedded scripting language (PHPDBG binary)
    php-mbstring - MBSTRING module for PHP [default]
    php5.6-mbstring - MBSTRING module for PHP
    php7.0-mbstring - MBSTRING module for PHP
    php7.1-mbstring - MBSTRING module for PHP
    php7.2-mbstring - MBSTRING module for PHP
    php7.3-mbstring - MBSTRING module for PHP

    apt-cache search php xml --names-only show:
    php-horde-xml-element - Horde Xml Element object
    php-horde-xml-wbxml - Horde_Xml_Wbxml provides an API for encoding and decoding WBXML documents used in SyncML and other wireless applications
    php-xml-dtd - Parsing of DTD files and DTD validation of XML files
    php-xml-htmlsax3 - SAX parser for HTML and other badly formed XML documents
    php-xml-parser - XML parsing class based on PHP's bundled expat
    php-xml-rpc - PHP implementation of the XML-RPC protocol
    php-xml-rpc2 - PHP XML-RPC client/server library
    php-xml-rss - php based parser for RSS news feeds
    php5-xmlrpc - XML-RPC module for php5
    php-pear - PEAR Base System
    php-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP [default]
    php-xmlrpc - XMLRPC-EPI module for PHP [default]
    php5.6-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    php5.6-xmlrpc - XMLRPC-EPI module for PHP
    php7.0-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    php7.0-xmlrpc - XMLRPC-EPI module for PHP
    php7.1-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    php7.1-xmlrpc - XMLRPC-EPI module for PHP
    php7.2-xml - DOM, SimpleXML, WDDX, XML, and XSL module for PHP
    php7.2-xmlrpc - XMLRPC-EPI module for PHP
    php7.3-xmlrpc - XMLRPC-EPI module for PHP

    So the mbstring looks like fixed, and xml not: i also try:
    apt-get install php7.3-xml

    intially it fail indicating me that there is a 404 and i need apt update, and after update and upgrade it works. But no changes: i still get the error. The past of the command post here "apt-cache search php xml --names-only" is done, after this try of installation ...

    Thanks :)
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    On my host there is php7.3-xml:
    Code:
    [email protected]:~# LANG=C apt-cache policy php7.3-xml
    php7.3-xml:
      Installed: (none)
      Candidate: 7.3.0-2+0~20181217092659.24+stretch~1.gbp54e52f
      Version table:
         7.3.0-2+0~20181217092659.24+stretch~1.gbp54e52f 500
            500 https://packages.sury.org/php stretch/main amd64 Packages
    [email protected]:~#
    
    I have not yet installed PHP 7.3, don't trust it just yet.
    Have you run
    Code:
    apt-get update
    before that apt-cache search? Or are you not using the same sury repository?
    Code:
    [email protected]:~# cat   /etc/apt/sources.list.d/php.list
    deb https://packages.sury.org/php/ stretch main
    
     
  9. Pierrot727

    Pierrot727 New Member

  10. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You are using the repo for Debian Jessie, that is version 8.x. I run Debian 9.x Stretch, so I use the repository for stretch.
     

Share This Page