ispconfig2 and webdav

Discussion in 'General' started by poisen, Feb 25, 2010.

  1. poisen

    poisen New Member

    Hey everybody,

    I got a problem. I've been reading a lot about using webdav with ispconfig2, now I just setup a new web called "data.xyz.com" and tried making a connection to it. FTP is NOT enabled, I want to use the webdav to mount a network share and use it as some swap space for some of my files. Sadly, whatever I do, I just cannot get a connection to it. What am I doing wrong or is there anything else I have to watch out for? My user is Admin and webdav is for the user enabled.

    I'd be happy to get some help.
     
  2. jnsc

    jnsc rotaredoM Moderator

    1. Enable webdav for this site
    2. Create a user and allow him to do webdav (by checking the webdav box)
    3. connect by www.example.com/webdav

    That should do it.
     
  3. poisen

    poisen New Member

    This is what I've been trying already like 1000 times and it doesn't work, when I enter www.example.com/webdav in the browser, I get a 404 error. When I try setting up a network drive in windows it keeps prompting me to enter a password.
     
  4. poisen

    poisen New Member

    I just tried using Webdrive to setup a connection, this is the error I got:

    Connecting to site example.com
    Connecting to example.com/webdav
    Resolving url example.com to an IP address
    Url resolved to IP address 12.12.12.12
    Connecting to 12.12.12.12 on port 80
    Connected successfully to the server on port 80
    Testing directory listing ...

    Unable to connect to server, error information below

    Error: HTTP Error response received from server, erorr=405 (4516)
    Operation: Connecting to server
    Server Response: 405 Method Not Allowed
     
  5. jnsc

    jnsc rotaredoM Moderator

    What is in your apache error logs?
     
  6. poisen

    poisen New Member

    [Fri Feb 26 11:19:32 2010] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /srv/www/htdocs/
    [Fri Feb 26 11:19:40 2010] [error] an unknown filter was not added: PHP

    Those are errors that are from some other misconfiguration which I've just resolved ... otherwise there are no errors in the apache error_log when I am trying to connect using webdav and the connection fails.
     
    Last edited: Feb 26, 2010
  7. poisen

    poisen New Member

    I've been trying many many times now to set up WebDAV Support in ISPConfig 2.2.35 but it just doesn't work.

    This is part of the Apache access_log when I'm trying to connect through MacOSX
    This is what comes up in the apache access_log when trying to connect with TeamDrive
    WebDav is activated for the reseller, this is the part out of the Vhosts_ispconfig.conf
    Can anybody else help me on this problem? It would be very very important for me to have this feature working.

    Thanks a lot,

    Eddie
     
    Last edited: Mar 1, 2010
  8. falko

    falko Super Moderator ISPConfig Developer

  9. poisen

    poisen New Member

  10. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in the error log of that web site (in the /srv/www/web102/log folder)?
     
  11. poisen

    poisen New Member

    Hi falko,

    these are the erros out of /srv/www/web102/log/error.log

    These are the messages found in the web.log

     
    Last edited: Mar 4, 2010
  12. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /srv/www/web102/web/
    ?
     
  13. poisen

    poisen New Member

    this ist he output when I run: ls -la /srv/www/web102/web/

     
  14. falko

    falko Super Moderator ISPConfig Developer

    Hm... Looks ok. Is AppArmor disabled?
     
  15. poisen

    poisen New Member

    AppArmor is disabled :-( I don't really know what else could be wrong.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    I have no idea either... :(
     

Share This Page