ISpconfig work but

Discussion in 'Installation/Configuration' started by peacengell, Jan 26, 2008.

  1. peacengell

    peacengell Member

    why named donot start and apache is working
    see attachment thanks for any help
    on centos 5.1 i follow the tut perfect server setup
    [root@server ~]# /etc/init.d/named restart
    Stopping named: [FAILED]
    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/var/named/chroot/var/named' failed: file not found

    /etc/named.conf:3: parsing failed
    [FAILED]
    [root@server ~]#
     

    Attached Files:

  2. falko

    falko Super Moderator ISPConfig Developer

    Did you set up BIND exactly as shown in the Perfect Setup?
     
  3. peacengell

    peacengell Member

    yes i did

    ok i will try again to setup bind dns ok thanks i will do it today ok then i will post coment thanks see u
     
  4. peacengell

    peacengell Member

    bind configure again same problem

    [root@server ~]#
    [root@server ~]# chmod 755 /var/named/
    [root@server ~]#
    [root@server ~]# chmod 775 /var/named/chroot/
    [root@server ~]#
    [root@server ~]# chmod 775 /var/named/chroot/var/
    [root@server ~]#
    [root@server ~]# chmod 775 /var/named/chroot/var/named/
    [root@server ~]#
    [root@server ~]# chmod 775 /var/named/chroot/var/run
    [root@server ~]#
    [root@server ~]# chmod 777 /var/named/chroot/var/run/named/
    [root@server ~]#
    [root@server ~]# cd /var/named/chroot/var/named/
    [root@server named]# ln -s ../../chroot
    ln: creating symbolic link `./chroot' to `../../chroot': File exists
    [root@server named]# cp /usr/share/doc/bind-9.3.3/sample/var/named/named.local

    /var/named/chroot/var/named/named.local
    cp: overwrite `/var/named/chroot/var/named/named.local'? y
    [root@server named]# cp /usr/share/doc/bind-9.3.3/sample/var/named/named.root

    /var/named/chroot/var/named/named.root
    cp: overwrite `/var/named/chroot/var/named/named.root'? y
    [root@server named]# touch /var/named/chroot/etc/named.conf
    [root@server named]# chkconfig --levels 235 named on
    [root@server named]# /etc/init.d/named start
    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/var/named/chroot/var/named' failed: file not found

    /etc/named.conf:3: parsing failed
    [FAILED]
    [root@server named]#
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    ls -la /var/named/chroot/var/named
     
  6. peacengell

    peacengell Member

    ls -la /var/named/chroot/var/named out put .....

    [root@server ~]# ls -la /var/named/chroot/var/named
    total 52
    drwxr-xr-x 4 root named 4096 Jan 26 23:11 .
    drwxrwxr-x 5 root named 4096 Jan 25 20:54 ..
    lrwxrwxrwx 1 root root 12 Jan 26 00:13 chroot -> ../../chroot
    drwxrwx--- 2 named named 4096 Aug 25 2004 data
    -rwxrwxr-x 1 root root 426 Jan 27 20:40 named.local
    -rwxrwxr-x 1 root root 2518 Jan 27 20:40 named.root
    drwxrwx--- 2 named named 4096 Jul 27 2004 slaves
    [root@server ~]#


    thanks for help man
     
  7. peacengell

    peacengell Member

    hi doing debian server from start again problem

    why i getting this error please help


    where the error is
    server1:/# /etc/init.d/bind9 restart
    stoping domain name service ...:bindrndc: connect fail: 127.0.0.1#953:
    connection refused
    fail!
    starting domain name service ...:bind failed!
    server1:/#
    why this any explanation please
    after instaling ISPConfig today help i'm die......
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Did you follow the Perfect Setup as close as possible? What's in /etc/default/bind9?
     
  9. peacengell

    peacengell Member

    hi everything work fine after one hour

    hi everythind works fine after one hour :confused:
    i done nothing just done everything as shown on the tut:D

    now i need a how to for ispconfig
    to setup all stuff need for a website and howto host website on lan
    cose my router get disconet from internet wen i enable NAT ...
    so i need to use my sever on lan is there any how to thanks
    for help i try but don't work thanks ...:eek:
    :confused:
     

Share This Page