ISPConfig wont update anymore

Discussion in 'General' started by neumann, Jul 16, 2019.

  1. neumann

    neumann New Member

    I am suspecting that there is a lock of the cronfile or similar. I have 23 items in the red dot, and they keep adding up as I try things.

    I tried to unlock the ISPconfig lockfile:
    rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock

    Then I try to see what is happening:
    /usr/local/ispconfig/server/server.sh

    And I get this answer:
    16.07.2019-09:20 - WARNING - There is already a lockfile set, but no process running with this pid (32465). Continuing.

    PHP Fatal error: Uncaught Error: Call to undefined function curl_init() in /usr/local/ispconfig/server/lib/classes/aps_installer.inc.php:627
    Stack trace:
    #0 /usr/local/ispconfig/server/plugins-available/aps_plugin.inc.php(87): ApsInstaller->installHandler('1', 'install')
    #1 /usr/local/ispconfig/server/lib/classes/plugins.inc.php(120): aps_plugin->install('aps_instance_up...', Array)
    #2 /usr/local/ispconfig/server/mods-available/web_module.inc.php(170): plugins->raiseEvent('aps_instance_up...', Array)
    #3 /usr/local/ispconfig/server/lib/classes/modules.inc.php(285): web_module->process('aps_instances', 'u', Array)
    #4 /usr/local/ispconfig/server/lib/classes/modules.inc.php(218): modules->raiseTableHook('aps_instances', 'u', Array)
    #5 /usr/local/ispconfig/server/server.php(180): modules->processDatalog()
    #6 {main}
    thrown in /usr/local/ispconfig/server/lib/classes/aps_installer.inc.php on line 627

    What can I do further to make ISPConfig work again?

    Best regards
    Neumann
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you installed the PHP curl module. Install it again.
     
  3. neumann

    neumann New Member

    if I do it like apt-get install php7.0-curl, it tells me that I allready have the latest version.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Run the command:

    php --version

    as root and post the result. Maybe you use a different PHP version on the shell.
     
  5. neumann

    neumann New Member

    You were right. :) I use php version 7.3 and updated the curl.
    But now I get this message:
    PHP Fatal error: Uncaught Error: Class 'ZipArchive' not found in /usr/local/ispconfig/server/lib/classes/aps_installer.inc.php:106
    Stack trace:
    #0 /usr/local/ispconfig/server/lib/classes/aps_installer.inc.php(655): ApsInstaller->getContentFromZIP('/usr/local/ispc...', 'APP-META.xml')
    #1 /usr/local/ispconfig/server/plugins-available/aps_plugin.inc.php(87): ApsInstaller->installHandler('1', 'install')
    #2 /usr/local/ispconfig/server/lib/classes/plugins.inc.php(120): aps_plugin->install('aps_instance_up...', Array)
    #3 /usr/local/ispconfig/server/mods-available/web_module.inc.php(170): plugins->raiseEvent('aps_instance_up...', Array)
    #4 /usr/local/ispconfig/server/lib/classes/modules.inc.php(285): web_module->process('aps_instances', 'u', Array)
    #5 /usr/local/ispconfig/server/lib/classes/modules.inc.php(218): modules->raiseTableHook('aps_instances', 'u', Array)
    #6 /usr/local/ispconfig/server/server.php(180): modules->processDatalog()
    #7 {main}
    thrown in /usr/local/ispconfig/server/lib/classes/aps_installer.inc.php on line 106


    /neumann
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You use Debian or Ubuntu? Then better use update-alternatives command to switch the system PHP back to the one that belongs to the OS version, you will get lots of trouble otherwise. Using a newer PHP versiona s additional PHP is fine, but don't alter the default version.
     
  7. neumann

    neumann New Member

    To be honest I'm not sure how I have come to this. But I run Ubuntu 16.04, and at that time only php5 was supported. So along the ride I have updated to later php versions. But now it seems to go wrong. It worked fine for me to ugrade to php7. But then roundcube didn't work anymore, and I tried some guides online to upgrade roundcube. I might have chosen the wrong guide, because after that I lost ispconfig database, and had to reinstall ispconfig. And now I'm in this problem.
    I want to restart with a new server, and install ubuntu 18.04lts, and start all over with a fresh install. But for now it is just to save the (few) email clients I have. I feel a little resposibility towards them. :)

    /neumann
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Try installing the php zip extension.
     
  9. neumann

    neumann New Member

    Well I went back and took a look at the new install I made of ISPCOnfig. And I looked at which php version is installed in your fantastic guide "the perfect server". And at that point it was apparently php7.0. But I know that I have earlier tried to install php7.2 and even php7.3.

    So I thought why not take the perfect server guide and change all the installs of php7.0 with php7.3. So I did, and now it seems that ISPConfig is updating again and no errors reported when I run:
    /usr/local/ispconfig/server/server.sh
     
    ahrasis likes this.

Share This Page