ISPConfig Won't Recognize Sites

Discussion in 'Installation/Configuration' started by midcarolina, Jan 10, 2012.

  1. midcarolina

    midcarolina New Member

    I have been banging my head against the wall...have tried everything imaginable and ISPConfig will simply NOT override the DirectoryIndex in Apache and launch a site.

    In /etc/httpd/conf/sites-enabled/000-ispconfig.conf every ip I have placed on the server is there with :80 and :443

    In the database, EVERY single IP that is listed in the above is in server_ip table.

    In ISPConfig CPanel, EVERY single IP I have created is listed exactly

    Running ifconfig, EVERY single IP is present

    Running ifconfig -a EVERY single IP is present

    In /etc/httpd/conf/sites-enabled/100-example.com.vhost THE IP is there.

    BUT EVERY error code wants to send apache to the test page. EVERY site, EVERY time. Can someone PLEASE PLEASE help me with this. It is driving me crazy!

    [Tue Jan 10 14:54:58 2012] [notice] mod_python: Creating 4 session mutexes based on 19000 max processes and 0 max threads.
    [Tue Jan 10 14:54:58 2012] [notice] mod_python: using mutex_directory /tmp
    [Tue Jan 10 14:54:58 2012] [notice] SSL FIPS mode disabled
    [Tue Jan 10 14:54:58 2012] [notice] Apache/2.2.21 (Unix) DAV/2 mod_fcgid/2.3.6 PHP/5.3.8 mod_python/3.3.1 Python/2.7.1 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.21 OpenSSL/1.0.0e-fips mod_perl/2.0.4 Perl/v5.12.4 configured -- resuming normal operations
    [Tue Jan 10 14:55:02 2012] [error] [client ::1] Directory index forbidden by Options directive: /var/www/
    [Tue Jan 10 14:55:02 2012] [error] [client ::1] Directory index forbidden by Options directive: /var/www/
    [Tue Jan 10 14:55:03 2012] [error] [client 66.249.71.13] File does not exist: /var/www/tag
    [Tue Jan 10 14:55:14 2012] [error] [client 178.162.248.85] File does not exist: /var/www/2011
    [Tue Jan 10 14:55:20 2012] [error] [client 66.249.71.86] File does not exist: /var/www/tag
    [Tue Jan 10 14:55:41 2012] [error] [client 66.249.71.86] File does not exist: /var/www/tag
    [Tue Jan 10 14:55:42 2012] [error] [client 173.93.151.171] Directory index forbidden by Options directive: /var/www/
    [Tue Jan 10 14:55:48 2012] [error] [client 173.93.151.171] Directory index forbidden by Options directive: /var/www/
    [Tue Jan 10 14:55:49 2012] [error] [client 150.214.40.112] File does not exist: /var/www/wp-content, referer: http://www.ipmart-forum.es/showthread.php?t=79468
    [Tue Jan 10 14:55:53 2012] [error] [client 173.93.151.171] Directory index forbidden by Options directive: /var/www/
    [Tue Jan 10 14:55:57 2012] [error] [client 66.249.71.86] File does not exist: /var/www/tag
    [Tue Jan 10 14:55:57 2012] [error] [client 173.93.151.171] Directory index forbidden by Options directive: /var/www/
    [Tue Jan 10 14:56:01 2012] [error] [client ::1] Directory index forbidden by Options directive: /var/www/
    [Tue Jan 10 14:56:28 2012] [error] [client 65.52.104.84] File does not exist: /var/www/members
    [Tue Jan 10 14:56:28 2012] [error] [client 65.52.104.84] File does not exist: /var/www/stories
    [Tue Jan 10 14:56:34 2012] [error] [client 69.86.124.51] File does not exist: /var/www/buttons, referer: http://www.vertigoshtick.com/2010/08/song-for-hump-day-madonna-justify-my.html
    [Tue Jan 10 14:56:38 2012] [error] [client 66.249.71.13] File does not exist: /var/www/tag
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Please post the vhost file of the affected website from /etc/httpd/conf/sites-enabled/ directory.
    2) Do you run your server behind a router?
    3) Post the output of the command:

    ifconfig
     
  3. midcarolina

    midcarolina New Member

    Till,

    In Order (all three site files are acting the same and are all similar)

    1. <Directory /var/www/articlecomposition.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost 192.168.11.168:80>
    DocumentRoot /var/www/clients/client2/web3/web

    ServerName articlecomposition.com
    ServerAlias www.articlecomposition.com
    ServerAdmin [email protected]

    ErrorLog /var/log/ispconfig/httpd/articlecomposition.com/error.log


    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 502 /error/502.html
    ErrorDocument 503 /error/503.html

    <IfModule mod_ssl.c>
    </IfModule>
    <Directory /var/www/articlecomposition.com/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>
    <Directory /var/www/clients/client2/web3/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>

    <IfModule mod_ruby.c>
    <Directory /var/www/articlecomposition.com/web>
    Options +ExecCGI
    </Directory>
    RubyRequire apache/ruby-run
    #RubySafeLevel 0
    <Files *.rb>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
    </Files>
    <Files *.rbx>
    SetHandler ruby-object
    RubyHandler Apache::RubyRun.instance
    </Files>
    </IfModule>

    <IfModule mod_python.c>
    <Directory /var/www/articlecomposition.com/web>
    AddHandler mod_python .py
    PythonHandler mod_python.publisher
    PythonDebug On
    </Directory>
    </IfModule>

    # cgi enabled
    <Directory /var/www/clients/client2/web3/cgi-bin>
    Order allow,deny
    Allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/clients/client2/web3/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # suexec enabled
    SuexecUserGroup web3 client2
    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    # suphp enabled
    <Directory /var/www/clients/client2/web3/web>
    <IfModule mod_suphp.c>
    suPHP_Engine on
    # suPHP_UserGroup web3 client2
    AddHandler x-httpd-suphp .php .php3 .php4 .php5
    suPHP_AddHandler x-httpd-suphp
    </IfModule>
    </Directory>


    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web3 client2
    </IfModule>

    <IfModule mod_dav_fs.c>
    # Do not execute PHP files in webdav directory
    <Directory /var/www/clients/client2/web3/webdav>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN
    # WEBDAV END
    </IfModule>


    </VirtualHost>

    2. Do I run my boxes behind a router? Yes. The EXACT same router is running the EXACT same Linux set-up (OS Version AND router type) on and older ISPConfig 3 version with a dummy index.html file in /var/www/html/index.html. That server runs perfectly.

    3. Output of ifconfig:

    This is coming in two seconds. I cannot copy / paste from the SSH terminal. (From my second laptop)
     
  4. midcarolina

    midcarolina New Member

    Ok, number 3. Output of ifconfig:

    eth0 Link encap:Ethernet HWaddr 6C:FD:B9:24:DA:F0
    inet addr:192.168.11.5 Bcast:192.168.11.255 Mask:255.255.255.0
    inet6 addr: fe80::6efd:b9ff:fe24:daf0/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:67730 errors:0 dropped:0 overruns:0 frame:0
    TX packets:56094 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:48506637 (46.2 MiB) TX bytes:9960575 (9.4 MiB)
    Interrupt:10 Base address:0xcc00


    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:13499 errors:0 dropped:0 overruns:0 frame:0
    TX packets:13499 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2322697 (2.2 MiB) TX bytes:2322697 (2.2 MiB)

    [[email protected] ~]#
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Please check your router settings and ensure that port 80 of the external IP 24.172.54.150 is forwarded to the internal IP address 192.168.11.168 .It is very important that it is forwarded to this exact IP and not any other IP address even if the IP is on the same server.

    2) Post the httpd.conf file of your server. You can zip it and attache the zip file to the post instead of posting the file content it inside the post.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The IP address of this server is "192.168.11.5" and you selected IP "192.168.11.168" for the website. Apache can not show the website if the IP's dont match.

    So please dont do what I posted in 1) in my last post, instead change the IP address 192.168.11.168 to 192.168.11.5 in ISPConfig under System > Server IP. Then go to the website settings of the site articlecomposition.com and select 192.168.11.5 as IP for the website. Then wait a 2 minutes until ispconfig has written the new configuration.
     
  7. midcarolina

    midcarolina New Member

    Ok, with respect to the router, please rest assured that I have three of these EXACT same routers with the EXACT same setup, so this can't be the issue. I have two other boxes with the same routers...older version of ISPConfig 3 with dummy index.html file that fixed all. These boxes are identical in every way, shape and form.

    The httpd.conf .zip is attached
     

    Attached Files:

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Read #6 again. I explained you that you used wrong IP's and that this can not work. You are able to understand that 192.168.11.168 and 192.168.11.5 are not the same IP and If you tell apache that the that the vhost has IP 192.168.11.168 while the network address is 192.168.11.5 so that the vhost can never match??
     
  9. midcarolina

    midcarolina New Member

    Ok, this makes no sense. Several reasons. What is the purpose of these items:

    ifcfg-eth0
    ifcfg-eth0:0
    ifcfg-eth0:1 OR alternatively,

    ifcfg-eth0-range0 w/ IPADDR_START= and IPADDR_END= CLONENUM, etc.

    or still better yet, what is the purpose of the functionality of adding IPs in ISPConfig at all?

    Load balancing, resource allocation, security (SSL, etc.), predefined IPs for resellers and clients for this purpose.

    I.E. One may as well use only the WAN IP....
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    As you dont want to change the settings that I recommended to change, I cant help you. You seem to not want to get your problem solved,so I will stop here now.

    I recommend that you read the ISPConfig 3 manual if you want to know the detailed purpose of all the fields in ISPConfig, I will not retype the 300+ pages here for you.
     
  11. midcarolina

    midcarolina New Member

    I have the manual (which is Debian based), and no, I do not want to run 100 or so websites on one LAN IP. My other boxes are running eth0-range0 with the same router and set-up with numerous websites on different LAN ips.

    There is an apparent misconfiguration in the update which I will have to find on my own. No one runs 100 websites on a single LAN IP...unheard of!
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Nobody talked here about running hundred sites on one IP, which is no problem by the way with current apache versions.

    Maybe you should start to get the first site working instead of having hundred not working sites ;)

    I see that you still dont got it that you had the same problem with ispconfig 2 and ispconfig 3, the shared IP page is the exact same issue. The reason are not matching IP / vhost combinations as i told you already several days ago and what you cinstantly ignored.

    If you want to use more IP addresses, then you should add them first in your network card which you havent done yet as they dont show up in the ifconfig command. The shell command for redhat based distributions to do that is system-config-network if I remeber correctly.

    Beside that, the IP / vhost must match, so you have to reconfigure the sites and router to use the same IP's.

    By the way, the ISPConfig manual is for all Linux distributions, only the multiserver guides are for debian.
     
  13. midcarolina

    midcarolina New Member

    For RedHat / Fedora / Centos, it is as simple as creating a new network-scripts file ifcfg-eth0-range0 as long as the IPs are in the same family.

    Restarting the network # service network restart then ifconfig -a

    Where you will see written eth0:0, eth0:1, eth0:2, etc., etc. Done it numerous times with no problems. It was running this exact same way using the ISPConfig setup two days ago. ifconfig -a showed every ip produced in the range, yet the index page for "shared ip" continued to resolve until I formatted the Raid system.
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    You posted the ifconfig output in #4 of this thread and there you can see in your own post that the IP's are not configured.
     
  15. midcarolina

    midcarolina New Member

    [SOLVED] ISPConfig 3.0.4.2 Set-up Fedora 15 x86_64

    For those that have been following this thread and were having problems getting your site launched, the following instructions fixed the problem. PLEASE NOTE:

    This may not apply to all Linux OS. This is specific to Fedora 15 x86_64 using ISPConfig 3.0.4.2

    1. Open Apache's welcome.conf, like:

    vi /etc.httpd/conf.d/welcome.conf and remove the "-" from Options -Indexes like

    FROM THIS:

    <LocationMatch “^/+$”>
    Options -Indexes
    ErrorDocument 403 /error/noindex.html
    </LocationMatch>

    TO THIS:

    <LocationMatch “^/+$”>
    Options Indexes
    ErrorDocument 403 /error/noindex.html
    </LocationMatch>

    Next, you will need to make two corrections in the httpd.conf file:

    vi /etc/httpd/conf/httpd.conf

    Change DocumentRoot from "/var/www/html" to "/var/www"

    Next, change the <Directory "/var/www/html"> to

    <Directory "/var/www">

    Then, locate the DirectoryIndex and revise it to look like this:

    DirectoryIndex index.html index.htm index.shtml index.php

    Finally, restart Apache server

    [[email protected] ~]# service httpd restart

    Wala! Your site should now launch....
     

Share This Page