ISPConfig wont accept new certificate

Discussion in 'Installation/Configuration' started by Keagan, Feb 4, 2019.

Tags:
  1. Keagan

    Keagan New Member

    I was using certificate which expired. I requested new one with new private key and request file.

    But when I add new certificate to ISPConfig vhost, even after running

    Code:
     /usr/local/ispconfig/server/server.sh 
    the new certificate wont be accepted by ISPConfig and is still using the old one which expired, so my site is not working with HTTPS. Is there possibility that ISPConfig have this old certificate stored somewhere?

    I also deleted content of SSL folder in my vhost but did not worked either. Site is working with generated Let's Encrypt certificate.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The cert is stored in ISPConfig DB (that what you see in the UI) and in the ssl folder of the site (when you choose 'save certificate' as option in ISPConfig UI). There are no other places where it is saved.
     
  3. Keagan

    Keagan New Member

    I deleted content of /var/www/vhost/ssl/ but there is no change. It still wont use new certificate which I provided. Checked modulus of key and certificate and it's same so there is not issue in cert/key pair.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. Keagan

    Keagan New Member

    Nothing specific there...

    Code:
    Tue Feb 5 09:56:02 CET 2019 setquota: Not setting inode grace time on /dev/vda1 because softlimit is not exceeded.
    Tue Feb 5 09:56:08 CET 2019 setquota: Not setting block grace time on /dev/vda1 because softlimit is not exceeded.
    Tue Feb 5 09:56:08 CET 2019 setquota: Not setting inode grace time on /dev/vda1 because softlimit is not exceeded.
    Tue Feb 5 09:56:19 CET 2019 finished.
    Tue Feb 5 09:57:01 CET 2019
    Tue Feb 5 09:57:01 CET 2019
    Tue Feb 5 09:57:01 CET 2019 finished.
                
    
    finished.
    
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You did not enable debugging. See the link that I posted above on how to enable debugging and get debug output.
     
  7. Keagan

    Keagan New Member

    Not much changed after setted up to debug.
    setquota: Not setting block grace time on /dev/vda1 because softlimit is not exceeded.
    setquota: Not setting inode grace time on /dev/vda1 because softlimit is not exceeded.
    setquota: Not setting block grace time on /dev/vda1 because softlimit is not exceeded.
    setquota: Not setting inode grace time on /dev/vda1 because softlimit is not exceeded.
     
  8. Keagan

    Keagan New Member

    Had to delete all files with the domain which were not able to renew Let's Encrypt certificate from /etc/letsencrypt/ and disable and enable ssl in ISPConfig.
     

Share This Page