ISPConfig with postfix problem

Discussion in 'General' started by Chrisssssss, Jan 16, 2007.

  1. Chrisssssss

    Chrisssssss New Member

    This is /etc/hosts

    Code:
    # 
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    
    
    
    127.0.0.1              localhost.localdomain localhost
    85.17.97.14             cip001.france-tracker.net
    
    this is /etc/host.conf
    Code:
    order hosts,bind
    ~
    ~
    ~
    
    and this is /etc/resolv.conf
    Code:
    search www.france-tracker.net
    nameserver 85.17.97.14
    
     
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    I think you run your own DNS, right? If yes, comment both lines in resolv.conf. The DNS forward should be done in your own Bind/Named configuration with the 'forward' directive.

    The 'search www.france-tracker.net' line should be commented out, if you have your hosts/DNS oke. Your system is now trying to find local.localdomain.www.france-tracker.net, which I'm pretty sure, does not exist.
     
  3. Chrisssssss

    Chrisssssss New Member

    Hello thanks for your help
    Yes I use Bind for my DNS and I dont have a ligne whith local.localdomain.www.france-tracker.net But my english and my administration is not good i am studied this. And I not sure to understand very well this.
    Whats I do modifie for repar my probleme please
     
  4. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Edit /etc/resolv.conf to make it look like:
    Code:
    # search www.france-tracker.net
    nameserver 85.17.97.14
    for starters. The # sign means to turn a line into a comment. Check if sending mail now works. If not, the next step is to change the way address resolving is done. We'll do that if this step does not work. Oke?
     
  5. Chrisssssss

    Chrisssssss New Member

    Thanks for your help I test this
     
  6. Chrisssssss

    Chrisssssss New Member

    After to change this my mail server accept to send mail but mail don t enter
    I have reload postfix after this change.
    And after has reput this to
    search www.france-tracker.net
    nameserver 85.17.97.14
    my serveur mail dont restart correctly it s refused my mail but I have still the mail not delivery
     
    Last edited: Jan 20, 2007
  7. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    I did some more testing:
    Code:
    :~# [COLOR="DarkRed"]dig MX france-tracker.net[/COLOR]
    
    ; <<>> DiG 9.3.2-P1 <<>> MX france-tracker.net
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18558
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;france-tracker.net.            IN      MX
    
    ;; AUTHORITY SECTION:
    france-tracker.net.     3559    IN      SOA     ns1.domainpeople.com. root.domainpeople.com. 2001050903 28800 14400 3600000 3600
    
    ;; Query time: 3 msec
    ;; SERVER: 172.16.3.70#53(172.16.3.70)
    ;; WHEN: Sat Jan 20 17:08:53 2007
    ;; MSG SIZE  rcvd: 97
    
    Apparantly you have not set your DNS MX record. Thus, external sites do not know to which server / IP they have to connect to deliver mail.

    To setup a MX record, go to your DNS manager in ISPConfig, click on your site, and go to the tab 'records'.

    Scroll down till you see MX with a new button. I think there's no entry for MX, right? Click on the new button, leave the hostname field empty and enter your system name (cip001.france-tracker.net) in the mailserver field. Press save.

    Now this is DNS, so it may take a while before it is propagated all over the world. You can check this yourself. Mail should start to work by using the dig command above. You should see a line somewhere in the middle saying:
    Code:
    ......
    ;; ANSWER SECTION:
    france-tracker.net.              86400   IN      MX      10 cip001.france-tracker.net.
    .....
    
    Then start testing your email again.
     
  8. Chrisssssss

    Chrisssssss New Member

    Thanks for your reponse but I am not sour to file to modify /etc/named.conf or /var/named/france-tracker.zone or another file but I dont wont to modifiy the bad file.
    I your answer waits and thanks for this :)
     
  9. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Sorry, I have no idea what your trying to say. Did I mention anything about changing /etc/named.conf or /var/named/france-tracker.zone ? No, I told you the steps in the grafical interface of ISPConfig, which I assume you use, as you posted your question in the ISPConfig forum and you state "ISPConfig & postfix error".

    Please do the steps as I described in my previous post in ISPConfig and the actual files will be modified in the right locations in the right place for you. No manual editing. If you get errors, we'll start over from there.

    Without a MX record, you will never receive email from the internet.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Please put
    Code:
    order hosts,bind
    multi on
    in /etc/host.conf and run
    Code:
    postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
    postconf -e 'mydestination = /etc/postfix/local-host-names'
    /etc/init.d/postfix restart
     
  11. Chrisssssss

    Chrisssssss New Member

Share This Page