ISPconfig with Dovecot

Discussion in 'Installation/Configuration' started by FredZ, Oct 7, 2009.

  1. FredZ

    FredZ New Member

    Hello all

    I am attempting to install ISPconfig as per this. I don't like Courier so I am installing dovecot instead.

    All I have done is replace the Courier install with "apt-get install dovecot*" which installs dovecot-common dovecot-dev dovecot-imapd dovecot-pop3d, yes I am aware dovecot-dev is not required.

    For obvious reasons (dovecot doesn't come with it) I didn't do the SSL certificate thing.

    After ISPconfig has finished installing I install the squirrelmail.pkg and attempt to login. It fails all the time. Yes I sent a welcome message to the email account first.

    This is all being done on a second machine in an effort to resolve a problem I have with setting up a global webmail client.

    If someone would be so kind as to point me in the right direction I would be most greatful.

    Regards

    Fred
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
     
  3. FredZ

    FredZ New Member

    OK, have had to reinstall it all again, tried copying messages from existing server to new server using imapsync.

    Here is what is in the mail.log
    Code:
    Oct  8 17:04:41 web2 dovecot: imap-login: Disconnected: user=<********@********.com>, method=PLAIN, rip=192.168.0.25, lip=192.168.0.25, secured
    Note:
    I had to use PLAIN as the auth type for the server with dovecot as no other auth types are supported.

    Here is the command I am using and the results:
    Code:
    web2:~# imapsync --host1 192.168.0.31 --user1 *****@*****.com --password1 ***** --host2 192.168.0.25 --user2 *****@*****.com --password2 ***** --authmech1 LOGIN --authmech2 PLAIN
    $RCSfile: imapsync,v $ $Revision: 1.252 $ $Date: 2008/05/08 02:30:17 $
    Here is a [linux] system (Linux web2.corpcomp.co.nz 2.6.26-2-686 #1 SMP Wed Aug 19 06:06:52 UTC 2009 i686)
    with perl 5.10.0 and the module Mail::IMAPClient version used here is 2.2.9
    Command line used :
    /usr/bin/imapsync --host1 192.168.0.31 --user1 *****@*****.com --password1 ***** --host2 192.168.0.25 --user2 *****@*****.com --password2 ***** --authmech1 LOGIN --authmech2 PLAIN
    Turned ON syncinternaldates, will set the internal dates on host2 same as host1.
    TimeZone :[NZDT]
    Will try to use LOGIN authentication on host1
    Will try to use PLAIN authentication on host2
    From imap server [192.168.0.31] port [143] user [*****@*****.com]
    To   imap server [192.168.0.25] port [143] user [*****@*****.com]
    Banner : * OK Dovecot ready.
    Host 192.168.0.31 says it has CAPABILITY for AUTHENTICATE LOGIN
    Success login on [192.168.0.31] with user [*****@*****.com] auth [LOGIN]
    Banner : * OK Dovecot ready.
    Host 192.168.0.25 says it has CAPABILITY for AUTHENTICATE PLAIN
    Error login : [192.168.0.25] with user [*****@*****.com] auth [PLAIN]: 2 NO Authentication failed.
    
    Trying LOGIN Auth mechanism on [192.168.0.25] with user [*****@*****.com]
    Error login : [192.168.0.25] with user [*****@*****.com] auth [LOGIN] : 3 NO Authentication failed.
    web2:~#
    So I conclude from this that auth on the new ISPconfig system with dovecot isn't working. I have no idea as to why or what to look for.

    Regards

    Fred
     
  4. jnsc

    jnsc rotaredoM Moderator

Share This Page