ISPConfig went away , not starting

Discussion in 'General' started by zyzzza, May 13, 2020.

  1. zyzzza

    zyzzza New Member

    Hi,
    My install was working quite cool on:

    ssd.domain.com:8080 , I also had ssd.domain.com as a domain in ispconfig itself, and had letsecrypt done with https://github.com/ahrasis/LE4ISPC

    Today i couldnt login into ISP as it stated certificate was invalid , i ran update to git-stable , and got this in the middle of install :
    Code:
    Broadcast message from [email protected] (Wed 2020-05-13 20:42:00 GMT):
    Password entry required for 'Enter passphrase for SSL/TLS keys for ssd.domain.com:443 (RSA):' (PID 18786).
    Please enter password with the systemd-tty-ask-password-agent tool!
    
    Tho i dont remeber any password used for SSL .
    So long story short - i have reupdated ISP several times, reconfigured the main certificate of ISP during update, and removed ssd.domain.com config from apache enabled site . So for now all seems like working, except ISP. And if i enable ssd.domain.com - it would again ask for password and would not allow apache to start.

    Theoretically i could have used ISP panel to remove SSL from ssd.domain.com , but as ISP does not start (not accessible on 8080 port) i cannot do anything.

    Anyone would have any thoughts on how to fix this ?
    Thanks
     
  2. zyzzza

    zyzzza New Member

    UPD: Found out , that privatekey and fullchain in where updated in /etc/letsencrypt/archive/ssd.domain.com , and in private key it has :

    -----BEGIN RSA PRIVATE KEY-----
    Proc-Type: 4,ENCRYPTED
    DEK-Info: DES-EDE3-CBC,....

    Any ideas how this could have happened ?
     

Share This Page