ISPConfig web - only header loading - SOLVED

Discussion in 'Installation/Configuration' started by Snyll, Mar 20, 2021.

  1. Snyll

    Snyll New Member

    I have strange issue with ISP config v 3.2.3. I am using Debian 10 (used the perfect server guide for installation). Everything went smoothly (kinda). Right now i checked the "lets encrypt" checkbox at one website (all the rest of sites - about 20 - is running fine with lets encrypt using this method) and since then I cannot load the ISP config administration, only the header loads, until the moment it should show the number of waiting jobs (see bellow where the html code ends).

    I even tried to skip the job incrementing the "updated" number in the server table but it did not help. Then I found that there is some bug in 3.2.3 (this one: "This is a known bug in ISPConfig 3.2.3, which occurs after changing server config. It is fixed in 3.2.4. You can use this as temporary work around:") - I used the workaround but did not help, probably different issue. Any idea what could cause this? (Reloging doesnt help, other browser doesnt help). Thank you!

    This is what loads for me:

    <!-- Datalogstatus Modal -->
                <div id="datalogModal" class="modal fade" role="dialog">
                  <div class="modal-dialog">
                    <div class="modal-content">
                      <div class="modal-header">
                        <button type="button" class="close" data-dismiss="modal">&times;</button>
                        <h4 class="modal-title">The following changes are not yet populated to all servers:</h4>
                      <div class="modal-body">

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] OS version is Debian GNU/Linux 10 (buster)
    [INFO] uptime:  21:42:37 up 3 days,  3:22,  1 user,  load average: 4.93, 3.80, 3.41
    [INFO] memory:
                  total        used        free      shared  buff/cache   available
    Mem:           31Gi       8.5Gi       593Mi       562Mi        22Gi        22Gi
    Swap:          46Gi       102Mi        46Gi
    [INFO] systemd failed services status:
    0 loaded units listed. Pass --all to see loaded but inactive units, too.
    To show all installed unit files use 'systemctl list-unit-files'.
    [INFO] ISPConfig is installed.
    ##### ISPCONFIG #####
    ISPConfig version is 3.2.3
    ##### VERSION CHECK #####
    [INFO] php (cli) version is 7.3.27-9+0~20210227.82+debian10~1.gbpa4a3d6
    ##### PORT CHECK #####
    ##### MAIL SERVER CHECK #####
    [INFO] I found the following web server(s):
            Apache 2 (PID 9084)
    [INFO] I found the following mail server(s):
            Postfix (PID 941)
    [INFO] I found the following pop3 server(s):
            Dovecot (PID 603)
    [INFO] I found the following imap server(s):
            Dovecot (PID 603)
    [INFO] I found the following ftp server(s):
            PureFTP (PID 1050)
    ##### LISTENING PORTS #####
    (only           ()
    Local           (Address)
    [localhost]:8082                (1339/sidekiq)
    [localhost]:8083                (1201/puma)
    [localhost]:9236                (1272/gitaly)
    [anywhere]:21           (1050/pure-ftpd)
    ***.***.***.***:53              (630/named)
    [localhost]:53          (630/named)
    [anywhere]:22           (645/sshd)
    [localhost]:3000                (1200/grafana-server)
    [anywhere]:25           (941/master)
    [localhost]:953         (630/named)
    [anywhere]:8443         (1197/nginx:)
    [anywhere]:8060         (1197/nginx:)
    [localhost]:9121                (1183/redis_exporter)
    [anywhere]:993          (603/dovecot)
    [localhost]:9090                (1198/prometheus)
    [localhost]:9187                (1308/postgres_expor)
    [anywhere]:995          (603/dovecot)
    [localhost]:10023               (757/postgrey)
    [localhost]:10024               (1117/amavisd-new)
    [localhost]:10025               (941/master)
    [localhost]:10026               (1117/amavisd-new)
    [localhost]:10027               (941/master)
    [anywhere]:587          (941/master)
    [localhost]:11211               (598/memcached)
    [localhost]:9100                (1189/node_exporter)
    [localhost]:9229                (1184/gitlab-workhor)
    [anywhere]:110          (603/dovecot)
    [anywhere]:143          (603/dovecot)
    [localhost]:9168                (1182/ruby)
    [anywhere]:465          (941/master)
    *:*:*:*::*:21           (1050/pure-ftpd)
    *:*:*:*::*:53           (630/named)
    *:*:*:*::*:22           (645/sshd)
    *:*:*:*::*:25           (941/master)
    *:*:*:*::*:953          (630/named)
    *:*:*:*::*:443          (9084/apache2)
    *:*:*:*::*:993          (603/dovecot)
    *:*:*:*::*:995          (603/dovecot)
    *:*:*:*::*:10023                (757/postgrey)
    *:*:*:*::*:10024                (1117/amavisd-new)
    *:*:*:*::*:10026                (1117/amavisd-new)
    *:*:*:*::*:3306         (721/mysqld)
    *:*:*:*::*:587          (941/master)
    [localhost]10           (603/dovecot)
    [localhost]43           (603/dovecot)
    *:*:*:*::*:8080         (9084/apache2)
    *:*:*:*::*:80           (9084/apache2)
    *:*:*:*::*:9168         (1182/ruby)
    *:*:*:*::*:8081         (9084/apache2)
    *:*:*:*::*:465          (941/master)
    ##### IPTABLES #####
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    You should not do this. Undo this change.

    After that, try doing a force update of ISPConfig and let it reconfigure your services:
    Code: --force
  3. Snyll

    Snyll New Member

    Hello, I did what you said but I still have the same problem.
  4. Snyll

    Snyll New Member

    Ok it is fixed now. For some reason my default CGI version of PHP got changed to 8.0, so after changing it back to 7.3 with "update-alternatives --config php-cgi" it works fine again. Sorry for a stupid question and thank you for your help.
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Weird, the test script should usually show that. Did you alter the output before sharing it?
  6. Snyll

    Snyll New Member

    No I did not alter anything inbetween. I was surprised when I found this too. I tested the php version with "php -v" and it showed 7.3 - I am still kinda new in all the server administration so I don't know how exactly the default debian PHP version works. Maybe it used fpm instead of cgi? I am not really sure. I installed PHP 8.0 recently for some new project, aside that I have 7.3 as default and 5.6 for some old projects. I am just glad it works now.
  7. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    If you want to add a version in the future, see
  8. Snyll

    Snyll New Member

    Th0m likes this.
  9. Joost De Bock

    Joost De Bock New Member

    I have the same problem at the moment. For some unknown reason php7.4 broke down and I had to completely delete and reinstall it.
    From then on I also only see the header. --force does not help
    Switching to a different version of php via sudo update-alternatives --config php does not help either.
  10. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you have the same problem, it should be solved following instructions on this marked-as-solved thread.
    Maybe you should have created a new thread? Describing what exactly the problem is, on which OS and version and which version of ISPConfig. Or just follow which has other useful instructions.
    This is a way to break your ISPConfig system, do not do it. If you have installed additional PHP versions (have you?), for Debian instructions to follow are in , maybe it offers clues for the whatever OS you are running. Or find instructions suitable for your OS from under "Using multiple PHP versions".
    My guess is your PHP installation for the default version of your OS is broken/misconfigured, and you have to install missing parts and fix configuration.

Share This Page