Ispconfig version issue

Discussion in 'Installation/Configuration' started by Patrick Tanis, Mar 17, 2019 at 3:42 AM.

  1. Patrick Tanis

    Patrick Tanis New Member

    My ispconfig has been installed with php7.0. I have installed php7,2 because of security issue. But when i add a new site the fastcgi use the old path : fastcgi_pass unix:/var/lib/php7.0-fpm/web39.sock; and no socket created in /run/php path. Any help would be appreciable.

    Patrick Tanis
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no issue here. You wrongly assumed that the 7.0 in the socket path means that the site is using PHP 7.0, which is not the case. The folder /var/lib/php7.0-fpm/ is the central system folder for all PHP sockets, no matter which PHP version.

    If you want to know which PHP version a specific site is using, drop a php file with phpinfo() command into the site. Socket paths are no way to guess a PHP version.
     

Share This Page