ISPConfig User Locked

Discussion in 'ISPConfig 3 Priority Support' started by tortib, Jan 15, 2015.

  1. tortib

    tortib Member

    I'm using ISPConfig3 with WHMCS module that creates users automatically when they sign up on my website. Unfortunately I had this checkmark box checked in that the website would be readonly, which I do *not* want. A user was created with those settings and now they can't edit their website details, DNS, etc. I'm trying to figure out how to remove this lock so the user will be able to modify the settings for that specific domain. They're able to create additional domains within the limits of the template I have specified for them but the user cannot modify the original domain they signed up with due to that option that was enabled to make the website read only. Please help I need to resolve this as soon as possible. (I unchecked the option to make the website read only for future users that sign up, but I need to know how to disable it for the existing user that has already signed up with the account.)

    Thank you for your assistance.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Find the website record of this site in the dbispconfig database in web_database table and set the sys_perm_group field to "riud". Do the same for the dns recrd in dns_soa table.
  3. tortib

    tortib Member

    Hello Till,
    Thank you for the quick reply.

    I checked the web_database table and the sys_perm_group filed is already set to "riud". But I can make any changes as the user.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats the way ispconfig manages it when you lock a site for editing. But I dont know the whmcs plugin, its ot develped by ispconfig. Maybe it assigns a wrong user or so to implement this function.

    The correct settings for a record are:

    sys_userid = userid of the user that created the record
    sys_groupid = group_id of the user
    sys_perm_user = riud
    sys_perm_group = riud
    sys_perm_other = <empty>
  5. tortib

    tortib Member

    I was able to edit the domain in web_domain and I set the sys_perm_group to riud from ru and now I can uncheck the boxes, but it doesn't appear to be saving the actual settings for the domain when I click save.
  6. tortib

    tortib Member

    Okay I figured it out it was the sys_userid that was set to 1 instead of the ID of the actual user which didn't allow me to save the settings for the website.

    Thank you very much for your help Till, this has been educational and has relieved some stress.

    Have a good evening.

Share This Page