ispconfig upgrade ubuntu to 22.04 LTS

Discussion in 'Installation/Configuration' started by soomon, May 12, 2022.

  1. soomon

    soomon New Member

    hello,

    I could not find any information in the ispconfig website. is ubuntu 22.04 LTS already supported by ispconfig?

    is there anything I need to do to get ispconfig to work after the os upgrade?

    thanks!
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You need to install PHP 7.4 and set that as the system default version, at least.
     
    Last edited: May 13, 2022
  3. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Nope. I do not encourage any trial on it until it is fully supported.
     
    Last edited: May 14, 2022
  4. soomon

    soomon New Member

    thanks guys!
     
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  6. Thanks, guys. I was actually wondering about how you'd deal with the upgrade to 8.X (hopefully, you'll fix things to work directly in 8.1, that should give you a couple of years of rest), now that the 7.X branch is going to be retired soon...
    In spite of Th0m's linked thread, the truth is that your plugins work wonderfully with Roundcube 1.5.0 and PHP 8.0 under Ubuntu 22.04. There were just a few very minor tweaks to get rid of a handful of annoying warning messages, which prompted me to add a PR on GitHub with those slight changes and a few comments for those who are bold enough to try out unsupported versions of Roundcube, PHP, and Ubuntu :)
     
  7. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    We do not maintain these plugins, so we aren't the ones to work on that ;)
     
  8. Oh! I see! So who does maintain them?
    They certainly continue to work flawlessly...
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    See Gitlab link that @Th0m posted.
     

Share This Page