ispconfig upgrade script from 3.0.4.6 to 3.0.5.2 fails the to upgrade

Discussion in 'General' started by webserver1, Apr 8, 2013.

  1. webserver1

    webserver1 New Member

    helpe with the upgrade it fails after directory backup.

    root@server1:/home/root# ispconfig_update.sh



    --------------------------------------------------------------------------------
    _____ ___________ _____ __ _
    |_ _/ ___| ___ \ / __ \ / _(_)
    | | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _
    | | `--. \ __/ | | / _ \| '_ \| _| |/ _` |
    _| |_/\__/ / | | \__/\ (_) | | | | | | | (_| |
    \___/\____/\_| \____/\___/|_| |_|_| |_|\__, |
    __/ |
    |___/
    --------------------------------------------------------------------------------


    >> Update

    Please choose the update method. For production systems select 'stable'.
    The update from svn is only for development systems and may break your current setup.
    Note: Update all slave server, before you update master server.

    Select update method (stable,svn) [stable]:

    --2013-04-08 12:22:27-- http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    Resolving www.ispconfig.org (www.ispconfig.org)... 78.46.59.59
    Connecting to www.ispconfig.org (www.ispconfig.org)|78.46.59.59|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 3330389 (3.2M) [application/x-gzip]
    Saving to: `ISPConfig-3-stable.tar.gz'

    100%[======================================>] 3,330,389 736K/s in 5.8s

    2013-04-08 12:22:33 (565 KB/s) - `ISPConfig-3-stable.tar.gz' saved [3330389/3330389]

    ispconfig3_install/
    ispconfig3_install/server/
    ispconfig3_install/server/server.php
    ispconfig3_install/server/conf-custom/
    ispconfig3_install/server/conf-custom/index/
    ispconfig3_install/server/conf-custom/mail/
    ispconfig3_install/server/conf-custom/error/
    ispconfig3_install/server/plugins-enabled/
    ispconfig3_install/server/plugins-available/
    ispconfig3_install/server/plugins-available/powerdns_plugin.inc.php
    ispconfig3_install/server/plugins-available/mailman_plugin.inc.php
    ispconfig3_install/server/plugins-available/cron_plugin.inc.php
    ispconfig3_install/server/plugins-available/postfix_filter_plugin.inc.php
    ispconfig3_install/server/plugins-available/maildeliver_plugin.inc.php
    ispconfig3_install/server/plugins-available/getmail_plugin.inc.php
    ispconfig3_install/server/plugins-available/bind_dlz_plugin.inc.php
    ispconfig3_install/server/plugins-available/shelluser_jailkit_plugin.inc.php
    ispconfig3_install/server/plugins-available/mail_plugin.inc.php

    --------------------------------------------------------------------------------
    _____ ___________ _____ __ _ ____
    |_ _/ ___| ___ \ / __ \ / _(_) /__ \
    | | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ /
    | | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ |
    _| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \
    \___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/
    __/ |
    |___/
    --------------------------------------------------------------------------------


    >> Update

    Operating System: 12.10 (Quantal Quetzal)

    This application will update ISPConfig 3 on your server.

    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:
    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...
    root@server1:/home/root#


    it fails after creating the back up any help please to correct this issue thanks to everyone.
    and i also tried the manual upgrade same result:confused:
     
  2. Torch_za

    Torch_za New Member

    Same issue

    Same Issue Debian Squeeze ...

     
  3. falko

    falko Super Moderator ISPConfig Developer

    Can you check if there's enough free space left on the hard drive?

    Code:
    df -h
    What's the output of
    Code:
    free
    ?
     
  4. Torch_za

    Torch_za New Member

    Filesystem Size Used Avail Use% Mounted on
    /dev/xvda1 38G 7.3G 29G 21% /
    tmpfs 509M 0 509M 0% /lib/init/rw
    udev 486M 72K 486M 1% /dev
    tmpfs 509M 0 509M 0% /dev/shm


    total used free shared buffers cached
    Mem: 1042268 1032020 10248 0 3976 61008
    -/+ buffers/cache: 967036 75232
    Swap: 2096472 505840 1590632
     
  5. webserver1

    webserver1 New Member

    ther is enough space

    root@server1:/# df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/mapper/server1-root 178G 28G 141G 17% /
    udev 2.9G 4.0K 2.9G 1% /dev
    tmpfs 1.2G 436K 1.2G 1% /run
    none 5.0M 0 5.0M 0% /run/lock
    none 2.9G 0 2.9G 0% /run/shm
    none 100M 0 100M 0% /run/user
    /dev/sda1 236M 153M 72M 69% /boot
    root@server1:/#
     
  6. webserver1

    webserver1 New Member

    please the problem persists i cant upgrade

    Heeeeeeeeeeeeeeeeelp please
     
  7. webserver1

    webserver1 New Member

    ouput of the command free

    root@server1:/# free
    total used free shared buffers cached
    Mem: 6039116 5172828 866288 0 255788 3344828
    -/+ buffers/cache: 1572212 4466904
    Swap: 6279164 27540 6251624
    root@server1:/# ^
     
  8. webserver1

    webserver1 New Member

    Torch_za did you have any luck fixing the issue?

    Torch can you post how is it going with your upgrade did you succeed?
     
  9. webserver1

    webserver1 New Member

    Falko please Help me i got stuck with the upgrade

    Falko i know you might be busy but can you please have a look to my problem if you have sometime free. i got no one else to ask. you are my only hope. thanks:eek:
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    When a php script dies without an error message then a php module might be broken. Do you have any php binary cahces like apc or xcache installed? Ifyes, you should try to disable them.
     
  11. webserver1

    webserver1 New Member

    YES i have APC INSTALLED. i will disable it and see what happens thanks for the fast reply. wow i am inpressed.
     
  12. webserver1

    webserver1 New Member

    Nothing happens the problem persistes

    First i disabled apc nothing happened
    second i remove it and nothing happened
    thinrd i installed xcache no luck

    after every attempt i run
    service apache2 restart
    service php5-fpm restart

    no luck :(

    still gets stuck after directory back up
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a virtual server?
     
  14. webserver1

    webserver1 New Member

    yes it is.
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    cat /proc/user_beancounters
     
  16. webserver1

    webserver1 New Member

    sorry i made a mistake its not a virtual server.
    its a dedicated server.
     
  17. webserver1

    webserver1 New Member

    Still stuck with the upgrade

    I have been trying the upgrade for more than a week now, and still no luck
    anyone please have any idea what could be the problem. i just cant figure it out.
     
  18. webserver1

    webserver1 New Member

    Heeeeeeeeeeeeeeeeeelp

    Please anybody out there had similar problem?
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    is apparmor disabled as described in the perfect setup guide?

    /etc/init.d/apparmor stop
    update-rc.d -f apparmor remove
    apt-get remove apparmor apparmor-utils
     
  20. webserver1

    webserver1 New Member

    thansk for helping me ,yes it not there here is the output.

    root@server1:/home/admin# /etc/init.d/apparmor stop
    /etc/init.d/apparmor: line 35: /lib/apparmor/functions: No such file or directory
    root@server1:/home/admin# update-rc.d -f apparmor remove
    Removing any system startup links for /etc/init.d/apparmor ...
    root@server1:/home/admin# apt-get remove apparmor apparmor-utils
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package 'apparmor' is not installed, so not removed
    Package 'apparmor-utils' is not installed, so not removed
     

Share This Page