ISPCONFIG update

Discussion in 'General' started by toux, Sep 10, 2010.

  1. toux

    toux New Member

    Hello all,

    I just update my ISPconfig 3.0.1 to 3.0.2 version, and now i can not acces to the control panel ssh runs, webmin runs, too, but ispconfig no..

    I have some sites here and is a disaster, i backuped the mysql and files like i saw in a how to.

    Please somebody can help, me?

    I did not change the 8080 port and i follow steps as I read.

    Thank you
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Restart the apache webserver. If it dont start, take a look at the apache error log.
     
  3. toux

    toux New Member

    Hello Till

    Thank you for yoru reply

    cdn1:/etc/apache2/sites-enabled# /etc/init.d/apache2 restart
    Restarting web server: apache2Syntax error on line 16 of /etc/apache2/sites-enabled/000-apps.vhost:
    Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration
    failed!

    This says, I compare this file, with other other server that i have installed ispconfig 3.0.2 and is 100% similar, is the same.

    Please help me Till

    Thank you

    EDITED: I try active "a2enmod suexec" with this comand and i get the same error when i try to restrat apache.
     
    Last edited: Sep 10, 2010
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    suexec is not installed or not loaded according to the apache error.

    1) Which Linux distribution do you use?
    2) Post the output of the command:

    apache2ctl -t
     
  5. toux

    toux New Member

    Hello Till

    1) DEbian Lenny 5.0


    2) cdn1:/etc/apache2# apache2ctl -t
    Syntax error on line 16 of /etc/apache2/sites-enabled/000-apps.vhost:
    Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration


    Here the file:

    #####################################################
    # This virtual host contains the configuration
    # for the ISPConfig apps vhost
    ######################################################

    Listen 8081
    NameVirtualHost *:8081

    <VirtualHost _default_:8081>
    ServerAdmin [email protected]


    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/apps
    SuexecUserGroup ispapps ispapps
    <Directory /var/www/apps>
    Options Indexes FollowSymLinks MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    AddHandler fcgid-script .php
    FCGIWrapper /var/www/php-fcgi-scripts/apps/.php-fcgi-starter .php
    Order allow,deny
    Allow from all
    </Directory>
    </IfModule>

    <IfModule mod_php5.c>
    DocumentRoot /var/www/apps
    AddType application/x-httpd-php .php
    <Directory /var/www/apps>
    Options FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>
    </IfModule>

    ServerSignature Off

    </VirtualHost>
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The configuration file is fine, the problem is the missing suexec in your system. Please post the content of the file:

    /etc/apache2/mods-enabled/suexec.load
     
  7. toux

    toux New Member

    Hello Till!!

    Thank you now running sites, this line was comented #load...

    But i continue having a problem, i can not acces to ispconfig browser print a ssl error.

    Thnak you very very much for your help.

    Greetens!

    David
     
  8. toux

    toux New Member

    Hello Till I found this post you helo another ........... like me.

    http://www.howtoforge.net/forums/showthread.php?t=47223&highlight=ssl error update

    And you say him do this:
    http://www.faqforge.com/linux/controlpanels/ispconfig3/enable-ssl-for-the-ispconfig-3-controlpanel/

    I try to do it, but says "Enter pass phrase for ispserver.key:"

    Where must I get this phrase?

    Thank you another time!

    David

    EDITED:

    I have another great great problem all the sites i was have configured, not show the index.html of default ISP Config, is there some way to recover them?
     
    Last edited: Sep 10, 2010
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    This is a new password that you should enter.
     
  10. toux

    toux New Member

    I enter a password the same password always but i get this error, or must I do something more.

    Enter pass phrase for ispserver.key:
    Verifying - Enter pass phrase for ispserver.key:
    Verify failure
    User interface error
    15235:error:0906906F:pEM routines:pEM_ASN1_write_bio:read key:pem_lib.c:331:
    cdn1:/etc/apache2/ssl#

    I have a great problem, all my sites show a index.html default from isp config, i backuped the files and mysql databases, how can i recover the configuration of the virtualhosts?

    Sorry Till, i know my knowbase is very short, i like learn this, today i don't go the bed.. Thank you another time for your work and your help.

    David
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Regarding the ssl password, do not use any special characters in the password, use just a-z and 0-9.

    I dont think that there is something that needs to be recovered as a ispconfig update doies not change a single vhost file.

    Check that the vhost files are in /etc/apache2/sites-available and that the folder /etc/apache2/sites-enabled contains symlinks to these files in the sites-available folder.
     
  12. toux

    toux New Member

    cdn1:/etc/apache2/ssl# /etc/init.d/apache2 restart
    Restarting web server: apache2apache2: Syntax error on line 284 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/sites-enabled/domain.com.vhost: Too many levels of symbolic links

    Hello Till,

    I do that and the ssl too, but now i have this problem

    Greetens! and thanks

    David
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Can you post the output of
    Code:
    ls -la /etc/apache2/sites-enabled/
    ?

    What's in /etc/apache2/sites-enabled/domain.com.vhost?
     
  14. koltz

    koltz Member

    I had the same issue and went through my instructions and found that I missed this line when setting up the Perfect Server

    Code:
    a2enmod suexec rewrite ssl actions include
    I ran that which enabled what should have been enabled and good to go. Hope this helps somebody else.
     

Share This Page