ISPConfig update till 3.1.11 stops

Discussion in 'Installation/Configuration' started by Denis Yurov, Jan 12, 2018.

  1. Denis Yurov

    Denis Yurov New Member

    Hi I am trying to update from "(Xenial Xerus)) ISPConfig 3.1dev" to the latest one but it simply stop at this point:
    Operating System: Ubuntu 16.04.3 LTS (Xenial Xerus)
    This application will update ISPConfig 3 on your server.
    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:
    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...
    [email protected] ~ #
    Any Idea why it could be happened.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This can be a problem with your PHP setup. Please post the output of:

    which php

    and

    php --version
     
  3. Denis Yurov

    Denis Yurov New Member

    [email protected] ~ # which php
    /usr/local/bin/php
    [email protected] ~ # php --version
    PHP 5.6.30 (cli) (built: Jan 11 2018 09:01:21)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    I used to install php 5.6.30 according this tutorial "How to install PHP 5.6 as additional PHP-FPM & FastCGI for ISPConfig 3.1 on Ubuntu 16.04"
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That's the problem, you accidentally overwrote the system php binary during compilation and this system php now lacks mysql support. Run:

    mv /usr/local/bin/php /usr/local/bin/php_bak

    and then run the update again.
     
  5. Denis Yurov

    Denis Yurov New Member

    Thanks Till. It's updated now :)
     

Share This Page