ISPConfig Update problem

Discussion in 'Installation/Configuration' started by Monotoba, Aug 27, 2019.

  1. Monotoba

    Monotoba Member

    Hi All, I have an issue running update.php. Here's the output:

    php -q update.php


    --------------------------------------------------------------------------------
    _____ ___________ _____ __ _ ____
    |_ _/ ___| ___ \ / __ \ / _(_) /__ \
    | | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ /
    | | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ |
    _| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \
    \___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/
    __/ |
    |___/
    --------------------------------------------------------------------------------


    >> Update

    Operating System: Ubuntu 18.04.3 LTS UNKNOWN

    This application will update ISPConfig 3 on your server.

    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]: yes

    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...
    PHP Warning: Declaration of db::query($sQuery = '') should be compatible with mysqli::query($query, $resultmode = NULL) in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 754
    Checking ISPConfig database .. OK
    PHP Warning: Illegal string offset 'global' in /tmp/ispconfig3_install/install/lib/install.lib.php on line 631
    PHP Fatal error: Uncaught Error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/lib/install.lib.php:631
    Stack trace:
    #0 /tmp/ispconfig3_install/install/lib/update.lib.php(137): ini_to_array('[global]\nwebser...')
    #1 /tmp/ispconfig3_install/install/update.php(288): updateDbAndIni()
    #2 {main}
    thrown in /tmp/ispconfig3_install/install/lib/install.lib.php on line 631
    [email protected]:/tmp/ispconfig3_install/install#

    Any ideas on how to solve this?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems to me as if you use an old version of ISPConfig as an update source. Use this command to update ISPConfig:

    ispconfig_update.sh
     

Share This Page