ISPConfig Update fails

Discussion in 'ISPConfig 3 Priority Support' started by Nilpo, Apr 6, 2021.

  1. Nilpo

    Nilpo Member HowtoForge Supporter

    ispconfig_update.sh script fails after downloading.

    Code:
    >> Update
    
    PHP Parse error:  syntax error, unexpected '[' in /tmp/update_stable.sh.i6K9DC5Hk1/ispconfig3_install/install/lib/installer_base.lib.php on line 296
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Is /bin/sh bash?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The PHP version is probably too old. which OS do you use on that server and which PHP version?
     
  4. Nilpo

    Nilpo Member HowtoForge Supporter

    Yes.
    5.3.3 Can't upgrade OS because of VPS/kernel limitations. I do have newer PHP versions installed, but the system version is outdated.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    If the OS version is too old and not supported by ISPConfig anymore, then config file templates that ship with ISPConfig might be incompatible and also the default PHP version of the OS might be too old as in your case, it's better to migrate the websites to a new system then if you can't update the current OS and keep the ISPConfig version as it is until then.
     

Share This Page