ispconfig unique problem

Discussion in 'Installation/Configuration' started by robotsyntex, Nov 25, 2013.

  1. robotsyntex

    robotsyntex New Member

    hi,
    I have plan to start webhosting company. recently i used your tutorial

    http://www.howtoforge.com/perfect-server-ubuntu-13.04-apache2-bind-dovecot-ispconfig-3

    but i end up with blank page here
    Code:
    http://83.136.252.68/ispconfig/
    and not opening
    Code:
    83.136.252.68:8080
    my confirations are
    Code:
    Nmap 
    Starting Nmap 5.21 ( http://nmap.org ) at 2013-11-25 08:48 EET
    Nmap scan report for localhost (127.0.0.1)
    Host is up (0.0000080s latency).
    rDNS record for 127.0.0.1: localhost.localdomain
    Not shown: 982 closed ports
    PORT      STATE SERVICE
    21/tcp    open  ftp
    22/tcp    open  ssh
    25/tcp    open  smtp
    53/tcp    open  domain
    80/tcp    open  http
    110/tcp   open  pop3
    143/tcp   open  imap
    443/tcp   open  https
    465/tcp   open  smtps
    587/tcp   open  submission
    993/tcp   open  imaps
    995/tcp   open  pop3s
    3306/tcp  open  mysql
    8080/tcp  open  http-proxy
    8081/tcp  open  blackice-icecap
    9000/tcp  open  cslistener
    10024/tcp open  unknown
    10025/tcp open  unknown
    
    Nmap done: 1 IP address (1 host up) scanned in 0.09 seconds
    [email protected]:/etc/apache2/sites-available#
    netstat -tap
    Code:
    [email protected]:/tmp/ispconfig3_install/install#  netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State
    PID/Program name
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN
    5715/master
    tcp        0      0 *:mysql                 *:*                     LISTEN
    5480/mysqld
    tcp        0      0 *:submission            *:*                     LISTEN
    5715/master
    tcp        0      0 *:pop3                  *:*                     LISTEN
    6653/dovecot
    tcp        0      0 *:imap2                 *:*                     LISTEN
    6653/dovecot
    tcp        0      0 *:http-alt              *:*                     LISTEN
    6709/apache2
    tcp        0      0 *:http                  *:*                     LISTEN
    6709/apache2
    tcp        0      0 *:tproxy                *:*                     LISTEN
    6709/apache2
    tcp        0      0 *:ssmtp                 *:*                     LISTEN
    5715/master
    tcp        0      0 10.2.0.144:domain       *:*                     LISTEN
    6750/named
    tcp        0      0 sever.studylover:domain *:*                     LISTEN
    6750/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN
    6750/named
    tcp        0      0 *:ftp                   *:*                     LISTEN
    6731/pure-ftpd (SER
    tcp        0      0 *:ssh                   *:*                     LISTEN
    7379/sshd
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN
    6750/named
    tcp        0      0 *:smtp                  *:*                     LISTEN
    5715/master
    tcp        0      0 *:https                 *:*                     LISTEN
    6709/apache2
    tcp        0      0 *:imaps                 *:*                     LISTEN
    6653/dovecot
    tcp        0      0 *:pop3s                 *:*                     LISTEN
    6653/dovecot
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN
    5892/amavisd (maste
    tcp        0      0 localhost.localdom:9000 *:*                     LISTEN
    17966/php-fpm.conf)
    tcp        0      1 sever.studylovers.:http 39.x.x.12:63296      LAST_ACK
    -
    tcp        0      0 localhost.localdom:http localhost.localdo:37310 TIME_WAIT
    -
    tcp        0      0 localhost.localdo:50367 localhost.localdo:imap2 TIME_WAIT
    -
    tcp        0      0 localhost.localdo:49360 localhost.localdo:mysql TIME_WAIT
    -
    tcp        0      0 localhost.localdoma:ftp localhost.localdo:47722 TIME_WAIT
    -
    tcp        0   5604 sever.studylovers.c:ssh 39.53.222.12:63048      ESTABLISHED
    18345/0
    tcp6       0      0 [::]:submission         [::]:*                  LISTEN
    5715/master
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN
    6653/dovecot
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN
    6653/dovecot
    tcp6       0      0 [::]:ssmtp              [::]:*                  LISTEN
    5715/master
    tcp6       0      0 [::]:domain             [::]:*                  LISTEN
    6750/named
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN
    6731/pure-ftpd (SER
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN
    7379/sshd
    tcp6       0      0 ip6-localhost:953       [::]:*                  LISTEN
    6750/named
    tcp6       0      0 [::]:smtp               [::]:*                  LISTEN
    5715/master
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN
    6653/dovecot
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN
    6653/dovecot
    [email protected]:/tmp/ispconfig3_install/install# sudo iptables -A INPUT -p tcp --dpo
    rt 443 -j ACCEPT
    [email protected]:/tmp/ispconfig3_install/install# sudo iptables -A INPUT -p tcp --dpo
    [email protected]:/etc/apache2/sites-available#  netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State
    PID/Program name
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN
    5715/master
    tcp        0      0 *:mysql                 *:*                     LISTEN
    5480/mysqld
    tcp        0      0 *:submission            *:*                     LISTEN
    5715/master
    tcp        0      0 *:pop3                  *:*                     LISTEN
    6653/dovecot
    tcp        0      0 *:imap2                 *:*                     LISTEN
    6653/dovecot
    tcp        0      0 *:http-alt              *:*                     LISTEN
    7165/apache2
    tcp        0      0 *:http                  *:*                     LISTEN
    7165/apache2
    tcp        0      0 *:tproxy                *:*                     LISTEN
    7165/apache2
    tcp        0      0 *:ssmtp                 *:*                     LISTEN
    5715/master
    tcp        0      0 10.2.0.144:domain       *:*                     LISTEN
    6750/named
    tcp        0      0 sever.studylover:domain *:*                     LISTEN
    6750/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN
    6750/named
    tcp        0      0 *:ftp                   *:*                     LISTEN
    6731/pure-ftpd (SER
    tcp        0      0 *:ssh                   *:*                     LISTEN
    7379/sshd
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN
    6750/named
    tcp        0      0 *:smtp                  *:*                     LISTEN
    5715/master
    tcp        0      0 *:https                 *:*                     LISTEN
    7165/apache2
    tcp        0      0 *:imaps                 *:*                     LISTEN
    6653/dovecot
    tcp        0      0 *:pop3s                 *:*                     LISTEN
    6653/dovecot
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN
    5892/amavisd (maste
    tcp        0      0 localhost.localdom:9000 *:*                     LISTEN
    17966/php-fpm.conf)
    tcp        0    404 sever.studylovers.c:ssh 39.53.222.12:63048      ESTABLISHED
    18345/0
    tcp6       0      0 [::]:submission         [::]:*                  LISTEN
    5715/master
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN
    6653/dovecot
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN
    6653/dovecot
    tcp6       0      0 [::]:ssmtp              [::]:*                  LISTEN
    5715/master
    tcp6       0      0 [::]:domain             [::]:*                  LISTEN
    6750/named
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN
    6731/pure-ftpd (SER
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN
    7379/sshd
    tcp6       0      0 ip6-localhost:953       [::]:*                  LISTEN
    6750/named
    tcp6       0      0 [::]:smtp               [::]:*                  LISTEN
    5715/master
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN
    6653/dovecot
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN
    6653/dovecot
    along with this when i restart my apache it gives this error
    Code:
    [email protected]:/etc/apache2/sites-available# /etc/init.d/apache2 restart
     * Restarting web server apache2
    [Mon Nov 25 08:52:04 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Mon Nov 25 08:52:04 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
     ... waiting [Mon Nov 25 08:52:06 2013] [warn] NameVirtualHost *:443 has no Virt
    ualHosts
    [Mon Nov 25 08:52:06 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
                                                                             [ OK ]
    but squremail is opeing
    Code:
    http://83.136.252.68/squirrelmail/src/login.php
    kindly help me.
     
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

  3. robotsyntex

    robotsyntex New Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the content of the file /etc/apache2/sites-enabled/000-ispconfig.vhost
     
  5. robotsyntex

    robotsyntex New Member

    Code:
    [email protected]:~# cat /etc/apache2/sites-enabled/000-ispconfig.vhost
    
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################
    
     Listen 8080
    NameVirtualHost  *:8080
    
    <VirtualHost _default_:8080>
      ServerAdmin [email protected]
    
      <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
      </FilesMatch>
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options -Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
        IPCCommTimeout  7200
            MaxRequestLen 15728640
      </IfModule>
    
      <IfModule mpm_itk_module>
        DocumentRoot /usr/local/ispconfig/interface/web/
            AssignUserId ispconfig ispconfig
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:
    /tmp"
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
      <IfModule mod_security2.c>
        SecRuleEngine Off
      </IfModule>
    
      # SSL Configuration
      SSLEngine On
      SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
      SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
      #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    [email protected]:~#
    
    
    
    
    
    
    
    
    
    
     
  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    please post output of
    Code:
    iptables -L -n
    maybe port 8080 is blocked in firewall.
     
  7. robotsyntex

    robotsyntex New Member

    here is
    Code:
    [email protected]:~/imscp# iptables -L -n
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    fail2ban-dovecot-pop3imap  tcp  --  0.0.0.0/0            0.0.0.0/0            mu
    ltiport dports 110,995,143,993
    fail2ban-pureftpd  tcp  --  0.0.0.0/0            0.0.0.0/0            multiport
    dports 21
    fail2ban-ssh  tcp  --  0.0.0.0/0            0.0.0.0/0            multiport dport
    s 22
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:443
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:8080
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:8080
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain fail2ban-dovecot-pop3imap (1 references)
    target     prot opt source               destination
    RETURN     all  --  0.0.0.0/0            0.0.0.0/0
    
    Chain fail2ban-pureftpd (1 references)
    target     prot opt source               destination
    RETURN     all  --  0.0.0.0/0            0.0.0.0/0
    
    Chain fail2ban-ssh (1 references)
    target     prot opt source               destination
    RETURN     all  --  0.0.0.0/0            0.0.0.0/0
    [email protected]:~/imscp#
    
    
     
  8. Ghostdare

    Ghostdare Member

    Your ISPConfig server is behind a firewall/router? If so, open the 8080 port.
     
    Last edited: Nov 26, 2013

Share This Page