ISPconfig under gentoo - One small problem

Discussion in 'Installation/Configuration' started by CeuL, Jan 28, 2008.

  1. CeuL

    CeuL New Member

    First of all, i want to congratulate the amazing team that developed this amazing web panel... after going trough tons of webpages, reading reviews and trying out demos of other panels, ispconfig has convinced me to use it for being reliable.

    After a smal personal war between my OS and ISPconfig install, and after some minor changes on the install script provided by the release, i finnaly was able to set up a working copy of ISPconfig.

    The 1st problem i had, was easy to solve, and stopped me from posting, since i found a solution ( problem with mysql char code ), after that all went smothly until i tryed to set up our 1st website.

    There are two things that i've encontered, one of them is solved, but i would like to know if theres another way to do it.

    To begin, i dont want to use the default web page for the "clients" but my own, wich is a whole hdd just for that purpose... i found 2 ways to do it.

    1) Change my mount directory of the hdd, to the default web directory of ispconfig.

    2) Edit the data in mysql databse and change the directory to my mounting point of that hdd.

    Is there another way? This is not very importante, since its solved, but if theres a proper way to do it, i would like to know.

    And the main problem, wich is getting on my nerves, and after reading all the available topics and threads that showed similar problems with mine, i couldnt find any that was exactly the same, and after trying all the solutions provided in those threads, still it doesnt work.

    When i add a new site, it works perfectly, except for the bit that it doesnt add the new website information to the vhost file in etc/apache2/vhost dir.

    And, not only that, it doesnt show up any other file in that dir.

    heres the log ( of a new fresh install of ispconfig ) with only 2 sites added to the same client:

    when i try to run
    /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php
    the php prog just hangs... when i run another .php file, it works ok.

    So i decided to do something i read in another thread

    m -f /root/ispconfig/.ispconfig_lock

    Run the command again, and still the same... no display of what so ever, and just stands there until i "break" the php program with ctrl+c.

    running the strace to the command above it shows ( in a loop )

    It writes de http.conf in apache2 dir, and several files with the date added have shown up... so is there anything you can to do help?

    Thanks for your time and atention.
  2. falko

    falko Super Moderator ISPConfig Developer

    You can use the expert installation mode and specify your preferred directory.

    What's at the end of your main httpd.conf? What are the outputs of
    ls -la /root/ispconfig
    ls -la /home/admispconfig

Share This Page