ISPConfig - Ubuntu 13.04 - Not working

Discussion in 'Installation/Configuration' started by Arjen, Jan 27, 2014.

  1. Arjen

    Arjen New Member

    Hi there,

    while install ISPConfig 3 on Ubuntu 13.04 i've encountered a problem. I'm not quite sure what it is so i'm hoping you guys can help me out. I've followed this manual.

    My ubuntu has to following partitioning

    [​IMG]

    Ubuntu is currently running on VMWare Workstation 10 ( due to this is the testphase). It's networkcard is just bridged and has an IP in my normal LAN. I'm planning on doing some tests with an editted windows host file.

    For the installation i found the following deviations:

    - During chapter 14: apache2.2-common not installed, allready included in apache2. Package libapache2-mod-ruby give "E: Unable to locate package libapache2-mod-ruby"

    - Skipped 15. Mailman. Will do that later.

    - Skipped 16 -> The part of making an certificate and quota's. Will do that later.

    Now, uptill step 22 everything works. Apache works, squirrelmail is accesable, nothing wrong so far. Now for step 22, the install of ISPConfig 3. The installations does work nicely. Seems like there are no problems. The only thing i might have done wrong is the following:

    "Full qualified hostname (FQDN) of the server, eg server1.domain.tld [server1.example.com]: <-- ENTER"

    This is where i've just typed in the hostname of the server instead of an FQDN. ( so julia-www instead of julia-www.example.com)

    After the installation I go to my root (192.168.1.250) where normaly the apache 2 "It works!" message is displayed. However now I get an 403 forbidden. Also when i try to connect to localhost on 8080 i get a page not found. Side note: Squirrelmail on 192.168.1.250/webmail is still working. When restarting apache the following gets displayed.

    [email protected]:/tmp/ispconfig3_install/install# service apache2 restart
    * Restarting web server apache2
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:53
    [ OK ]

    I did notice apache does not load .vhost files automaticaly, so i've added the following to /etc/apache2/apache.conf

    "IncludeOptional sites-enabled/*.vhost"

    However now after restarting apache i get the following:

    [email protected]:/tmp/ispconfig3_install/install# service apache2 reload
    * Reloading web server apache2 *
    * The apache2 configtest failed. Not doing anything.
    Output of config test was:
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:53
    AH00526: Syntax error on line 30 of /etc/apache2/sites-enabled/000-apps.vhost:
    Either all Options must start with + or -, or no Option may.
    Action 'configtest' failed.
    The Apache error log may have more information.

    So yeah, im a bit stuck now. I've included the diagnose form, this is as follows:


    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [WARN] ip addresses from hostname differ from ifconfig output. Please check your ip settings.
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.3


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.5.3-1ubuntu2.1

    ##### PORT CHECK #####

    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
    [WARN] Port 143 (IMAP server) seems NOT to be listening
    [WARN] Port 993 (IMAP server SSL) seems NOT to be listening
    [WARN] Port 110 (POP3 server) seems NOT to be listening
    [WARN] Port 995 (POP3 server SSL) seems NOT to be listening
    [WARN] Port 465 (SMTP server SSL) seems NOT to be listening
    [WARN] Port 21 (FTP server) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "submission" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
    [WARN] I found no "smtps" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 1096)
    [INFO] I found the following mail server(s):
    Unknown process (smtpd) (PID 11427)
    [WARN] I could not determine which pop3 server is running.
    [WARN] I could not determine which imap server is running.
    [WARN] I could not determine which ftp server is running.

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    [localhost]:953 (61114/named)
    [anywhere]:25 (11427/smtpd)
    [localhost]:10024 (62196/amavisd-new)
    [localhost]:10025 (59170/master)
    [anywhere]:3306 (58256/mysqld)
    [localhost]:11211 (41321/memcached)
    ***.***.***.***:53 (61114/named)
    [localhost]:53 (61114/named)
    [anywhere]:22 (1044/sshd)
    *:*:*:*::*:953 (61114/named)
    *:*:*:*::*:25 (11427/smtpd)
    *:*:*:*::*:443 (1096/apache2)
    *:*:*:*::*:80 (1096/apache2)
    *:*:*:*::*:53 (61114/named)
    *:*:*:*::*:22 (1044/sshd)

    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    fail2ban-dovecot-pop3imap tcp -- [anywhere]/0 [anywhere]/0 multiport dports 110,995,143,993
    fail2ban-pureftpd tcp -- [anywhere]/0 [anywhere]/0 multiport dports 21
    fail2ban-sasl tcp -- [anywhere]/0 [anywhere]/0 multiport dports 25
    fail2ban-ssh tcp -- [anywhere]/0 [anywhere]/0 multiport dports 22

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain fail2ban-dovecot-pop3imap (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain fail2ban-pureftpd (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain fail2ban-sasl (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0

    Chain fail2ban-ssh (1 references)
    target prot opt source destination
    RETURN all -- [anywhere]/0 [anywhere]/0


    Is there anyone who can point my in the correct direction on how to solve this issues?

    Side note 2: I've tried this 2 times now, both times same thing happends.
     
  2. sjau

    sjau Local Meanie Moderator

  3. Arjen

    Arjen New Member

    Well, im a system engineer for over 4 years now and i've done mostly Windows. The company i work with runs a lot of ubuntu servers so I'm kinda expanding my knowledge on that one for now.

    Also: I've posted ubuntu 13.04. Not sure why since it is clearly 13.10. Apologies :)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ubuntu is genarally a good choice. I prefer Debian as well, but using ubuntu is fine as well.

    Skipping steps is bad, as it will cause parts of your setup to fail. the steps have to be done before you install ispconfig. If you do them later, they wont work as ispconfig was not able to configure these pats of the system during installation.

    To your other issues:

    check yor /etc/aptSources.list file and ensure that the universe and multiverse repositories are enabled.

    that was a bad choice. it is a must to enter a fully qalified domain name here or your mailsystem will fal. your mailserver will now try to connect to other servers and say !Hey, I'am julia-www. and tehy will just close the connection as they cant lookup a name like julia-www in the global dns servers.

    Then I guess you do not use Ubuntu 13.04. This line is missingin Ubuntu 13.10 and Ubuntu 1.10 is not supported by ispconfig yet due to the change to apache 2.4, which has a different config syntax then apache 2.2.

    Ubuntu 13.10 will be supported in the next ispconfig release, till then, use ubuntu 13.04 and not 13.10.
     
  5. sjau

    sjau Local Meanie Moderator

    I like Ubuntu (or rather Kubuntu) as Desktop system. However for server deployments you'd better stick to the Ubuntu LTS versions as they get 5 years supports. Ubuntu 13.10 only has 9 months support.

    But in general I prefer to use Debian on servers.
     
  6. Arjen

    Arjen New Member

    Till, thanks for your reply.

    As for the skipping steps, good comment. Not beeing able to edit things after ISPConfig installation seems a legit reason.

    Regarding the FQDN, as this is an internal test I'm not all to worried about the mailserver. I would not think this explains my issues regarding a not working ISPConfig server however. I do see the reason why mail should not work with this setting and same goes for possible other things.

    The problem here seems to be my ubuntu version. I thought I was on 13.04 but clearly it was not. It was 13.10. Somewhat a dumb mistake as the ISPConfig website clearly states "Ubuntu 8.10 – 13.04 (recommended)". Currently im reinstalling a new machine with 13.04 and fixing the issues you've addressed in your reply. Thank you. I will post again in this thread after installation if the problems are solved.

    Arjen.
     
  7. Arjen

    Arjen New Member

    Jup, all solved now. Thanks for the help!
     
  8. sjau

    sjau Local Meanie Moderator

    btw, next LTS release will be 14.04 - in april. That will be supported until Arpil 2019.
     

Share This Page