ISPConfig trouble, mod_php not working

Discussion in 'Installation/Configuration' started by Leftblank, Sep 3, 2009.

  1. Leftblank

    Leftblank New Member

    I suppose these two issues are connected; I noticed that after following the server guide for ISPConfig on Ubuntu 9.04 PHP works fine as long as I'm not using mod_php for the sites. In case I do pick mod_php, the following is generated:

    Code:
    [Thu Sep 03 19:30:03 2009] [error] [client 82.168.xx.xx] SoftException in Application.cpp:217: File "/var/www/clients/client2/web2//web/index.php" is not in document root of Vhost "/var/www/test.leftblank.nl/web"
    [Thu Sep 03 19:30:03 2009] [error] [client 82.168.xx.xx] Premature end of script headers: index.php
    When I try to run a PHP file dropped in my /var/www folder, (such as phpinfo();) I receive the following similar, but not equal errors;
    Code:
    [Thu Sep 03 19:41:55 2009] [error] [client 82.168.xx.xx] SoftException in Application.cpp:296: UID of script "/var/www/index.php" is smaller than min_uid
    [Thu Sep 03 19:41:55 2009] [error] [client 82.168.xx.xx] Premature end of script headers: index.php
    In addition to this, phpMyAdmin is nonfunctional, when clicking the link a funky 'download file' dialog is opened with an empty input, so apparently Apache is not delivering that one either. The problem here is though that I'm unable to find records of this anywhere; the requests do show up in the access.log, but no errors are written in any of the errorlogs. My guess is that this is related to the mod_php not working.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please update to the latest ISPConfig 3.0.1.4 release, change a setting in the website like quota and click on save, then wait a few minutes and test again.

    The info.php file in /var/www does not work because it belongs to the wrong user, chown it to www-data user and group.
     
  3. Leftblank

    Leftblank New Member

    Thanks, I updated to the last version right now, though the same errors happen. Chowning the php file in the root dir didnt help sadly, and for my testpage the following shows up again:
    Code:
    [Thu Sep 03 21:44:29 2009] [error] [client 82.168.x] SoftException in Application.cpp:217: File "/var/www/clients/client1/web2//web/index.php" is not in document root of Vhost "/var/www/test.leftblank.nl/web"
    [Thu Sep 03 21:44:29 2009] [error] [client 82.168.x] Premature end of script headers: index.php
     
    Last edited: Sep 3, 2009
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which exact settings do you have enabled for the site?
     
  5. Leftblank

    Leftblank New Member

    No custom settings, everything disabled except for a big enough quota, mod_php and 'active'.
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which Linux distribution and which exact ispconfig version.
     
  7. Leftblank

    Leftblank New Member

    Ubuntu 9.04 and ISPConfig 3.0.1.4 (stable one from SourceForge)
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I'am not able to reproduce this on debian. Are there any errors in the system log of the monitor or are any jobs left in the jobqueue?
     
  9. Leftblank

    Leftblank New Member

    There are quite some odd logs available sadly, but most unrelated. Maillog is spammed by the following every few minutes
    Code:
    Sep 4 08:27:51 s1 postfix/error[9418]: 4D09610E94F4: to=, orig_to=, relay=none, delay=139070, delays=139070/0.17/0/0.02, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    System log shows the following every 5 minutes:
    Code:
    Sep 4 08:30:01 s1 pure-ftpd: (?@__1) [INFO] New connection from __1
    Sep 4 08:30:01 s1 pure-ftpd: (?@__1) [INFO] Logout.
    And the ISPC log complained about the php_admin values in the vhosts, which I commented in the template now to be able to start Apache, the search noted that this could be because PHP is not installed, but that's not the case at all sadly.

    Possibly related is the memory usage, it's up to 920MB while nothing is running on the box. Ps aux shows 6+ processes by courier, a whole lot "error -n retry -t unix -u -c" and "bounce -z -n defer -t unix -u -c" running under the postfix user and like 30 times /usr/lib/cgi-bin/php with -d magic_quotes_gpc=off. It seems like clamav and spamd are using the most memory though.
     
    Last edited: Sep 4, 2009
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    To the mail log: amavisd is not running and without amavisd you will not be able to reaceive or send emails. Please run:

    /etc/init.d/amavis start

    and check the mail log again.

    The entry in the system log are fine.

    Then you really dont have mod_php installed and this explains the problems with php in your sites too. Please make sure that you followed the perfect server instllation guide for ispconfig 3 and ubuntu to the line or your system will not work properly.
     
  11. Leftblank

    Leftblank New Member

    Odd, only the 'libapache2-mod-php5' package was missing, all other packages did get installed, I suppose some error came up during install. Anyway, it's working now so thanks a lot.
     
: mod_php

Share This Page