ispconfig think that i'm using apache

Discussion in 'Installation/Configuration' started by stef157, Jan 19, 2017.

  1. stef157

    stef157 Member HowtoForge Supporter

    Hi all,
    I'm currently using ispconfig 3.1.
    When I'm trying to add a new web site nothing is working and I get this kind of error :

    In the server config I see Nginx under the web section.

    Any advise ?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you have the ispconfig apache plugin enabled and not the nginx plugin. The ispconfig installer asked you if apache or nginx shall be used when it finds both binaries on a server, if you say apache there, then the apache and not nginx will be used.
     
  3. stef157

    stef157 Member HowtoForge Supporter

    When I try to update :

    And here you should see the config panel that show NGINX : [​IMG]
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    An update can not change the setting that has been chosen during install. The only way to fix that without reinstalling is that you disable the apache plugin in ispconfig in /usr/local/ispconfig/server/plugins-enabled and enable the nginx plugin instead.
     
  5. stef157

    stef157 Member HowtoForge Supporter

    It's working like a charm.
    Just removed apache module… nginx was already there…

    Thanks !
     

Share This Page