ispconfig stop working

Discussion in 'General' started by vassilis3, Dec 19, 2019.

  1. vassilis3

    vassilis3 Member

    Hi
    I use the icpconfig without much knowledge of Debian without any problems for a long time.
    Today as I was browsing the control panels I suddenly lost everything.
    I noted that I able to received email but there isn't ispconfig web interface and no site running
    I also noticed that apache dosent running
    I try to restart but I reveived the followin message
    Failed to start apache :
    Starting apache2 (via systemctl): apache2.serviceJob for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
    failed!
    I try to update but I facing an other problem
    include_once(../../config.php): failed to open stream: No such file or directory
    any idea?
    Thanks for your time
    Vassilis
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to restart apache again and right after it fails, run:

    journalctl -xn

    and post the result.
     
  3. vassilis3

    vassilis3 Member

    Thanks for quick replay
    [email protected]:/home/diavgia# /etc/init.d/apache2 restart
    [....] Restarting apache2 (via systemctl): apache2.serviceJob for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
    failed!
    [email protected]:/home/diavgia# journalctl -xn
    -- Logs begin at Thu 2019-12-19 12:01:49 EET, end at Thu 2019-12-19 13:20:18 EET. --
    Dec 19 13:20:09 srv.gxxxxxxxxrs.com apache2[7292]: AH00112: Warning: DocumentRoot [/var/www/s-plex.eu/web] does not exist
    Dec 19 13:20:09 srv.gxxxxxxxxrs.com apache2[7292]: AH00543: apache2: bad user name web5
    Dec 19 13:20:09 srv.gxxxxxxxxrs.com apache2[7292]: Action 'configtest' failed.
    Dec 19 13:20:09 srv.gxxxxxxxxrs.com apache2[7292]: The Apache error log may have more information.
    Dec 19 13:20:09 srv.gxxxxxxxxrs.com systemd[1]: apache2.service: control process exited, code=exited status=1
    Dec 19 13:20:09 srv.gxxxxxxxxrs.com systemd[1]: Failed to start LSB: Apache2 web server.
    -- Subject: Unit apache2.service has failed
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit apache2.service has failed.
    --
    -- The result is failed.
    Dec 19 13:20:09 srv.gxxxxxxxxrs.com systemd[1]: Unit apache2.service entered failed state.
    Dec 19 13:20:18 srv.gxxxxxxxxrs.com postfix/smtpd[6573]: connect from static.88-198-98-195.clients.your-server.de[88.198.98.195]
    Dec 19 13:20:18 srv.gxxxxxxxxrs.com postfix/smtpd[6573]: NOQUEUE: reject: RCPT from static.88-198-98-195.clients.your-server.de[88.198.98.195]: 450
    Dec 19 13:20:18 srv.gxxxxxxxxrs.com postfix/smtpd[6573]: disconnect from static.88-198-98-195.clients.your-server.de[88.198.98.195]
    lines 1-18/18 (END)

    -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit apache2.service has failed.
    --
    -- The result is failed.
    Dec 19 13:01:20 srv.gxxxxxxxxrs.com systemd[1]: Unit apache2.service entered failed state.
    lines 1-18/18 (END)
     
    Last edited: Dec 19, 2019
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the symlink for the vhost file of the site s-plex.eu in /etc/apache2/sites-enabled/ and then restart apache. Possible reasons: you removed the website directory manually so the site still exists in ISPConfig or you deleted the site in ispconfig but you used Let's encrypt for that site manually on the shell in the past which duplicated the config file and now causes apache to fail.
     
  5. vassilis3

    vassilis3 Member

    works
    thanks you!
     

Share This Page