ispconfig ssl let's encrypt not issuing certificate

Discussion in 'Installation/Configuration' started by Francesco Galletti, Feb 5, 2020.

  1. Francesco Galletti

    Francesco Galletti New Member

    Hello, we moved the webserver behind firewall and changed ip adress from public ip on the interface to private behind nat, since that moment even if everythings seems working fine we have troubles to issue certificates from the ispconfig 3 control panel, sites select site and select ssl and Let's Encrypt SSL i go back there after 5 minutes and it's unchecked, but if i run from ssh certbot --apache and select website cert issue working perfectly but in ispconfig panel i don't see flag on SSL and Let's Encrypt SSL
    what can i check?
     
  2. Francesco Galletti

    Francesco Galletti New Member

    Fixed.... behind nat server - When your server is behind a NAT router so that the server itself can not reach the hosted domains, then enable the option "Skip Letsencrypt check" under System > Server config > web.
     
  3. Th0m

    Th0m Member HowtoForge Supporter

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I hope you did not used that command in real as it will lock the site so ispconfig can't edit it anymore due to certbots duplication of config files.
     

Share This Page