ISPconfig: ssl.conf certs used instead of the vhost ones

Discussion in 'General' started by ochorocho, Aug 19, 2014.

  1. ochorocho

    ochorocho Member

    Hey ...

    i just noticed that ISPconfig ignores my vhost config for SSL and uses certs defined in ssl.conf

    i have this in my vhosts file:

    <IfModule mod_ssl.c>
    SSLEngine on
    SSLCertificateFile /var/www/clients/client1/web5/ssl/xxx.crt
    SSLCertificateKeyFile /var/www/clients/client1/web5/ssl/xxx.key
    SSLCACertificateFile /var/www/clients/client1/web5/ssl/xxx.bundle
    when i put these certs in ssl.conf file (same paths) it works.

    How can i make sure ISPconfig ist not ignoring certs in the vhosts file?


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Has this vhost file a .err ending?
  3. ochorocho

    ochorocho Member

    there was a file with the .err ending but a normal .vhost of this file as well....

    Thanks Till!

  4. ochorocho

    ochorocho Member

    Hey Till ...

    i removed all occurences of the following settings in ssl.conf:


    is there any side effect i should be aware of?
    in case this is a bug, let me know and i will write a bugreport.

    Thanks till!

    Thanks for making such a nice piece of software.

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    A file with .err ending means that apache did not start with that configuration and ispconfig had to roll back the previous configuration. So thats a normal behaviour to keep your system working and not a bug. I cant say for sure why apache did not restart, this can be a side affect of a manual configuration as well thats resolved now.
  6. ochorocho

    ochorocho Member

    k... i'll keep an eye on this.

    Thanks Till!

  7. ochorocho

    ochorocho Member

    Hey Till,

    thanks... now everything works as expected.
    I cleaned configs again... stopped messing around with the apache configs (!!!!).
    Let ISPconfig generate a new conf.

    ssl.conf is default again and all is good.

    Last edited: Aug 20, 2014

Share This Page